Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 425
  • Last Modified:

Joomla magic quotes

My server has magic quotes turned on, and in my articles all quotes are being preceed with a \ every time i save so  now I have  multiple slashes in front of any quotes.

How should a php.ini file look and where should it be placed to prevent magic quotes from being applied when article and custom html module content is being edited?

I've tried suggestions found in google but don't seem to work.
0
tf2012
Asked:
tf2012
  • 3
1 Solution
 
Ray PaseurCommented:
Who controls the server? This should be turned off immediately by the owner of the server!

Here is the man page link:
http://php.net/manual/en/security.magicquotes.disabling.php

And here is a fuller explanation of what happened and why, historically speaking.
http://www.experts-exchange.com/Web_Development/Web_Languages-Standards/PHP/A_6630-Magic-Quotes-a-bad-idea-from-day-one.html
0
 
Ray PaseurCommented:
Also, this note seems particularly apt:
http://php.net/manual/en/security.magicquotes.disabling.php#82777

HTH, ~Ray
0
 
tf2012Author Commented:
I just sent an email to my client asking for the server admin to turn it off.

thanks!
0
 
Ray PaseurCommented:
Thanks for the points -- I think that's the best way to go.  Best of luck with it, ~Ray
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now