Solved

Remote desktop licensing not available, Server 2012

Posted on 2013-01-21
8
16,518 Views
Last Modified: 2013-09-10
Hey all,

I have a terminal server in Windows Server 2012 that the 120 grace period expired for licenses. I had setup the license server on the same server, it's a domain member/system, and installed the licenses (50). For some reason, on boot, the server has:

The RD Licensing grace period has expired and the service has not registered with a license server with installed licenses. A RD Licensing server is required for continuous operation. A Remote Desktop Session Host server can operate without a license server for 120 days after initial start up.

And it will not allow remote desktop users to connect, stating that their isn't a license server available. I've gone into License manager, verified the server is activated and working. I can ping the license server by the FQDN I'm using.

In licensing diagnosis, it says the server is up, the licenses are available, and it can't find any problems.

When I try to connect a remote desktop I get an event log warning:

The Remote Desktop Session Host server does not have a Remote Desktop license server specified. To specify a license server for the Remote Desktop Session Host server, use the Remote Desktop Session Host Configuration tool.

Funny, because the Remote Desktoop Session Host Config tool doesn't exist in 2012. Argh! Help!
0
Comment
Question by:Secondstreet
8 Comments
 
LVL 56

Expert Comment

by:Cliff Galiher
ID: 38804249
The session host does not find the licensing server automatically, even hen it is on the same install. You must use server manager, edit the session host properties, and poi t it at the licensing server
0
 

Author Comment

by:Secondstreet
ID: 38805369
I've already done that. It is set correctly, I've tried two different licensing servers. I've set this up on other Terminal Services machines without a problem.
0
 
LVL 25

Expert Comment

by:DrDave242
ID: 38806138
I've seen this happen on a 2012 RDSH server, even though it appeared that everything was set up correctly.  I never determined the root cause, but if I recall, configuring licensing via Group Policy worked.  The settings are located at Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Licensing.  Feel free to configure it in the server's local policy if there's only one RDSH server and you don't want to create/modify a GPO.
0
 

Author Comment

by:Secondstreet
ID: 38806265
Unfortunately, I've tried that workaround as well without any luck. Thanks for the suggestion though. I have a case open with Microsoft, I'll post what they say.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 1

Expert Comment

by:doshinheretic
ID: 38910248
I'm going through the same situation currently with Microsoft support.

Is there anything that you could report?


http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2012/Q_28035739.html
0
 
LVL 1

Accepted Solution

by:
doshinheretic earned 500 total points
ID: 38918707
After two days with Microsoft and rebuilding everything three times; The problem that everyone is having is simply a problem with the registry.

If your grace period has expired then you must delete the GracePeriod reg entry in order to get the licensing working again.

computer\hkey_local_machine\system\CurrentControlSet\Control\Terminal Server\RCM\GracePeriod

Delete the REG_BINARY entry that is not the default.

Then try turning it off and on again. After rebooting all of the servers the license server should serve up some deleicious RDP CALs.

If that doesn't do it there are four places that the Licensing server must be specified. In the Deployment Settings in the server manager, The local group policy, the domain policy and in the registry in the RCM folder.
0
 

Author Comment

by:Secondstreet
ID: 38918717
I actually did that in the registry and it didn't fix it. I eventually made a static DNS entry in the hosts file to the license server... and it seemed to fix it. Thanks for the help dosh, all good responses and things to try, to fix.
0
 

Expert Comment

by:Calimour
ID: 39480471
FYI - I have had this happen to me twice with new server 2012 RDS servers where they were configured and showed no errors with licensing. After the 120 days they gave the exact same issues. I had MS fix the one, and this thread helped with the other. I would advise watching any RDS Servers you set up right around the 120 day mark...
0

Featured Post

Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

Join & Write a Comment

Detailed instructions on how to install an Access add-in in recent versions of Office and Windows (with screen shots)
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now