?
Solved

Sharepoint 2010 activate solution disabled even with Farm Admin

Posted on 2013-01-21
10
Medium Priority
?
1,736 Views
Last Modified: 2013-02-05
Hello Experts!

I am having an issue with a SharePoint Server 2010 enviroment I have inherited.  The sandbox is turned on but the activate/deactive buttons for solutions are greyed out, even to Farm Admin accounts.

I did do Google searches and have checked the following :
All servers have the User Code Host service started and running (even tried to restart them).  
Each server has the Sandboxed Code Service started in Central Admin (tried restarting them too).

I try my account, as a Farm Admin, and I can upload a solution (.wsp) but if I don't opt to activate it at the same time as upload, I never can since the activate/deactivate buttons are greyed out.
If I DO opt to Activate it during upload, it shows as activated, but when I go to activate the Feature, I get an access denied!

I've tried this with my farm admin account AND the system account with the same results.

What am I missing is there some other securities the previous SP admins turned on?  Getting the access denied on the system account or on my account as a Farm Admin is a little unsettlingly.

Thanks for any help!
Steph
0
Comment
Question by:Smcglasson
  • 5
  • 3
9 Comments
 
LVL 44

Expert Comment

by:Rainer Jeschor
ID: 38804420
Hi,
can you please share a little bit more info about your farm configuration?
You mentioned the services run on all servers, so which servers do you have in your farm?
Do you use load balancing and if yes, what type of?

Thanks and KR
Rainer
0
 

Author Comment

by:Smcglasson
ID: 38806191
The farm has 3 servers and the database. There is a load balancer in place and from what I understand it was just the add features NLB that was utilized and runs between the 2 servers.  
Looks like CA was started on the 2 servers running the NLB, the 3rd server looks to be used for search query, profile service and web analytics...but it also had Sandboxed Code Service Started and running.

Edit -

I have tried to use powershell to install/enable the solution to see if i would get any errors....(remember, the activate, deactivate and also the delete solution buttons are greyed out for mas as Farm Admin).  

When I tried to Add- SpUserSolution it threw the error that the solution file already exists.  Ok that's fine, I had uploaded it via the UI.

I then ran the Install-SpUserSolution and it also said the it was already activated.  Again, ok it shows as activated in the UI.

If I then move on and try to Enable-SPFeature, it throws the following:

Feature Activation: Failed to ensure feature dependencies for feature '21apps.Aberdovey.SPSolution_AberdoveySiteCollection' (id: '2bcef57b-ab71-4959-b1f9-69243e30a7e7'), exception thrown: System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))    
 at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionModules(SPFeaturePropertyCollection props, SPSite site, SPWeb web, Boolean fForce)    
 at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionElements(SPFeaturePropertyCollection props, SPWebApplication webapp, SPSite site, SPWeb web, Boolean fForce)    
 at Microsoft.SharePoint.SPFeature.Activate(SPSite siteParent, SPWeb webParent, SPFeaturePropertyCollection props, Boolean fForce)    
 at Microsoft.SharePoint.SPFeatureCollection.AddInternal(SPFeatureDefinition featdef, Version version, SPFeaturePropertyCollection properties, Boolean force, Boolean fMarkOnly)    
 at Microsoft.SharePoint.SPFeatureCollection.CheckSameScopeDependency(SPFeatureDefinition featdefDependant, SPFeatureDependency featdep, SPFeatureDefinition featdefDependency, Boolean fActivateHidden, Boolean fUpgrade, Boolean fForce, Boolean fMarkOnly)    
 at Microsoft.SharePoint.SPFeatureCollection.CheckFeatureDependency(SPFeatureDefinition featdefDependant, SPFeatureDependency featdep, Boolean fActivateHidden, Boolean fUpgrade, Boolean fForce, Boolean fMarkOnly, FailureReason& errType)    
 at Microsoft.SharePoint.SPFeatureCollection.CheckFeatureDependencies(SPFeatureDefinition featdef, Boolean fActivateHidden, Boolean fUpgrade, Boolean fForce, Boolean fThrowError, Boolean fMarkOnly, List`1& missingFeatures)    
 at Microsoft.SharePoint.SPFeatureCollection.CheckFeatureDependencies(SPFeatureDefinition featdef, Boolean fActivateHidden, Boolean fUpgrade, Boolean fForce, Boolean fMarkOnly)    
 at Microsoft.SharePoint.SPFeatureCollection.AddInternal(SPFeatureDefinition featdef, Version version, SPFeaturePropertyCollection properties, Boolean force, Boolean fMarkOnly)

Even if I try to use the Uninstall-SPUserSolution I get
Uninstall-SPUserSolution : Cannot find an SPUserSolution object with Name : 2bc
ef57b-ab71-4959-b1f9-69243e30a7e7.
At line:1 char:25
+ Uninstall-SPUserSolution <<<<  -Identity 2bcef57b-ab71-4959-b1f9-69243e30a7e7
    + CategoryInfo          : InvalidData: (Microsoft.Share...allUserSolution:
   SPCmdletUninstallUserSolution) [Uninstall-SPUserSolution], SPCmdletPipeBin
  dException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletUninstal
   lUserSolution

I'm just lost as to what in the world was changed in this farm that is causing these issues.
0
 

Author Comment

by:Smcglasson
ID: 38831351
Can anyone offer any insight into this issue of mine?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 38838402
Have you tried turn Sandbox solutions off in Central Admin?  Were these solutions written as sandbox solutions?
0
 

Author Comment

by:Smcglasson
ID: 38839533
Yes, the solutions were written as sandbox solutions (3rd party product bought by department).

I'm just more wondering if there is some setting, or something that could have been editted to throw an access denied for farm admins and to grey out the options to Activate and Deactivate solutions for farm admins.
Or could this be a problem that came about when they did the upgrade from SP Server 2007 to SP Server 2010?
0
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 38842600
Ooh, this definitely could be an upgrade problem.  I attended a by invitation SharePoint 2010 Deep Dive at Microsoft back in June 2010.  One key thing told to me by their product team was the upgrade was actually only designed for the installation of SharePoint with Small Business Server.  They strongly recommended against the inplace upgrade for any other farms however people still do it and sadly the MSDN documentation contradicts the product team.

Have you tried turning off the SandBox solution service?
0
 

Author Comment

by:Smcglasson
ID: 38844637
I tried turning them off and back on - same thing happened.  I may just have to chalk this up as an issue stemming from the in-place upgrade.
0
 
LVL 51

Accepted Solution

by:
Ted Bouskill earned 1500 total points
ID: 38846007
Based on your last comment I concur.  I think it's an issue with the upgrade.
0
 

Author Comment

by:Smcglasson
ID: 38855494
Thanks for you help all!
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For SharePoint sites, particularly public-facing ones, there are times when adding JavaScript, Meta Tags, CSS Styles or other content to the page <head> section is more practical than modifying master pages.  For instance, you could add the jQuery l…
SharePoint Designer 2010 has tools and commands to do everything that can be done with web parts in the browser, and then some – except uploading a web part straight into a page that is edited in SPD. So, can it be done? Scenario For a recent pr…
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…
How can you see what you are working on when you want to see it while you to save a copy? Add a "Save As" icon to the Quick Access Toolbar, or QAT. That way, when you save a copy of a query, form, report, or other object you are modifying, you…

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question