Solved

Asp.NET Crystal Report Blob field not displaying SQL Db image when deploying to server

Posted on 2013-01-21
8
1,087 Views
Last Modified: 2013-02-14
Dear All,

Reports on my web application is created using Crystal Reports. On each report I have a Blob field to display logo of a client which is stored in SQL Database. The image store on database is of type JPG

The report displays image when running in Visual Studio environment, but deploying to local server or even to the Shared Hosting solution, it is not displaying any report.
0
Comment
Question by:Marsh-Narewec
  • 4
  • 4
8 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 38804093
Is there any error?

What did you deploy to the local server or the Shared Host?

mlmcc
0
 

Author Comment

by:Marsh-Narewec
ID: 38804097
There was no error. The image is not showing. It only shows the missing image icon.

I publish the website to local server and shared hosting. In both cases, they are using the same database.
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 38804107
What version of Crystal?

mlmcc
0
 

Author Comment

by:Marsh-Narewec
ID: 38804116
Crystal Reports for VS 2010 (.NET 4 Framework)
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:Marsh-Narewec
ID: 38813012
Most Forums I search said to include the below statement in web.config file which I did but still there is that issue
 
<httpHandlers>
      <add path="CrystalImageHandler.aspx" verb="GET" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/>
    </httpHandlers>
   

Open in new window


Anyone ??
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 38817049
Did you install the Crystal 4 VS2010 runtimes on the servers?

mlmcc
0
 

Author Comment

by:Marsh-Narewec
ID: 38837057
Yes I did.
0
 
LVL 100

Accepted Solution

by:
mlmcc earned 500 total points
ID: 38837937
The only thing I can think of is that you are still missing some Crystal assemblis or dlls on the servers.  Which ones I couldn't say or even really begin to guess.

mlmcc
0

Featured Post

Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

Join & Write a Comment

Suggested Solutions

Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
SQL Server engine let you use a Windows account or a SQL Server account to connect to a SQL Server instance. This can be configured immediatly during the SQL Server installation or after in the Server Authentication section in the Server properties …
This video discusses moving either the default database or any database to a new volume.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now