Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

No binding for SSL on default web site

Posted on 2013-01-22
3
Medium Priority
?
1,638 Views
Last Modified: 2016-10-11
When running Windows best practice analyser it keeps reporting  “No binding for SSL on default Web Site”. I have checked the bindings and tried to add a new https binding as per the instructions on best practice analyser. However, it tells me that the “specified port is being used by a different binding” although I have tried selecting each certificate.
0
Comment
Question by:paulmac110
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 5

Accepted Solution

by:
Harsem earned 2000 total points
ID: 38804614
Hello,

it sounds like you already have another site that uses the Port that you are trying to use for that site. If this is SSL then most likely you are trying to use Port 443.

Can you confirm if this web server is already hosting another site, and if this is already using that port. You cannot have 2 sites sharing the same port.

If you need to create a second site with the SSL certificate you only have 2 options:
- create the binding on another port (such as 9443 or 444)
   This tends not to be doine as this is a non-standard port and most firewalls will block this communication.
- Give this server a second IP address (it can be on the same subnet with the same default gateway) and bind the site to this new IP address on port 443.

Please note however that with option 2 above you need to change your site binding away from the default "*" in the Ip address to the actual IP address of an interface.

If you continue to struggle with this can I ask for print-screens of the IIS config on that server.

Hope this helps

Jens
0
 
LVL 14

Expert Comment

by:BlueCompute
ID: 38804914
Is this an SBS server?  If so the https 443 binding is on the SBS Web Applications site rather than the default website.
0
 
LVL 1

Expert Comment

by:Ben Keyser
ID: 41838134
If I can reopen this question - I have a 4 box-standard SBS 2011 installations. All giving this error/issue. I checked all the sites and ONLY the default sites use 443. Also, the bindings on all the sites are the same, and as I mentioned these are out of the box installations. So, any ideas why the analyser keeps on kicking out this response?

The discussions above does not really seem to present a solution (in my case anyway)

Ben
0

Featured Post

Looking for the Wi-Fi vendor that's right for you?

We know how difficult it can be to evaluate Wi-Fi vendors, so we created this helpful Wi-Fi Buyer's Guide to help you find the Wi-Fi vendor that's right for your business! Download the guide and get started on our checklist today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We take a look at some of the most common obstacles that IT teams run into as they work relentlessly to keep all the alarms and sirens from going off at once.
Tech spooks aren't just for those who are tech savvy, it also happens to those of us running a business. Check out the top tech spooks for business owners.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question