Solved

offline address book in outlook 2010 not updating

Posted on 2013-01-22
29
2,636 Views
Last Modified: 2013-01-23
Hi experts,

Our offline address book in outlook 2010 / Exchange 2010 is not updating for the default global address list. We have recently added some new users with mailboxes and these new users are not appearing the address book.

If I try to do a manual download of the address book in outlook I get the following error message on any client computer:
Task 'Kevin@companydomain.co.uk' reported error (0x8004010F) : 'The operation failed. An object cannot be found.'

If I disable cached exchange mode on my outlook profile then I can see all of the address contacts fine. We quite recently migrated from SBS 2003 to server 2008 R2 & Exchange 2010 so I’m thinking perhaps the issue is related to this in some way.

Any ideas how to fix this?
0
Comment
Question by:kevin1983
  • 17
  • 7
  • 4
  • +1
29 Comments
 
LVL 1

Expert Comment

by:James Powell
ID: 38804987
Sounds like a replication issue.
How long ago were the new users created?

Check this link

for more info to see if Exchange is pointing to the proper location of AD
0
 
LVL 1

Expert Comment

by:George-
ID: 38804990
Hi

Have you tried to update the GAL from Exchange PowerShell?

[PS] C:\>Update-GlobalAddressList -Id "Default Global Address List"
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38804997
Since the migration did you upgrade the OAB to point to Exchange 2010 servers ?
What if you update the OAB in EMC ?

- Rancy
0
 

Author Comment

by:kevin1983
ID: 38805006
The users were created recently  - last Friday.

I just tried to run this cammand: [PS] C:\>Update-GlobalAddressList -Id "Default Global Address List"

and i got a number of warnings such as:
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Relaunch Sept 2003 84778277" is invalid and
couldn't be updated.
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Requote 2005" is invalid and couldn't be
updated.

In Active directory users and computers theres a folder named: "Microsoft Exchange System Objects" which appears to have these objects in them. and they are all Public folder type, but we dont use public folders anymore. Maybe this is related to the issue?, perhaps they should be removed if possible?
0
 

Author Comment

by:kevin1983
ID: 38805025
Rancy -  Since the migration did you upgrade the OAB to point to Exchange 2010 servers ?

No I dont think we did this, we used the SBS 2003 to server 2008 + Exchange 2010 migration guide in Experts exchange and dont rememeber seeing info about this step unless this was over looked. How do we do this?

What if you update the OAB in EMC ?
I can try doing this, or is it best to check to see if the correct servers are pointed in OAB first?
0
 
LVL 1

Expert Comment

by:George-
ID: 38805031
Open the EMC 2010 and browse to the Toolbox, pick the Public Folder Management console. In the tree navigate to System Public Folders > OFFLINE ADDRESS BOOK. In the window pane right-click and go to the properties of your OAB causing the errors. Choose the Exchange General tab and remove any " " (spaces) from the Alias. Save your changes and try to run "Get-GlobalAddressList | Update-GlobalAddressList" again.

It may take a minute for the change to get noticed in the EMS.
0
 

Author Comment

by:kevin1983
ID: 38805042
George -
Ok i looked where you suggested. Doesn't appear to be any spaces, currently the name says:
does this look ok?

/o=companydomain/cn=addrlists/cn=oabs/cn=Default Offline Address List
0
 

Author Comment

by:kevin1983
ID: 38805048
Just a thought - would user permissions on the area where georoge suggested cause this type of error?, on the permission tab there is just 2 users: anonoymous - no permissions and default which has read items and visible only
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38805051
In EMC you can go to properties of the OAB and ensure its showing the Exchange 2010 server as generation server

What is the Distribution type set ?
What is the Outlook client version affected ? do we have any Outlook 2003 ?
Do we have PF database ?

- Rancy
0
 

Author Comment

by:kevin1983
ID: 38805057
I just tried to update the OAB in EMC  as Rancy suggested and I got this error:
--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Action 'Update' could not be performed on object 'Default Offline Address List'.

Default Offline Address List
Failed
Error:
Exchange server "Public Folder Database 1759832846" was not found. Please make sure you typed the name correctly.

--------------------------------------------------------
OK
--------------------------------------------------------
0
 

Author Comment

by:kevin1983
ID: 38805075
Our Public folder appears to be present, although theres no database copies showing in the bottom window (see attached screenshot), maybe theres an error with the public database?
Public-Folder.jpg
0
 

Author Comment

by:kevin1983
ID: 38805083
Rancy -
The generation server says "Public Folder Database 1759832846"
The distribution mechanism is "Public Folders"
Looks like we have a PF database and says its mounted.

All our clients are running outlook 2010, however i can probably
insatall outlook 2003 on a test machine to see if it has
the same issue.

We dont use public folders, can the OAB be distributed using a different method?
0
 
LVL 1

Expert Comment

by:George-
ID: 38805097
Alias should look like this:
OfflineAddressBook-/o=domainname/cn=addrlists/cn=oabs/cn=Defa

Are you looking at the "Exchange General" tab?

You need to check every entry for the OAB causing the errors.
0
 

Author Comment

by:kevin1983
ID: 38805116
George - yes looking on the "General" tab. I cant find anything that's in the alias format example you have provided, unless i am looking in wrong place

(I can't see a tab named "Exchange General" )
0
 
LVL 52

Accepted Solution

by:
Manpreet SIngh Khatra earned 500 total points
ID: 38805159
Generation server should be the server name "Cobra" ... DIstribution should be PF and Web :)

- Rancy
0
 

Author Comment

by:kevin1983
ID: 38805174
Rancy - ok so the generation server is incorrect, How do I amend this to be the actual Exchange server name i.e Corba?

I cant find where I can amend. I wonder why its currently set to public folder
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38805418
You should be able to ammend it in Offline Address Book in EMC

- Rancy
0
 

Author Comment

by:kevin1983
ID: 38805496
Ok, ive found how to move to a different generation server: http://technet.microsoft.com/en-us/library/bb125184(v=exchg.141).aspx
0
 

Author Comment

by:kevin1983
ID: 38805527
OK, ive moved the generation server for the OAB to Cobra.
I got the below message.
At the moment i'm still getting same issue on client computers but I guess thats probably because the changes take time to move /replicate. Is there a way of refreshing the move/changes quicker?


Summary: 1 item(s). 1 succeeded, 0 failed.
Elapsed time: 00:00:00


Default Offline Address List
Completed

Warning:
The server from which this offline address book is being moved, "Public Folder Database 1759832846", no longer exists in Active Directory.  The OAB will be moved, but this will lead to a full OAB download for all users who are provisioned to use this OAB.  If public folder distribution was enabled, the older replica will be removed from the public folder.  Also, some OAB settings may be changed during the move.  Please examine the OAB after it has been moved and verify the settings.

Exchange Management Shell command completed:
move-OfflineAddressBook -Identity '\Default Offline Address List' -Server 'COBRA'

Elapsed Time: 00:00:00
0
 

Author Comment

by:kevin1983
ID: 38809075
Hi Experts,

I'm still getting the same issue after moving the OAB generation server. Updating the OAB directly on the Exchange server now seems to work ok without an error but client computers are still not seeing the new user's mailbox in the OAB and trying to manually download the OAB in outlook still shows the same error message.

Any other suggestions?
0
 
LVL 1

Expert Comment

by:George-
ID: 38809278
Does;
[PS] C:\>Update-GlobalAddressList -Id "Default Global Address List"
Come back with no errors now?
0
 

Author Comment

by:kevin1983
ID: 38809313
No same errors as before:
Looks like they refer to an objects folder in active directory users and computers
from old folders we had in the public folder. See attached screenshot


WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Relaunch Sept 2003 84778277" is invalid and
couldn't be updated.
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Requote 2005" is invalid and couldn't be
updated.
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Requote 2005 97345752" is invalid and
couldn't be updated.
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Run outs 47636143" is invalid and couldn't be
 updated.
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Sample Requests 05475830" is invalid and
couldn't be updated.
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Schedule+ Free Busy Information - first
administrative group" is invalid and couldn't be updated.
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Seriously Fresh 07987757" is invalid and
couldn't be updated.
WARNING: The recipient "companydomain.local/Microsoft Exchange System Objects/Smartprice Relaunch 78357899" is invalid and
ADUsersandComp.jpg
0
 
LVL 1

Expert Comment

by:George-
ID: 38809335
Go into EMC>Toolbox>Public Folder Management Console.
You need to go down the list in the left hand pane and find the entries listed above but so they are shown in the centre pain.  
Right click the entries in the middle pane and go to properties and you will see "Exchange General" and check the Aliases have no spaces.
0
 

Author Comment

by:kevin1983
ID: 38809366
I could delete any folders within public folders as there not needed anymore, would this be suitable instead?

Theres just 2 main top level folders but a number of subfolders / items within these

otherwise do you mean the "General" tab within properties?, I don't see a tab named "Exchange General", so far i cant seen any names that have spaces. Is the spaces in any part of the name that might be the issue or only if there's a space at the front?
0
 
LVL 1

Expert Comment

by:George-
ID: 38809392
Dont know about deleting the public folders.

If you were doing OAB 2 you would select:
Public Folders>System Public Folders>OFFLINE ADDRESS BOOK>/o=domainname/cn=addrlists/cn=oabs/cn=Default Offline Address List

THEN select "OAB Version 2" in the centre pain>right click>properties>"Exchange General"tab.


Its the "Alias" that can't have spaces in Exchange 2010.
0
 

Author Comment

by:kevin1983
ID: 38809466
Ok, I think ive found the area where you mean, but I still don't see a tab named "Exchange general" or an Alias name.

Is the area that ive marked in red on the attached screenshot the alias name?.
Does this need to be change to "OABVersion2"

does the same need to be done for version 3a and 4?
Is there a reason for different versions?
PFConsole.jpg
0
 
LVL 1

Expert Comment

by:George-
ID: 38809567
That looks wrong, please see attached.

You need to look at the aliases for the entries that error when running [PS] C:\>Update-GlobalAddressList -Id "Default Global Address List"

It may be worth asking another question regarding thoses errors as i think you need that fixed before your Offline Address Book will work.
OABVersion2.png
0
 

Author Comment

by:kevin1983
ID: 38809763
George - Thats strange unless your running a more up to date version of exchange 2010 that has more options / more tabs, still cant see an exchange general tab or allias name field. Unless theres a more detailed view somewhere but so far cant find any options for this.

ok, as you've suggested Ive created a new question here: http://www.experts-exchange.com/Software/Server_Software/File_Servers/Active_Directory/Q_28005521.html
0
 

Author Closing Comment

by:kevin1983
ID: 38810786
Thanks all for your help
0

Join & Write a Comment

Suggested Solutions

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Is your Office 365 signature not working the way you want it to? Are signature updates taking up too much of your time? Let's run through the most common problems that an IT administrator can encounter when dealing with Office 365 email signatures.
This video discusses moving either the default database or any database to a new volume.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now