• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3694
  • Last Modified:

Unable to get plugins to work in AutoCAD 2013 LT

I hav downloaded the SketchUp plugin but cannot get it to load.  After installing the .msi and launching AutoCAD LT 2013 nothing appears int he plugin tab.  

Some help pages advised to check the APPAUTOLOAD system variable but this variable does not appear in the list I see when I type setvar ? in the command screen.
0
canuckconsulting
Asked:
canuckconsulting
  • 7
  • 6
1 Solution
 
silverkornCommented:
Which plugin specifically are you trying to install, there are many to choose from and knowing which one isn't working could help me diagnose the problem.

Also the APPAUTOLOAD can be set by simply running the command APPAUTOLOAD from the command line. More info about the APPAUTOLOAD system variable can be found here:

http://docs.autodesk.com/ACD/2013/ENU/files/GUID-33E75B9A-93AC-4FBF-B941-0F99A6AC3617.htm 

Additionally, if you are trying to simply import SketchUp files into AutoCAD you could check out the SketchUp Import App that Autodesk developed:

http://apps.exchange.autodesk.com/ACD/Detail/Index?id=appstore.exchange.autodesk.com%3asketchupimport%3aen
0
 
canuckconsultingAuthor Commented:
Hi, that application you linked to is what I am trying to get to run.  I thought it was a plugin (not an app).
0
 
canuckconsultingAuthor Commented:
Also if I type APPAUTOLOAD into the command line I get:

Command: APPAUTOLOAD Unknown command "APPAUTOLOAD"
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
silverkornCommented:
run the command MENULOAD and see if the SKETCHUPIMPORT is listed under "Loaded Customization Groups:"

If not you can click the Browse button on the bottom of that window, "Load/Unload Customizations" and browse to the SketchUpImport.cuix file. This file can be found here for Windows 7:
C:\Users\[username]\AppData\Roaming\Autodesk\[autocad product]\enu\Support\

If all else fails, simply re-run the install msi file and remove the plugin and re-install it. Be sure to have AutoCAD closed out when running the install msi file
0
 
canuckconsultingAuthor Commented:
Just did a uninstall /reinstall with autocad closed with no difference.

Running MENULOAD shows the following loaded customization groups:

ACADLTCONTENTEXPLORER

I can browse but do not see the ciux file there.  I do see a mess of them (one for each language) under C:\Users\ukcra.del.sgoodwin\AppData\Roaming\Autodesk\ApplicationPlugins\Autodesk SketchUp Import.bundle\Contents\Resources\  Has something gone wrong with the install.

In case it matters I am using W7 x64 logged in as local admin.
0
 
silverkornCommented:
It seems to been able to install the program, so now I am thinking it might not be compatible with AutoCAD LT.

To verify you could contact customer support: AutoCAD.apps@autodesk.com

also as a check you could try and select the .cuix file from the MENULOAD application window to see if the program will accept the plugin
0
 
canuckconsultingAuthor Commented:
When I browse to the ciux file and load it the plug-ins do appear onthe tool bar.  However click thing the icons gives the error _IMPORTSKP Unknown command "IMPORTSKP".
0
 
silverkornCommented:
run the command OPTIONS within AutoCAD, under the "files" tab expand the "Support File Search Path" and click the add button on the right. Then click the browse button on the right and the path:
C:\Users\ukcra.del.sgoodwin\AppData\Roaming\Autodesk\ApplicationPlugins\Autodesk SketchUp Import.bundle\Contents\Resources
0
 
canuckconsultingAuthor Commented:
No luck I'm afraid.  Shame as we could really use getting these files into AutoCAD.
0
 
silverkornCommented:
one last thing to try is to load the .arx file manually by running the command APPLOAD within AutoCAD. then browse to the following location:
C:\Users\ukcra.del.sgoodwin\AppData\Roaming\Autodesk\ApplicationPlugins\Autodesk SketchUp Import.bundle\Contents\Win64\ and select the AcSketchUp.arx file. Make sure to select the correct Win folder depending on the software version you are using, Win32 for 32-bit version of AutoCAD LT. Once you have selected the file click the Load button. Then try running the plugin again

If this work you can go back into the APPLOAD window and add the .arx file into the Startup Suite in the lower right of the window. This will then autoload the arx file everytime AutoCAD is run.
0
 
canuckconsultingAuthor Commented:
I get:
Command: appload
Unknown command "APPLOAD".

Are these commands case sensitve?
0
 
silverkornCommented:
Then you are in fact using AutoCAD LT, which does not support the use of LISP or ARX. In order to have the plugin work you would need the full version of AutoCAD.

as an alternate you can use SketchUp to export skp files into a DWG/DXF format file which can be opened within AutoCAD
0
 
canuckconsultingAuthor Commented:
Thanks for help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now