Droid Email sync/push problem

I have a client with Windows Small Business server 2003. The users just switched from Blackberries to Android phones. I got them all synced up and thought it was working but it only downloads mail when you hit refresh or whatever the button for send/receive is on the phones it won't push. I have a different droid that I use with my email on a different server and added an account from their server to it and I get the same thing. it works but only when I remember to hit the refresh. If I don't nothing comes in. So I don't believe its the phone or cell network but maybe something on their server. Does anyone know what to check?
LVL 2
Axis52401Security AnalystAsked:
Who is Participating?
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Please add the registry key Reserved Ports listed in the following article and then restart the DNS Server service:

http://support.microsoft.com/kb/956189

Then test your phones.

Alan
0
 
James PowellData Analyst / Online Retail DevelopmentCommented:
http://helpdesk.illinoisstate.edu/kb/1646/Configuring_Android_for_Exchange/


check under number 8 within this article.

Under account options, you need to set to "automatic".
0
 
Axis52401Security AnalystAuthor Commented:
I don't know about their phones but on mine it doesn't have those exact settings. There is a sync schedule for Peak and off peak schedule and on mine both are set to push
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Alan HardistyCo-OwnerCommented:
Could be Anti-Virus interference or incorrect IIS settings.

What (if any) AV is installed on the server?

Please run through my article and check your settings:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
 
Axis52401Security AnalystAuthor Commented:
I checked your website and the only thing I found that didn't match was


Exchange 2003 (Part of Small Business Server):

Exchange Virtual Directory
•      Authentication = Integrated & Basic   (m ine was set to just basic so I changed it)
•      Default Domain = NetBIOS domain name - e.g., yourcompany*
•      Realm = yourcompany.com
•      IP Address Restrictions = Granted Access
•      Secure Communications = Require SSL IS ticked (very important)

I do see this error in the event viewer
Product:      Exchange
Event ID:      3024
Source:      Server ActiveSync
Version:      6.5.7638.0
Component:      Microsoft Exchange ActiveSync
Message:      IP-based AUTD failed to initialize. Error code: [0x80004005].
0
 
Axis52401Security AnalystAuthor Commented:
Now I'm getting this error

      IP-based AUTD failed to initialize because the processing of notifications could not be setup. Error code 0x80004005>]. Verify that no other applications are currently bound to UDP port [<2883>], or try specifying a different port number.
0
 
Alan HardistyCo-OwnerCommented:
Did you restart the DNS server service?  If you did, please reboot the server, otherwise restart the service please.

Alan
0
 
Axis52401Security AnalystAuthor Commented:
I did restart the service. I'll have to wait till tonight to do a full reboot. I'll try that and post back
0
 
Alan HardistyCo-OwnerCommented:
No problems. I'm about for another 5 hours approx if you need me.

Alan
0
 
Alan HardistyCo-OwnerCommented:
How is the server looking today?  Did you get it rebooted?

Alan
0
 
Axis52401Security AnalystAuthor Commented:
Not yet the owner wants to do it himself and he hasn't done it yet, they are a tax accounting firm and are pretty busy and he hasn't wanted to shut it down.
0
 
Alan HardistyCo-OwnerCommented:
No problems - shout as and when you have managed to get it rebooted.

Alan
0
 
Axis52401Security AnalystAuthor Commented:
Sorry for the delay took a while to get the reboot cleared. it seemed to fix the push problem only now its not deleting the messages from the inbox when they are deleted off the phone.
0
 
Alan HardistyCo-OwnerCommented:
Okay - if you delete an email via OWA from the Inbox, does it get deleted from Outlook and/or the iPhone?
0
 
Axis52401Security AnalystAuthor Commented:
Yes
0
 
Axis52401Security AnalystAuthor Commented:
Turned out this users new phone had an option to syn the Trash or deleted items and it wasn't set to sync. I turned that on and now it seems to be working
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.