How to work with ActionScript 2.0 in Adobe Flash CS5

I have a project that I am trying to deploy in Adobe Flash CS5 as an Adobe Air project as an Adobe Actionscript 2.0 compatible project since it was written in Adobe ActionScript 2.0.  If I try to deploy it now, I get an error that something is not supported in ActionScript 3.0.  How do I change which ActionScript my project is referencing?
Who is Participating?
CyanBlueConnect With a Mentor Commented:
You could write a new AIR project in AS3 which loads your AS2 SWF into it with Loader class. Yes you cannot develop any further but you can at least convert it as an AIR product as in deployable product and yes whatever you do from this point, you probably need to pick up AS3 skill.

quizengineConnect With a Mentor Commented:
Unfortunately Adobe AIR only works with Actionscript 3.0
quizengineConnect With a Mentor Commented:
Your project would need to be rewritten in AS3 - there is no AS2 engine in AIR
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.