Solved

Joomla Search Engine Friendly URL's No Longer Working

Posted on 2013-01-22
5
567 Views
Last Modified: 2013-01-24
Hello,

I recently moved my Joomla 2.5 website from a development directory to the root and when I did, the Search Engine Friendly URL's feature stopped working.

For instance, this link will work:
http://www.ourcountryhearts.com/index.php?option=com_content&view=article&id=3&Itemid=103
But this one will not:
http://www.ourcountryhearts.com/location

The second one is preferrable and USED TO WORK, but doesn't since the migration.

I've set Search Engine Friendly URLs to NO and it works, but when I switch it back to YES, it stops working again.

I fear something happened to my htaccess file, but I'm not sure what to do about it.  Can you help me make Search Engine Friendly URL's work again?
THANKS,
Jason
0
Comment
Question by:SqueezeOJ
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 12

Assisted Solution

by:duttcom
duttcom earned 250 total points
ID: 38807749
If you go to Extensions -> Plug-In Manager and go to the last page, is the "System - SEF" plugin enabled?
0
 
LVL 4

Accepted Solution

by:
webtechgal earned 250 total points
ID: 38807820
I have had the same thing happen to me when moving sites. I use Akeeba Backup (awesome product!) to roll it up and Kickstart to get it back out again. I have noticed that it does not seem to roll out the correct contents in the .htaccess file. I looked at the .htaccess file in the new location and it did not have any of the contents of the old file.

So, I would first try to either copy your old .htaccess file to the new location. If that doesn't work just create a new .htaccess file.

Creating a new .htaccess file is as simple as grabbing the htaccess.txt file and renaming it .htaccess and uploading it back to your directory.

Hope this helps. :)
0
 

Author Comment

by:SqueezeOJ
ID: 38811781
Duttcom:  Unfortunately, System SEF is Enabled.  But it was a good thought.

WebTechGal: I'm going to follow your htaccess idea next.  I will report back.

Thanks to both of you for your advice.
0
 

Author Closing Comment

by:SqueezeOJ
ID: 38815407
Didn't actually end up using either solution.  After waiting a night I tried checking the "Enable SEF URLs" checkbox again and THIS TIME it's working.  I have no idea why, but I'm happy it does.

Thanks to both of you for your suggestions.  They may help others in the future.
0
 
LVL 4

Expert Comment

by:webtechgal
ID: 38817526
It is generally suggested to clear the cache and your browser after making global config changes. Assuming you did a new browser session the next day, you cleared your browser at least.

Thanks for the points!
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
Introduction This article is intended for those who are new to PHP error handling (https://www.experts-exchange.com/articles/11769/And-by-the-way-I-am-New-to-PHP.html).  It addresses one of the most common problems that plague beginning PHP develop…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question