Solved

The SQL Server instance specified in SSIS service configuration is not present or is not available.

Posted on 2013-01-23
5
2,518 Views
Last Modified: 2016-02-10
Hi,

I am getting the below error while trying to access MSDB folder from SSIS.

-----------------------------------------------------------------------------------------------------------------------------
Failed to retrieve data for this request. (Microsoft.SqlServer.Management.Sdk.Sfc)

The SQL Server instance specified in SSIS service configuration is not present or is not available. This might occur when there is no default instance of SQL Server on the computer. For more information, see the topic "Configuring the Integration Services Service" in SQL Server 2008 R2 Books Online.

Login failed for user 'DSERVER\ke'. (MsDtsSrvr)

Login failed for user 'DSERVER\ke'. (Microsoft SQL Server Native Client 10.0)
-----------------------------------------------------------------------------------------------------------------------------

<?xml version="1.0" encoding="utf-8"?>
<DtsServiceConfiguration xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <StopExecutingPackagesOnShutdown>true</StopExecutingPackagesOnShutdown>
  <TopLevelFolders>
    <Folder xsi:type="SqlServerFolder">
      <Name>MSDB</Name>
      <ServerName>192.168.0.1,60428</ServerName>
    </Folder>
    <Folder xsi:type="FileSystemFolder">
      <Name>File System</Name>
      <StorePath>..\Packages</StorePath>
    </Folder>
  </TopLevelFolders>  
</DtsServiceConfiguration>
-----------------------------------------------------------------------------------------------------------------------------

Environment -
The server operating system is Server 2008 Standard Edition.
SQL SErver 2008 R2 Standard Edition
There are 3 instances of SQL 2008 on the server
There are 2 instances of SQL 2005 on the server

Tried the following -
Disabled Windows firewall completely.
Added the user DSERVER\KE to MSDB security and assigned all roles to it.
Server name in configuration file set as  192.168.0.1,60428
Server name in configuration file set as  DS\DEV2008
Server name in configuration file set as  \\.\pipe\SQLLocal\DEV2008
0
Comment
Question by:shaileshmonani
5 Comments
 
LVL 142

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 38808895
0
 

Author Comment

by:shaileshmonani
ID: 38809054
Thanks AngelIII,

Checked the link, it is very elaborate on SQL Database but not much is mentioned about SSIS.

Ketan.
0
 
LVL 10

Expert Comment

by:Monica P
ID: 38809388
Hi

by default ., a Instance with 1433 port assigned will be accessed outside..Try to set the sqlserver listening port to your instance

or

if you need to set Specific port

In SQL Server Configuration Manager>SQL Server 2005 Network Configuration>Protocols for "instance name", then
select TCP/IP, then take IP Address tab.
Under IPAll or (IP1/IP2 which ever is ur IP)> TCP Dynamic Ports delete '0' and
TCP Port <your port>.
Then restart sql server service from services.msc.
Now it will work on your port.
Also you can check whether your port is listening or not by using telnet to the port.


Way to Connect to Default or named instance

If you connect to a Named Instance, then you need to either specify the Server\Instance or Server,Port.
If you change the default port number for the default instance, then you need to specify Port number as well.
0
 
LVL 24

Accepted Solution

by:
DBAduck - Ben Miller earned 250 total points
ID: 38809874
The simple start is to ensure that you can connect to the SQL Server instance that you are specifying in the SSIS configuration file.

If you can open SSMS and connect to 192.168.0.1,60428 then you are almost there. If you cannot, then you need to ensure that you get a connection using your options.  Remember that you may not get a connection because SQL Browser is not running if you are using Dynamic Ports, or that you have multiple instances on that machine listening on that same IP, but different ports, etc.

But the second piece, is what privileges does the user KE have?  Is this user account SA, is it a normal user without access to MSDB database?  You must fix this part too.

So you need to pick a specific instance of SQL Server for MSDB and ensure connection, and resolve any permission errors you have with logging in with KE user.
0
 

Author Closing Comment

by:shaileshmonani
ID: 38825657
Thanks DBADUCK,

Sorted out the problem, the issue was because of some wrong settings with my login - Dserver\Ke.

I deleted the login Dserver\Ke which was created earlier, then re-created the same and set the role as sysadmin. After this the login error got resolved and i could connect to msdb folder in integration services.
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

My client sends a request to me that they want me to load data, which will be returned by Web Service APIs, and do some transformation before importing to database. In this article, I will provide an approach to load data with Web Service Task and X…
I have a large data set and a SSIS package. How can I load this file in multi threading?
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.
Viewers will learn how to use the SELECT statement in SQL and will be exposed to the many uses the SELECT statement has.

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now