Solved

Asa 5505 allow ping but not other traffic like remote desktop

Posted on 2013-01-23
9
818 Views
Last Modified: 2013-01-26
Hi,

If I ping from 10.10.25.69 to 192.168.30.32 it works. But remote desktop dosent. Any idears? Seams like Asa is blocking traffic on 3389.

TIA

LHC

Result of the command: "wr t"

: Saved
:
ASA Version 7.2(4)
!
hostname xxx-asa
names
name x.x.237.236 Mail-Server-Outside description SMTP adresse
name 10.10.25.69 mail-server-intern description Perl
name 192.168.0.0 BB
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.25.3 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.237.234 255.255.255.248
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns server-group DefaultDNS
 domain-name xx.co.uk
same-security-traffic permit intra-interface
object-group service DM_INLINE_TCP_1 tcp
 port-object eq imap4
 port-object eq pop3
 port-object eq smtp
 port-object eq ftp
 port-object eq 55555
access-list outside_1_cryptomap extended permit ip 10.10.25.0 255.255.255.0 172.16.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.10.25.0 255.255.255.0 172.16.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 192.168.200.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 172.16.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any BB 255.255.0.0
access-list inside_nat0_outbound extended permit ip BB 255.255.0.0 any
access-list Ciscovpn_splitTunnelAcl standard permit any
access-list Ciscovpn_splitTunnelAcl standard permit 10.10.25.0 255.255.255.0
access-list outside_access_in extended permit tcp any host Mail-Server-Outside object-group DM_INLINE_TCP_1
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool vpnpool 10.15.25.1-10.15.25.100 mask 255.255.255.128
ip local pool vpnpool1 192.168.200.1-192.168.200.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp Mail-Server-Outside ftp 10.10.25.5 ftp netmask 255.255.255.255
static (inside,outside) tcp Mail-Server-Outside smtp mail-server-intern smtp netmask 255.255.255.255
static (inside,outside) tcp Mail-Server-Outside 3389 mail-server-intern 3389 netmask 255.255.255.255
static (inside,outside) tcp Mail-Server-Outside 55555 10.10.25.9 55555 netmask 255.255.255.255
access-group outside_access_in in interface outside
route inside BB 255.255.0.0 10.10.25.1 1
route outside 0.0.0.0 0.0.0.0 x.x.237.233 1
0
Comment
Question by:melfarit
  • 5
  • 4
9 Comments
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 38809360
Looks like a part of the config is missing (?)
0
 

Author Comment

by:melfarit
ID: 38809364
Yes, I removed the last part with the crypto lines to keep it more simple.

LHC
0
 

Author Comment

by:melfarit
ID: 38809381
Hi,

Here the total config, if it helps ?


ASA Version 7.2(4)
!
hostname xxx-asa
names
name x.x.237.236 Mail-Server-Outside description SMTP adresse
name 10.10.25.69 mail-server-intern description Perl
name 192.168.0.0 BB
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.25.3 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.237.234 255.255.255.248
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns server-group DefaultDNS
 domain-name xx.co.uk
same-security-traffic permit intra-interface
object-group service DM_INLINE_TCP_1 tcp
 port-object eq imap4
 port-object eq pop3
 port-object eq smtp
 port-object eq ftp
 port-object eq 55555
access-list outside_1_cryptomap extended permit ip 10.10.25.0 255.255.255.0 172.16.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.10.25.0 255.255.255.0 172.16.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 192.168.200.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 172.16.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any BB 255.255.0.0
access-list inside_nat0_outbound extended permit ip BB 255.255.0.0 any
access-list Ciscovpn_splitTunnelAcl standard permit any
access-list Ciscovpn_splitTunnelAcl standard permit 10.10.25.0 255.255.255.0
access-list outside_access_in extended permit tcp any host Mail-Server-Outside object-group DM_INLINE_TCP_1
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool vpnpool 10.15.25.1-10.15.25.100 mask 255.255.255.128
ip local pool vpnpool1 192.168.200.1-192.168.200.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp Mail-Server-Outside ftp 10.10.25.5 ftp netmask 255.255.255.255
static (inside,outside) tcp Mail-Server-Outside smtp mail-server-intern smtp netmask 255.255.255.255
static (inside,outside) tcp Mail-Server-Outside 3389 mail-server-intern 3389 netmask 255.255.255.255
static (inside,outside) tcp Mail-Server-Outside 55555 10.10.25.9 55555 netmask 255.255.255.255
access-group outside_access_in in interface outside
route inside BB 255.255.0.0 10.10.25.1 1
route outside 0.0.0.0 0.0.0.0 x.x.237.233 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 10.10.25.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
snmp-server host inside 172.16.100.29 community xxx
snmp-server location Serverum hos xxx
snmp-server contact xxxxxxx
snmp-server community xxx
snmp-server enable traps snmp authentication linkup linkdown coldstart
snmp-server enable traps remote-access session-threshold-exceeded
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer x.x.152.20
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.10.25.130-10.10.25.199 inside
dhcpd dns 172.16.100.102 8.8.8.8 interface inside
dhcpd wins 172.16.100.102 interface inside
dhcpd lease 259200 interface inside
dhcpd domain xxxxx.local interface inside
!

group-policy Ciscovpn internal
group-policy Ciscovpn attributes
 wins-server value 10.10.25.50
 dns-server value 10.10.25.50 8.8.8.8
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Ciscovpn_splitTunnelAcl
 default-domain value mhstaal
group-policy xxxvpn internal
group-policy xxxvpn attributes
 wins-server value 172.16.100.102
 dns-server value 172.16.100.102 8.8.8.8
 vpn-tunnel-protocol IPSec
 default-domain value xxx.local
username cxxxxx password xxxxx encrypted
username cxxxxx attributes
 vpn-group-policy xxxvpn
username lxxxx password xxxxxx encrypted privilege 0
username lxxxxx attributes
 vpn-group-policy xxxvpn
username Jxxxxxxxx password xxxxxx encrypted
username Jxxxxxxxx attributes
 vpn-group-policy xxxvpn
tunnel-group x.x.152.20 type ipsec-l2l
tunnel-group x.x.152.20 ipsec-attributes
 pre-shared-key *
tunnel-group Ciscovpn type ipsec-ra
tunnel-group Ciscovpn general-attributes
 address-pool vpnpool1
 default-group-policy Ciscovpn
tunnel-group Ciscovpn ipsec-attributes
 pre-shared-key *
tunnel-group xxxvpn type ipsec-ra
tunnel-group xxxvpn general-attributes
 address-pool vpnpool1
 default-group-policy xxxvpn
tunnel-group xxxvpn ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map asa_global_fw_policy
 class inspection_default
  inspect ftp
  inspect pptp
!
service-policy asa_global_fw_policy global
prompt hostname context
Cryptochecksum:xxxxxxxxxxxxxxxxxxxx
: end
[OK]
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 38809535
Looking good (at first glance).
When you look at the (ASDM) logs, does anything show when trying to do RDP?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:melfarit
ID: 38809545
Hi Ernie!

No thats the strange thing, no error. But if I change to use default gateway 10.10.25.1 instead of 10.10.25.3, it runs?


BR

Lasse
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 38809592
Darn, you're right:

route inside BB 255.255.0.0 10.10.25.1
So all the traffic to 192.168.0.0/16 is router through 10.10.25.1 Is assume that is some sort of router.
So is it the idea of going to the 192.168.0.0/16 network that way or (as I assumed) through a VPN?
0
 

Author Comment

by:melfarit
ID: 38809648
Hi Ernie.

10.10.25.1 is a firewall that does vpn to the whole 192.168.0.0/16 network.

Tia

LHC
0
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 500 total points
ID: 38809686
Ok........

Then it would seem you only need to add a route to that network.

If it's only your computer you could do:
route add -p 192.168.0.0 mask 255.255.0.0 10.10.25.1

If it's for more machines on the network you could do it through DHCP by adding a 'classless static route' to the DHCP options.

That should be the easiest way.
0
 

Author Comment

by:melfarit
ID: 38822356
Hi ernie!

Your advice on using classless static route is super. But it did'ent work. It seems like 10.10.25.1 is dropping/blocking something, not the ASA. But this got me further on to a solution.

But thanx for once again being helpfull. Much appreciated!

BR

Lasse
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now