HTTP Error 500.19 - Internal Server Error Calling LoadLibraryEx on ISAPI filter "C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" failed

We have Exchange Server 2007 that is running on Windows Small Business Server 2008; our owa stopped working and when you try to access it you get this error "HTTP Error 500.19 - Internal Server Error
Calling LoadLibraryEx on ISAPI filter "C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" failed"
I have run this command
cscript.exe adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 true"
but the issue still occurs.
xpanditAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
xpanditConnect With a Mentor Author Commented:
this issue was resolved by reinstalling IIS
0
 
becraigCommented:
Take a look at this link:

http://support.microsoft.com/kb/2619202

Solution listed as:
Use the following steps to resolve the issue:

1.  Open Control Panel

2.  Open the System Icon

3.  Click Advanced System Settings

4.  Click the Environment Variables button

5.  In the Sysem Variables section, edit the variable for Path

On Small Business Server 2011 append the path variable with C:\Program Files\Microsoft\Exchange Server\V14\Bin\

On Small Business Server 2008 append the path variable with C:\Program Files\Microsoft\Exchange Server\Bin\

6.  Restart the Windows Small Business Server
0
 
xpanditAuthor Commented:
Hi becraig thanks for the response;I've done those steps but even after reboot its still the same; the eventvwr is showing the following errors. Thanks,
2268.PNG
2274.PNG
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
becraigCommented:
Please check the following:

    Go to %windir%\system32\inetsrv\config\applicationhost.config
    Under <Filters> find the OWA ISAPI filter

Can you copy the information there for owa and let me know:
<filter name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" enabled="true" preCondition="bitnessxx" />
0
 
xpanditAuthor Commented:
<filter name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" enabled="true" preCondition="bitness64" />
0
 
becraigCommented:
You need to change the bitness to 32 since you are launching on an x86 machine.

That should resolve your problem.
0
 
xpanditAuthor Commented:
Hi becraig; thanks for your response.  The server is a x64 bit machine.
0
 
becraigCommented:
Sorry I don't know where I ended up with that I was between two conversations and posted too soon.

Here are the values that should exist for OWA to work:
In the file %windir%\system32\inetsrv\config\applicationhost.config:

     change the line
    <filter name="Exchange OWA Cookie Authentication ISAPI Filter"
    path="C:\Exchange\ClientAccess\owa\auth\owaauth.dll" enabled="true"  />

    to the following
    <filter name="Exchange OWA Cookie Authentication ISAPI Filter"
    path="C:\Exchange\ClientAccess\owa\auth\owaauth.dll" enabled="true" preCondition="bitness64" />
    change the line
    <filter name="Exchange ActiveSync ISAPI Filter"
    path="C:\Exchange\ClientAccess\sync\bin\AirFilter.dll" enabled="true"   />

    to the following
    <filter name="Exchange ActiveSync ISAPI Filter"
    path="C:\Exchange\ClientAccess\sync\bin\AirFilter.dll" enabled="true"
    preCondition="bitness64" />
    change the line
    <add name="exppw"
    image="C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll"  />

    to the following
    <add name="exppw"
    image="C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll"
    preCondition="bitness64" />
    change the line
    <add name="kerbauth"
    image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll"  />

    to the following
    <add name="kerbauth"
    image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll"
    preCondition="bitness64" />
    change the line
    <add name="exppw" />

    to the following
    <add name="exppw" preCondition="bitness64" />
0
 
xpanditAuthor Commented:
Hi becraig, I didn't need to change anything as the current settings are identical to the ones you are suggesting.
0
 
xpanditAuthor Commented:
this issue was resolved by reinstalling IIS
0
All Courses

From novice to tech pro — start learning today.