Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 383
  • Last Modified:

Exchange 2010 Uninstall

I am trying to uninstall a test environment installation of Exchange 2010 and reinstall fresh as there were some configuration inconsistancies in the original installation and would prefer to have all the proper configuration in place rather than troubleshoot the configuration.  My attempts were made through add/remove programs and clearing the check boxes next to all available server roles and the management tools.  I receive the following error when it tries to remove the mailbox role and I can't continue:

Summary: 10 item(s). 1 succeeded, 1 failed.
Elapsed time: 00:00:07


Preparing Setup
Completed

Elapsed Time: 00:00:03


Mailbox Role
Failed

Error:
The following error was generated when "$error.Clear(); $a = get-wmiobject win32_operatingsystem; if( ([int]($a.version.split(".")[0])) -lt 6 ) { stop-SetupService -ServiceName HTTPFilter }" was run: "Not found ".

Not found

Error:
The following error was generated when "$error.Clear(); $a = get-wmiobject win32_operatingsystem; if( ([int]($a.version.split(".")[0])) -lt 6 ) { stop-SetupService -ServiceName HTTPFilter }" was run: "You cannot call a method on a null-valued expression.".

You cannot call a method on a null-valued expression.

Elapsed Time: 00:00:04

Are there specific steps that need to be taken prior to removing Excahnge in this fashion or a better way to perform the uninstall?

TIA
0
API
Asked:
API
  • 3
1 Solution
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Is HTTP removed before hand or what ?
No uninstall should be good if this was working properly in the first place

- Rancy
0
 
APIAuthor Commented:
I didn't remove anything before hand.  I don't understand what you mean by:

No uninstall should be good if this was working properly in the first place
0
 
APIAuthor Commented:
I have searched the net for clues/answers to no avail.  I cant seem to find any references to anything that resembles this issue.  I have been able to find that the HTTPFilter service is related to IIS 6 however not installed on my 2k8 server also the reference to get-wmiobject win32_operatingsystem seems odd considering this is a x64 platform.  I tried to fool the process by creating a service called HTTPFilter and mapping it to lsass.exe (as it is with my 2k3 servers) and setting it to manual hoping it would see it, trying to stop it and see that its already stopped and move on, that didn't work either.  Is there no one that has any experience with this or that could steer me in a viable direction?  This has me pretty well stumped as well as stuck with no way to uninstall Exchange other than a full rebuild of the server.  Then I need to worry about all the footprints it left in AD.
0
 
APIAuthor Commented:
There were no suggestions for help on this issue and I found the answer somewhere else.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now