Solved

Drupal not displaying notice on cache clear, module install, system change

Posted on 2013-01-23
9
309 Views
Last Modified: 2013-02-04
I'm having a problem on one Drupal 7 site.

On other drupal sites, if I clear all caches, enable or disable a module, generally apply any setting, I get a message at the top of the page telling me what just happened. “your settings have been applied, your module is installed, cache is cleared” etc.

This site doesn’t do that.

If I clear caches, install/uninstall modules, change settings etc. There is no notice until I navigate to another page, then the notice appears at the top of page I navigate to.

Things seem to be working, but this is pretty agrivating. For example, if I enable a module and save the change, no notice at the top of the page and the tick box does not appear to be checked. If I navigate away, I get a notice telling me the module has been enabled, if I go back to the module page, the module is not checked.

May or may not be related, but in backup and migrate, I can see a list of backed up DB files, If I try to download/delete/restore it tells me I don’t have permission. The backups are working though, I tested them manually.

all this was done as admin, UID 1
0
Comment
Question by:itkadmin
  • 4
  • 4
9 Comments
 
LVL 13

Expert Comment

by:Arrow_1
ID: 38811897
Are you using a custom theme for your admin screens? It's possible that the theme is not printing the messages.
0
 
LVL 12

Expert Comment

by:junipllc
ID: 38812459
When you say "go back to the module page" do you mean by hitting Back or by actually navigating to the page? Drupal is very form-oriented, with unique IDs for each form generation. Under certain circumstances (especially if you use the Back/Forward buttons on your browser) the "messages" will show up at the next page load. Some of that is by design.

Try switching your administrative theme to Rubik (you'll need Tao as well). Firstly, it's standardized, and secondly, you'll never go back. ;)

But that does sound really weird. I've run across that in instances like this:
the person who coded the site initially did not know what they were doing and possibly hacked core or contrib modules
the theme doesn't have the right variables in its .tpl.php files
somebody put some nasty, weird PHP embedded into a page - turn off the PHP filter (if you can, it's a module) and see if it helps. If you have drush, you can use 'drush dis php' to disable it.
a major misconfiguration of the permissions on the server
Just a few thoughts off the top of my head. It's definitely not acting correctly, but without more information about the exact version of Drupal, and what theme you are using, and the OS (Linux hopefully?) it's difficult to track down what it is.

I'd actually start and make sure that all of your files and directories are all set properly, and that they are owned by the correct users, and in the correct groups. Without write access in, say, the /tmp directory, the web server can't do much of anything, really. Also, the Backup/Migrate files are not downloadable directly from the file path. You need to download them via B&M. If you are doing that, though, then there is a permissions issue you need to address for the files/ directory and others below it.

Whatever you do, do not set the permissions to 777 if this is a live site!

I'm rambling. It's been a long day -- hopefully some of that will help.

Mike
0
 
LVL 2

Author Comment

by:itkadmin
ID: 38814471
Thank you Mike. I'm at a complete loss. Here is all the info I can think of.

When I say "go back to the module page" I mean actually navigating. Not back, forward or refresh.

As for the theme, I use Seven for the admin theme.

I built this site, I've never touched core or contrib.

I was wondering if it could be a module going goofy. To rule it out I did a clean install of D7 to see if I would have the same problem. I did. Well, except the B&M bit, didn't try that. On the clean install, if I go to admin/config/development/performance and clear caches, no message. If I click another menu item, say 'Modules' I get "Caches cleared" at the top of the page.

PARTICULARS
Drupal 7.19
Shared Unix hosting with arvixe.com
I put together a php info file, you can see it here http://www.crow.ws/crowphpinfo.php

The primary domain is crow.ws, everything else is either a sub-domain, ad-on domain or parked domain.

STRUCTURE
home\public_html      -www.crow.ws, nothing except an index.html and directories

craigclark.ca (the site I'm having issues with)
home\public_html\sites-d7       -www.craigclark.ca. it's an add-on domain pointed to this folder

home\drupal_craigclark_private      -private files,chmod 755, in drupal set to ../../drupal_craigclark_private

home\drupal_craigclark_temp      -temp files, chmod 755, in drupal set to ../../drupal_craigclark_temp

testd7.crow.ws (the clean install)
home\public_html\sites-test\d7       -testd7.crow.ws. it's a sub-domain pointed to this folder

home\drupal_craigclark_testd7      -private files,chmod 755, in drupal set to ../../../drupal_testd7_private

home\drupal_craigclark_testd7      -temp files, chmod 755, in drupal set to ../../../drupal_testd7_temp

BACKUP & MIGRATE
the permission message I'm getting is when I try to download/restore/delete via B&M. B&M is working, I can go get the backup files via FTP, then use B&M to upload and restore. I can also use quick back-up to download a backup.

OTHER ODD THING
both temp directories are empty. The last file in home\drupal_craigclark_temp was from sometime in December. I cleaned out the folder, navigated around in drupal for a bit, added a node, ran a back-up, cron, update, cleared caches, rebuilt permissions. nothing.
0
 
LVL 2

Author Comment

by:itkadmin
ID: 38814967
OK
I'm pretty sure this is some sort of issue in the shared hosting environment.

I replicated craigclark.ca on a friends shared host, exactly the same structure. Notices appeared at the top of the page as they should after cache was cleared. No problem downloading/restoring/deleting backups via B&M.

Now my issue, I think, is: What do I tell the host?  In the past arvixe has been really cooperative support wise. The thing is, the support staff don't have a clue about drupal. Generally they don't need to. Do you know what the problem is? or at least what should be looked into the server configuration? Sounds a bit silly, but I'm not sure what to ask them.

I just need something to tell them to avoid the "There's something wrong with your scripts" line.

home\drupal_craigclark_temp is still empty though. Is that normal?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 12

Expert Comment

by:junipllc
ID: 38816916
Haha, I know what you mean. There's a lot of info there to digest and I'm about to put my kids to bed. I just wanted to check in really quick -- I haven't forgotten about this.

I've run into just about every Drupal error I can think of, and that's only basically because there are a lot out there I haven't thought of yet. I'll take a look at some of my past notes and see if anything matches up. You will definitely need to have something to give to them, otherwise it will be "your scripts."

I'll hop back on in a little bit and if nobody else has answered this by then I'll see what I can do.

Cheers,

Mike
0
 
LVL 2

Author Comment

by:itkadmin
ID: 38818446
Thank you very much! I really appreciate the help, I'm at a complete loss.
0
 
LVL 12

Accepted Solution

by:
junipllc earned 500 total points
ID: 38820268
A couple thoughts:

home\public_html\sites-test\d7       -testd7.crow.ws. it's a sub-domain pointed to this folder
home\drupal_craigclark_testd7      -private files,chmod 755, in drupal set to ../../../drupal_testd7_private
home\drupal_craigclark_testd7      -temp files, chmod 755, in drupal set to ../../../drupal_testd7_temp
What is the ownership of this, and what is the ownership/perms for the rest of the install? I don't know how arvixe has their stuff set up, but if the Web server can't write to the directory then weird things start happening.

When I'm testing permissions to see if it's an issue I typically go to the parent directory of the directory in question (DIRNAME below) and run:
find DIRNAME -type f -exec chmod 664 {} \;
find DIRNAME -type d -exec chmod 775 {} \;
chown -R MYUSERNAME:WEBSERVERUSERNAME DIRNAME

Open in new window

That basically allows access for the web server via the group octet (middle, 7).

I see that you're also using symbolic links (?) ... if so, make sure that Apache on the server is set up to allow that. Some aren't configured that way.

I'm doing a quick drive-by here, but I'll be back.

Mike

P.S. Arvixe has a redirect loop error for their own web site, so.......hmm.
(see attached screenshot)
Screen-Shot-2013-01-25-at-2.55.2.png
0
 
LVL 12

Expert Comment

by:junipllc
ID: 38820271
The redirect loop is now gone. They must have fixed it.
0
 
LVL 2

Author Closing Comment

by:itkadmin
ID: 38851208
Sorry for taking so long to get back to this.

I did contact the webhost. Shortly after that things started working as they should. Unfortunately they didn't tall me what they did, or even acknolwedge the problem. I did notice while playing with some redirects that I was getting the same redirect loop error. I didn't think much of it at the time, because I wasn't really working on that.

I don't know, but I strongly suspect the issue was it was related to the redirect problem.

Thank you for all the time you've given this
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

This article is for those that are having major problems with users upload files such as pictures to their profile. The solution is simple and has to do with correcting the directory paths. With some experimenting and testing i got it fixed. Note…
RTL (right to left) web applications aiming for audiences speaking languages like Hebrew or Arabic, are generally more complicated than the same applications aiming for audiences speaking Latin based languages. The main difference lies of course …
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now