Solved

Need Help extending vlan through HP & Cisco Switches

Posted on 2013-01-23
16
632 Views
Last Modified: 2013-02-01
I am attempting to extend a vlan between two buildings and need some configuration assistance.  Below is what I have for vlan configurations on the HPs. The Cisco's have configurations for another vlan (172). I need to know how the Ciscos need to be configured to pass vlans 50,75 & 80 between the HPs


Switch 1: HP ProCurve 2910al-24G-PoE (Connected to Switch 2 via Cat5)
Vlan 1 untagged 1-24
Vlan 50 tagged 1-24
Vlan 75 tagged 1-24
Vlan 80 tagged 1-24

Switch 2: Cisco 3750G (Switches 2 & 3 are connected via fiber)

Switch 3: Cisco 3750G



Switch 4: Switch 1: HP ProCurve 2910al-24G-PoE (Connected to Switch 3 via Cat5)
Vlan 1 untagged 1-24
Vlan 50 tagged 1-24
Vlan 75 tagged 1-24
Vlan 80 tagged 1-24
0
Comment
Question by:tamray_tech
  • 8
  • 7
16 Comments
 
LVL 5

Expert Comment

by:Leeeee
ID: 38811533
The trunking config on the cisco switches will look like:

int g0/1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allow vlan 50,75,80

You will also need to add the VLANs that reside on the HP's to the Cisco Switches.

config)#vlan 50
config-name)#description whatever
config)#vlan 75
config-name)#description whatever
config)#vlan 80
config-name)#description whatever
0
 
LVL 2

Expert Comment

by:byt3
ID: 38811655
*Key thing to remember: Trunk on an HP switch means link aggregation, but trunk on a Cisco switch means a port that is on more than one VLAN.

(I didn't want to confuse you by that when you see that commands below)

enable (enable mode)
configure (config mode)
vlan 50 (create vlan and go to vlan-config mode)
exit (go back to config mode)
vlan 75
exit
vlan 80
exit
interface range fastethernet 1/1 - 24 (enter interface mode on this range of interfaces)

 (the command above depends on your switch. 1/1 means module one port one and assumes the switch is 10/100. Use " show interface brief " before the configure command to find out how your interfaces are listed.)

switchport trunk encapsulation dot1q (set the vlan tagging standard)
switchport mode trunk (tell the port to operate on more than one vlan)
switchport trunk allowed vlan add 50,75,80 (add vlans)
exit (back to config mode)
exit (back to enable mode)
copy running-config startup-config (save your changes)


You're done. Each VLAN you add will become tagged on those port(s). The VLAN the port is on before you change it to trunk mode and add VLANs is the native VLAN, which means the VLAN that is untagged. By default all ports are on VLAN 1.  To change the native (untagged) VLAN, use the command:

switchport trunk native vlan <vlan#>

You must do this while in the interface mode on the port(s) you want to change it on.

My Cisco config is rusty.  I hope this helps.
0
 

Author Comment

by:tamray_tech
ID: 38815993
I understand the configuration for g0/1. How would the Ethernet port that connects to the Procurve be configured?
0
 
LVL 2

Expert Comment

by:byt3
ID: 38816439
if the single Cisco port plugged into the HP is g0/2

then use the commands Leeee and I posted above.

int g0/2
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan add 50,75,80
0
 

Author Comment

by:tamray_tech
ID: 38816487
Just to clarify, same as the fiber ports between Ciscos?
0
 
LVL 2

Expert Comment

by:byt3
ID: 38817409
Yes.

If Cisco is plugged into HP port 24
and HP is plugged into Cisco port g0/1
As you have above, HP Port:

vlan 1 untag 24
vlan 50 tag 24
vlan 75 tag 24
vlan 80 tag 24

Cisco Port:
int g0/1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan add 50,75,80


Hope that clarifies things.
0
 

Author Comment

by:tamray_tech
ID: 38819097
Thanks... Will be traveling over an hour to work on this tomorrow and need to be sure I have all the info I need.
0
 

Author Comment

by:tamray_tech
ID: 38823048
On-site , working on the project. Having some difficulty.
I have a laptop attached to port 22 on the procurve POE. Port 16 of the Procurve is attached to Port 20 of the Cisco 3750G (In the same room).

The Ciscos original config for port 20 is as follows:
interface GigabitEthernet1/0/20
switchport access vlan 172
switchport mode access
spanning-tree portfast

With this setup, my laptop is able to pull a dhcp address.

When I change the cisco config on port 20 to the following, I am unable to pull an address:

interface GigabitEthernet1/0/20
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan add 50,75,80

Also tried with this line:
switchport trunk allowed vlan add 1,50,75,80,172
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 2

Expert Comment

by:byt3
ID: 38823085
If I understand correctly you want untagged traffic to be on vlan 172?

If that is the case then do this command on the cisco:

interface GigabitEthernet1/0/20
switchport trunk native vlan 172

That will make vlan 172 untagged on that port. While 1,50,75 and 80 will be tagged.
0
 

Author Comment

by:tamray_tech
ID: 38823101
This is what I have now, and I am getting a dhcp address. Should I remove the switchport access vlan 172, and spanning-tree portfast line or leave them there?


interface GigabitEthernet1/0/20
 switchport access vlan 172
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 172
 switchport mode trunk
 spanning-tree portfast
0
 
LVL 2

Expert Comment

by:byt3
ID: 38823160
If you leave the 'switchport access vlan 172' then the command 'switchport trunk native vlan 172' becomes redundant (it doesn't matter which you use, unless it matters whether or not  vlan 1 is tagged on the port as well).

'spanning-tree portfast' makes it so that a port goes into forwarding mode immediately: allowing the devices to start communicating sooner instead of the 30 seconds it would typically take (I think it's 30 seconds. It could be less).


The 'switchport access vlan 172' command changes the untagged vlan of a port that is not in trunking mode to vlan 172. A port in trunking mode allows you to add more vlans as tagged vlans. If you change the vlan of the port using 'switchport access vlan 172' before placing the port in trunking mode the untagged vlan of that port is the vlan it was on before going into trunking mode (in your case vlan 172). If you changed to trunking mode before using the 'switchport access vlan 172' command then the untagged vlan of the port while in trunking mode will be vlan 1 (because all ports are in vlan 1 by default).  'switchport trunk native vlan 172' changes the untagged vlan on that port to 172 and then vlan 1 becomes tagged. If you don't want vlan 1 to be tagged on that port, then you would then have to use the command 'swtichport trunk allowed vlan remove 1' after issuing the 'switchport trunk native vlan 172' command.

Examples:
Either go

interface GigabitEthernet1/0/20
switchport access 172
switchport mode trunk
switchport trunk allowed vlan add 50,75,80

or

interface GigabitEthernet1/0/20
switchport mode trunk
switchport trunk allowed vlan add 50,75,80,172 *need to add 172 before making it native
switchport trunk native vlan 172
switchport trunk allowed vlan remove 1

This would make vlan 172 untagged; vlan 50, 75 and 80 tagged; and vlan 1 would not be on that port.  **You need to add vlan 172 before making it the native vlan if you didn't use the 'switchport access vlan 172'.


I hope I explained that well enough for you to follow.  I'm not always good with words.
0
 

Accepted Solution

by:
tamray_tech earned 0 total points
ID: 38823187
Before you replied, I removed those two lines. This is what I have now:


interface GigabitEthernet1/0/20
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 172
 switchport mode trunk

DHCP still worked, but won't know about the vlans till I head over to the other building.


I attempted twice to be specific about the vlans like this:

switchport trunk allowed vlan add 50,75,80

But it doesn't add the line. No errors either. I am guessing its because we are declaring the native vlan.

Port interface GigabitEthernet1/0/26 is the fiber that connects the two buildings. Would I leave the native vlan alone, or set it to vlan 172 also?
0
 
LVL 2

Expert Comment

by:byt3
ID: 38823203
That depends on your network configuration. If on the other end you have an HP that has vlan 172 untagged on it then I would assume you would leave 172 as the native vlan.

If you don't receive an error when entering a command then it completed successfully.
0
 

Author Comment

by:tamray_tech
ID: 38823339
Couldn't get the vlans to extend. Have to head out for the night, but coming back in the morning. Attaching all the configs involved. Some residual stuff in there from all my attempts. Appreciate if you could look at it at your convenience
YME-Configs
0
 
LVL 2

Expert Comment

by:byt3
ID: 38824909
Glad you figured it out.
0
 

Author Closing Comment

by:tamray_tech
ID: 38843085
Got it working with the following:

interface GigabitEthernet1/0/26 (Fiber)
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,50,75,80,172
 switchport mode trunk



interface GigabitEthernet1/0/18      (Copper)                                          
 switchport trunk encapsulation dot1q                                          
 switchport trunk native vlan 172                                              
 switchport mode trunk                                                          
 spanning-tree portfast

I probably would have gotten it last night if I had double checked my last changes. The allowed vlans was missing on one side.

Thank you for your patience.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
Security is one of the biggest concerns when moving and migrating your data from your on-premise location to the Public Cloud.  Where is your data? Who can access it? Will it be safe from accidental deletion?  All of these questions and more are imp…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now