AutoComplete doesn't like Email Enabled Public Folders!

I have a mail enabled public folder with send as permissions set.

In outlook
I select From: button
Select the "Other Email Address"
Select the actual public folder
The email gets sent perfectly every time.

BUT:
In outlook
I select From: button
I use the Auto Complete (NK2) address for the folder
The email will never get sent and I get this error:
You can't send a message on behalf of this user unless you have permission to do so. Please make sure you're sending on behalf of the correct sender, or request the necessary permission. If the problem continues, please contact your helpdesk.
gpchicago08Asked:
Who is Participating?
 
BlueComputeConnect With a Mentor Commented:
Sorry, didn't realize you were on Outlook 2010. Does it work ok if you create a new mail profile on the PC? If so, try deleting the .dat, and if still no joy, try deleting the local store (.ost file). What's your environment - Exchange 2010? And is this a new setup, or a migrated install?
0
 
BlueComputeCommented:
Have you tried deleting the entry from the NK2 file and re-creating it by manually sending? The NK2 file's basically plain-text - if you open it in Notepad, what does the entry for your mail-enabled public folder say?
0
 
gpchicago08Author Commented:
I deleted it from the autocomplete list and restarted outlook.  still nothing.

NK2 no longer exists in 2010 outlook.  it is a .dat file.  I do no know how to open it.
0
 
gpchicago08Author Commented:
exch 2010
clean install mso 2010
no other autocomplete issues.
0
 
gpchicago08Author Commented:
Deleted .dat file and now it works.  HOW FRUSTRATING!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.