Solved

Exchange SP3 fails on SBS2008

Posted on 2013-01-23
4
843 Views
Last Modified: 2013-02-27
Tried to install SP3 following this post

http://www.sbsfaq.com/?p=2140

The install failed and left most of the Exchange Services disabled. I need to attempt this again, but have no idea what i might do differently to avoid the failure as before.

Last part of setup log showing failure to stop a MSEXCHANGEMAILBOXASSISTANTS service

7/11/2012 7:25:57 PM] [2] Ending processing.
[7/11/2012 7:25:57 PM] [2] Beginning processing.
[7/11/2012 7:25:57 PM] [2] The maximum wait for the operation is set to '00:15:00'.
[7/11/2012 7:25:57 PM] [2] [WARNING] Service checkpoint has not progressed. Previous checkpoint='0'- Current checkpoint='0'.
[7/11/2012 7:25:57 PM] [2] Previous service status query time is '7/11/2012 7:25:57 PM'.
[7/11/2012 7:25:57 PM] [2] Current service status query time is '7/11/2012 7:25:57 PM'.
[7/11/2012 7:25:57 PM] [2] Will wait '25000' milliseconds for the service 'MSExchangeTransportLogSearch' to reach status 'Stopped'.
[7/11/2012 7:25:58 PM] [2] Service 'MSExchangeTransportLogSearch' has successfully reached  status 'Stopped on this server while waiting for status change.
[7/11/2012 7:25:59 PM] [2] The maximum wait for the operation is set to '00:15:00'.
[7/11/2012 7:25:59 PM] [2] [WARNING] Service checkpoint has not progressed. Previous checkpoint='0'- Current checkpoint='0'.
[7/11/2012 7:25:59 PM] [2] Previous service status query time is '7/11/2012 7:25:59 PM'.
[7/11/2012 7:25:59 PM] [2] Current service status query time is '7/11/2012 7:25:59 PM'.
[7/11/2012 7:25:59 PM] [2] Will wait '25000' milliseconds for the service 'MSExchangeSearch' to reach status 'Stopped'.
[7/11/2012 7:25:59 PM] [2] Service 'MSExchangeSearch' has successfully reached  status 'Stopped on this server while waiting for status change.
[7/11/2012 7:26:00 PM] [2] The maximum wait for the operation is set to '00:15:00'.
[7/11/2012 7:26:00 PM] [2] [WARNING] Service checkpoint has not progressed. Previous checkpoint='0'- Current checkpoint='0'.
[7/11/2012 7:26:00 PM] [2] Previous service status query time is '7/11/2012 7:26:00 PM'.
[7/11/2012 7:26:00 PM] [2] Current service status query time is '7/11/2012 7:26:00 PM'.
[7/11/2012 7:26:00 PM] [2] Will wait '25000' milliseconds for the service 'MSExchangeRepl' to reach status 'Stopped'.
[7/11/2012 7:26:00 PM] [2] Service 'MSExchangeRepl' has successfully reached  status 'Stopped on this server while waiting for status change.
[7/11/2012 7:26:01 PM] [2] The maximum wait for the operation is set to '00:15:00'.
[7/11/2012 7:26:01 PM] [2] [WARNING] Service checkpoint has not progressed. Previous checkpoint='0'- Current checkpoint='0'.
[7/11/2012 7:26:01 PM] [2] Previous service status query time is '7/11/2012 7:26:01 PM'.
[7/11/2012 7:26:01 PM] [2] Current service status query time is '7/11/2012 7:26:01 PM'.
[7/11/2012 7:26:01 PM] [2] Will wait '25000' milliseconds for the service 'MSExchangeMailSubmission' to reach status 'Stopped'.
[7/11/2012 7:26:02 PM] [2] Service 'MSExchangeMailSubmission' has successfully reached  status 'Stopped on this server while waiting for status change.
[7/11/2012 7:26:02 PM] [2] Unexpected Error
[7/11/2012 7:26:02 PM] [2] Service 'MSExchangeMailboxAssistants' failed to stop. Error:'Cannot stop MSExchangeMailboxAssistants service on computer '.'.'.
[7/11/2012 7:26:02 PM] [2] Cannot stop MSExchangeMailboxAssistants service on computer '.'.
[7/11/2012 7:26:02 PM] [2] The pipe state is invalid
[7/11/2012 7:26:02 PM] [2] Ending processing.
[7/11/2012 7:26:06 PM] [1] The following 1 error(s) occurred during task execution:
[7/11/2012 7:26:06 PM] [1] 0.  ErrorRecord: Service 'MSExchangeMailboxAssistants' failed to stop. Error:'Cannot stop MSExchangeMailboxAssistants service on computer '.'.'.
[7/11/2012 7:26:06 PM] [1] 0.  ErrorRecord: Microsoft.Exchange.Configuration.Tasks.ServiceStopFailureException: Service 'MSExchangeMailboxAssistants' failed to stop. Error:'Cannot stop MSExchangeMailboxAssistants service on computer '.'.'. ---> System.InvalidOperationException: Cannot stop MSExchangeMailboxAssistants service on computer '.'. ---> System.ComponentModel.Win32Exception: The pipe state is invalid
   --- End of inner exception stack trace ---
   at System.ServiceProcess.ServiceController.Stop()
   at Microsoft.Exchange.Configuration.Tasks.ManageServiceBase.StopService(String serviceName, Boolean ignoreServiceStopTimeout, Boolean failIfServiceNotInstalled, Unlimited`1 maximumWaitTime)
   --- End of inner exception stack trace ---
[7/11/2012 7:26:06 PM] [1] Service 'MSExchangeMailboxAssistants' failed to stop. Error:'Cannot stop MSExchangeMailboxAssistants service on computer '.'.'.
[7/11/2012 7:26:06 PM] [1] Cannot stop MSExchangeMailboxAssistants service on computer '.'.
[7/11/2012 7:26:06 PM] [1] The pipe state is invalid
[7/11/2012 7:26:06 PM] [1] Setup is halting task execution because of one or more errors in a critical task.
[7/11/2012 7:26:06 PM] [1] Finished executing component tasks.
[7/11/2012 7:26:06 PM] [1] Ending processing.
[7/11/2012 7:28:36 PM] [0] End of Setup

googling for the error did not turn up anything.
0
Comment
Question by:gwa60060
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 

Author Comment

by:gwa60060
ID: 38813993
Nobody?
0
 
LVL 14

Expert Comment

by:BlueCompute
ID: 38815869
First off, you get the 10 bonus points for "first person on the internet with this error"...
To troubleshoot- do you have the service in question (Microsoft Exchange Mailbox Assistants) listed in services manager? And can you start and stop it ok from there? Is anything being logged in the event viewer at the same time as the installation fails?
In my experience it leaves the dagnammed services disabled even if it installs successfully, which is irritating. Worth rebooting and checking the event log looks clean before running the install - I know this can take bloody ages on SBS, but patience is a virtue...
0
 

Accepted Solution

by:
gwa60060 earned 0 total points
ID: 38816392
The service exists.
I will try to stop and start the service before the SP install. Install was last attempted last fall, so event logs long gone for that.
 I think I will-
Restart server
Stop All AV applications and services
Try to restart the  Microsoft Exchange Mailbox Assistants service.
If stopping and starting that service  succeeds, I will proceed with fingers crossed.
0
 

Author Closing Comment

by:gwa60060
ID: 38933262
It worked
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Suggested Courses

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question