[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 667
  • Last Modified:

Drupal 7 Fresh Install Keeps Directing to Apache index.html

Aloha,

I just did a fresh install of Drupal 7 on to a fresh install of Ubuntu 12.04. Everything went fine, no errors or issues through the install process.

Note: I am an Apache noob.

Ok, so when I go to load the site drupal.localhost I am redirected back to the Apache start page (index.html). I can load drupal.localhost/index.php just fine. But when I log in, I am again redirected back to the Apache start page. I have Googled and Googled for an answer, but have been getting nowhere. So, here I am.

There are no other websites being served by this box. I just want my main Drupal site to load to work properly using drupal.localhost.

Thanks in advance!
0
tlasoya808
Asked:
tlasoya808
  • 3
2 Solutions
 
sivagnanam chandrakanthCommented:
Check your htaccess file....

Try changing below line in htaccess by giving drupal path

RewriteBase /

Also check apache rewrite is enabled?
0
 
junipllcCommented:
Two things you can try:

First, make sure you have an .htaccess file in the Drupal root. You can't get any other pages but the front page if you don't.

Second, make sure that Apache is set to seek out .php index files before .html index files. Put this in your overall Apache config:

DirectoryIndex index.php index.html

Open in new window


I think one or both of these might be the problem, or lead to it.

Cheers!

Mike
0
 
tlasoya808Author Commented:
Aloha,

Thank for for the suggestions.

1. There is no RewriteBase option in my .htaccess file. Not sure if I should add one and if so, what the proper statement should look like.

2. Not sure where to ensure apache rewrite is enabled. Again, I am noob. I looked at the apache2.conf file and did not see anything obvious. There is a mods-enabled and a mods-available directory, The only reference to rewrite is in the mods-available directory, rewrite.load. Do I move that to the mods-available directory?

3. The .htaccess file is in the Drupal root, which is the webroot /var/www. And the DirectoryIndex index.php index.html statement exists in the .htaccess file. Does it need to be in apache2.conf as well?

What I think is odd is that in the /var/www directory, where index.php exists, there are no other Drupal files and there is no other Drupal directory. It very well could be that I botched my Drupal install somehow. I used these directions:

http://drupal.org/documentation/install/download

Thanks for all the suggestions. I may just try the install again. Thankfully I have a VM and can just revert to the snapshot I have prior to installing Drupal.

Tony
0
 
tlasoya808Author Commented:
Well, this fixed the redirect issue after login:

AllowOverride All (was set to none) in  /etc/apache2/sites-available/default.

Now just need to figure out how to get index.php to load automatically.
0
 
tlasoya808Author Commented:
Meh, cleared the cache in Chrome and it all works like it's supposed to. Going to split the points between the both of the responses as combined they got me where I needed to be.

Many thanks again!

Tony
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now