Solved

site to site VPN - cisco asa 5505

Posted on 2013-01-23
14
913 Views
Last Modified: 2013-01-28
Hi

I am having problem setting site to site VPN - cisco asa 5505.

Question

A site - ASDM:6.2(1)  ASA: 8.2(1)
B site - ASDM:6.4(7)  ASA: 8.4(3)

Different version - its the problem?

Thank you
0
Comment
Question by:jessiewang
  • 7
  • 3
  • 2
  • +1
14 Comments
 
LVL 10

Expert Comment

by:ddiazp
ID: 38812804
Versions shouldn't be a problem.

At what stage are you at? Is it failing at phase 1 or phase 2?

Do you have some config you have in place so that we can take a look?
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 38813367
Can you post your config pls
0
 

Author Comment

by:jessiewang
ID: 38820776
I am having problem with 69.x.x.54 VPN 208.x.x.165.

This is 69.x.x.54 - - A site - ASDM:6.2(1)  ASA: 8.2(1)
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 172.16.0.1 255.255.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 69.x.x.54 255.255.255.248
!
interface Vlan5
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 172.16.0.2
 name-server 69.x.x.6
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service TS-777 tcp-udp
 port-object eq 777
object-group service Graphon tcp-udp
 port-object eq 491
object-group service TS-778 tcp-udp
 port-object eq 778
object-group service moodle tcp-udp
 port-object eq 5801
object-group service moodle-5801 tcp-udp
 port-object eq 5801
object-group service smtp-587 tcp-udp
 port-object eq 587
access-list outside_access_in extended permit tcp any host 69.x.x.50 eq imap4
access-list outside_access_in extended permit tcp any host 69.x.x.52 eq ftp
access-list outside_access_in extended permit object-group TCPUDP any host 69.x.x.50 object-group smtp-587
access-list outside_access_in extended permit tcp any host 69.x.x.52 eq telnet
access-list outside_access_in extended permit tcp any host 69.x.x.52 eq ssh
access-list outside_access_in extended permit object-group TCPUDP any host 69.x.x.52 object-group moodle-5801
access-list outside_access_in extended permit tcp any host 69.x.x.52 eq smtp
access-list outside_access_in extended permit tcp any host 69.x.x.52 eq https
access-list outside_access_in extended permit tcp any host 69.x.x.52 eq www
access-list outside_access_in extended permit tcp any host 69.x.x.50 eq ftp
access-list outside_access_in extended permit tcp any host 69.x.x.50 eq smtp
access-list outside_access_in extended permit tcp any host 69.x.x.50 eq pop3
access-list outside_access_in extended permit object-group TCPUDP any host 69.x.x.50 eq domain
access-list outside_access_in extended permit tcp any host 69.x.x.50 eq https
access-list outside_access_in extended permit tcp any host 69.x.x.50 eq www
access-list outside_access_in extended permit object-group TCPUDP any host 69.x.x.51 eq domain
access-list outside_access_in extended permit object-group TCPUDP any host 69.x.x.51 object-group TS-778
access-list outside_access_in extended permit object-group TCPUDP any host 69.x.x.51 object-group Graphon
access-list outside_access_in extended permit tcp any host 69.x.x.51 eq https
access-list outside_access_in extended permit tcp any host 69.x.x.51 eq www
access-list outside_access_in extended permit object-group TCPUDP any host 69.x.x.50 object-group TS-777
access-list outside_access_in extended permit tcp any host 69.x.x.54 eq https
access-list outside_cryptomap_1 extended permit ip 172.16.0.0 255.255.0.0 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 192.168.0.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 172.16.0.32 255.255.255.224
access-list inside_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 192.168.50.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 192.168.1.0 255.255.255.0
access-list inside_access_in extended permit ip any any
access-list Split-Tunnel standard permit 172.16.0.0 255.255.0.0
access-list NONAT extended permit ip 172.16.0.0 255.255.0.0 192.168.0.0 255.255.255.0
access-list NONAT extended permit ip 172.16.0.0 255.255.0.0 172.16.100.0 255.255.255.0
access-list NONAT extended permit ip 172.16.0.0 255.255.0.0 192.168.50.0 255.255.255.0
access-list NONAT extended permit ip 172.16.0.0 255.255.0.0 192.168.1.0 255.255.255.0
access-list outside_cryptomap extended permit ip 172.16.0.0 255.255.0.0 192.168.0.0 255.255.255.0
access-list outside_cryptomap extended permit ip 172.16.0.0 255.255.0.0 192.168.50.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool vpn_users 172.16.100.10-172.16.100.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 69.x.x.50 172.16.0.2 netmask 255.255.255.255
static (inside,outside) 69.x.x.51 172.16.1.2 netmask 255.255.255.255
static (inside,outside) 69.x.x.52 172.16.1.3 netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 69.x.x.49 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 172.16.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 208.x.x.162
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 2 match address outside_cryptomap_1
crypto map outside_map 2 set pfs
crypto map outside_map 2 set peer 208.x.x.165
crypto map outside_map 2 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 5
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 1
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 172.16.0.20-172.16.0.40 inside
dhcpd dns 172.16.0.2 69.x.x.6 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
 svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
 svc enable
 tunnel-group-list enable
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
group-policy sales internal
group-policy sales attributes
 dns-server value 172.16.1.2 172.16.0.2
 vpn-tunnel-protocol svc
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Split-Tunnel
 webvpn
  svc mtu 1406
username graciela password CdnZ0hm9o72q6Ddj encrypted
tunnel-group 208.x.x.165 type ipsec-l2l
tunnel-group 208.x.x.165 ipsec-attributes
 pre-shared-key *
tunnel-group TunnelGroup1 type remote-access
tunnel-group TunnelGroup1 general-attributes
 address-pool vpn_users
 default-group-policy sales
 dhcp-server 172.16.0.1
tunnel-group TunnelGroup1 webvpn-attributes
 group-alias Remote_Access enable
 group-alias sales_department disable
tunnel-group 208.x.x.162 type ipsec-l2l
tunnel-group 208.x.x.162 ipsec-attributes
 pre-shared-key *
!
class-map global-class
 match default-inspection-traffic
!
!
policy-map global-policy
 class global-class
  inspect icmp
!
service-policy global-policy global
prompt hostname context
Cryptochecksum:
: end
asdm location 192.168.1.0 255.255.255.0 inside
no asdm history enable

This is 208.x.x.165- - B site - ASDM:6.4(7)  ASA: 8.4(3)

!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 208.x.x.165 255.255.255.248
!
ftp mode passive
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network NETWORK_OBJ_192.168.1.0_24
 subnet 192.168.1.0 255.255.255.0
object network email
 subnet 172.16.0.0 255.255.0.0
access-list outside_cryptomap extended permit ip 192.168.1.0 255.255.255.0 object email
access-list 1 standard permit 192.168.1.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static email email
!
object network obj_any
 nat (inside,outside) dynamic interface
route outside 0.0.0.0 0.0.0.0 208.x.x.161 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto map outside_map 1 match address outside_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 69.x.x.54
crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map outside_map interface outside
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.132 inside
dhcpd dns 208.x.x.10 208.x.x.11 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy GroupPolicy_69.x.x.54 internal
group-policy GroupPolicy_69.x.x.54 attributes
 vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec ssl-client ssl-clientless
tunnel-group 69.x.x.54 type ipsec-l2l
tunnel-group 69.x.x.54 ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 remote-authentication pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:
: end
no asdm history enable

Thank you
0
 
LVL 10

Expert Comment

by:ddiazp
ID: 38821761
Everything looks okay, access-lists, nonat, isakmp and ipsec parameters,.. the first thing i'd try is disabling pfs.

aside from that, can you post the results of

show crypto ipsec sa
show crypto isakmp sa

also - perhaps enable debugging:

debug crypto ipsec 127
debug crypto isakmp 127

and try to ping 192.168.1.0 from 172.16.0.0, and vice versa,.. 172.16.0.0 from 192.168.1.0
0
 
LVL 17

Assisted Solution

by:MAG03
MAG03 earned 250 total points
ID: 38825080
Is the tunnel being established and traffic just isn't crossing?

If the tunnel is not establishing, I am wondering if perhaps this statement is the culprit on the ASA running 8.4:

crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES

try removing this statement and test.
0
 
LVL 18

Accepted Solution

by:
fgasimzade earned 250 total points
ID: 38825764
Add

sysopt connection permit-vpn

on both ASAs
0
 

Author Comment

by:jessiewang
ID: 38828538
how to disable disabling pfs.?

Thank you
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:jessiewang
ID: 38828548
ciscoasa(config)# show crypto ipsec sa

There are no ipsec sas

ciscoasa(config)# show crypto isakmp sa

There are no IKEv1 SAs

There are no IKEv2 SAs
0
 

Author Comment

by:jessiewang
ID: 38828583
whats the command to remove "crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES"?

Thank you
0
 
LVL 17

Expert Comment

by:MAG03
ID: 38828723
no crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
0
 

Author Comment

by:jessiewang
ID: 38828743
does not work...

thank you
0
 

Author Comment

by:jessiewang
ID: 38828826
sysopt connection permit-vpn  - added. but not showing?...

Thank you
0
 
LVL 17

Expert Comment

by:MAG03
ID: 38828919
you don't see it because it is enabled by default and default values are normally not shown in the CLI.

are you sure the the preshared keys match?

If you allow ping on the outside interfaces can you ping the peer?
0
 

Author Comment

by:jessiewang
ID: 38828929
ok....I think its working now....

thank you
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
NSD FAIL 2 21
Native Vlans, Tagged & untagged annnd Trunks 6 25
cisco 2911 8 21
Access List 2 0
Overview The Cisco PIX 501, PIX 506e, ASA 5505 and ASA 5510 (most if not all of this information will be relevant to the PIX 515e but I do not have a working configuration handy to verify the validity) are primarily used within small to medium busi…
Some of you may have heard that SonicWALL has finally released an app for iOS devices giving us long awaited connectivity for our iPhone's, iPod's, and iPad's. This guide is just a quick rundown on how to get up and running quickly using the app. …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now