[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 285
  • Last Modified:

Server 2003 and Client System Time not syncing

I am working on a server 2003 std box which is a DC. The customer has told me that the clocks on the server and some workstations do not match. I do not know much about how to fix this issue, but I am under the impression that the server should be the clock the clients look to for syncing. Please let me know your suggestions.
0
jands
Asked:
jands
  • 4
  • 3
1 Solution
 
EMJSRCommented:
Easiest way would probably be if you have Active Directory and if you're running a logon script. If you do, add the following line along with other commands (such as NET USE for network drive mappings):

NET TIME \\mywindowsserver /SET /YES

Reaplace "mywindowsserver" with your server's name and that way, whenever a client logs on, the time will sync.
0
 
jandsAuthor Commented:
Is that not a default feature for a 2003 domain controller/domain. I would think that this would be automatic when I join a new pc or existing pc to the domain?
0
 
EMJSRCommented:
Well, if your workstations are Windows Vista or 7 based, you can also do the following:

In a command prompt type:

w32tm /config /syncfromflags:domhier /update

Open in new window


Then run "net stop w32time" and "net start w32time".

You can also try

w32tm /resync mywindowsserver

Open in new window

(replace "mywindowsserver" with the actual server name).

Usually Windows obtains the time from an internet source and in theory the server could also be a source. Maybe there are some time zone differences configured on the computers that causes the difference.

Either way, I think the easiest way would be to run a logon script. You can configure this in the Profile tab of an Active Directory user account.

The point is that if some of the computers do not have the same time then there is obviously something amiss in the configuration. If you were to run a script upon their start (either centralized as described above) or a simple batch file in the startup folder of each workstation, that should do it. You could use something like this:

@echo off
cls
echo.
echo Synchronizing time...
echo.
NET TIME \\mywindowsserver /SET /YES
echo.
echo Complete.
echo.

Open in new window


Save it as "time.bat" or a filename of your choice, put it into "\\localhost\sysvol\scripts" on the server and if there is already a login script in place, add a line to that batch file:

call time.bat

Open in new window


That will definitely work, because no matter what the local setting, it will force the time to be synchronized. It's the fastest way to resolve the issue.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jandsAuthor Commented:
I have not had time to address this yet. Will post back when fixed.
0
 
jandsAuthor Commented:
Thanks.
0
 
jandsAuthor Commented:
Thanks.
0
 
EMJSRCommented:
You're welcome!
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now