Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 332
  • Last Modified:

Deleted an AD user & mailbox

I am running win 2008 R2, with exchange 2007 R2.  On accident, I deleted a user account and after a few minutes, i was able to restore the account.  Since then though, the user is having email problems. When ever people email her, they get a non-deliverable message back.  I have attached the error message.

When creating a new email, when you start typing the name of the person you want to email, I think it's called auto complete or something, well (picture attached), I deleted the user from that list, and it worked, I can send the user that I deleted and recovered an email.

The problem is, I can't walk around to all the 70 + computers to fix that  manually.

I sent the user an email from my gmail account and she received that email, so the account should be good then, but not sure if something in AD is still causing this problem?

Any suggestions how to fix this for everyone's computers that has this user on their auto complete list?
auto-complete.jpg
error-message.jpg
0
afacts
Asked:
afacts
  • 12
  • 9
  • 3
2 Solutions
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Perfect you have the answer the error itself gives you the answer as its more like .... below and get it added to user as X500

/ExchangeOrgName/AGName/recipients/UserName (All the information is in the Undeliverable you get)

- Rancy
0
 
afactsAuthor Commented:
I'm sorry, I'm lost, I didn't understand what I need to do? Can You explain?
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Hope this can explain much better

How to set X500 proxy addresses for Exchange Server 2003 recipients and for Exchange 2000 Server recipients
http://support.microsoft.com/kb/313324

- Rancy
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
afactsAuthor Commented:
But I have exchange 2007, not 2000 or 2003.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Its just a understanding of the issue .... has nothing to do with Version of Exchange

- Rancy
0
 
afactsAuthor Commented:
So is this how it should look like?
X500.png
0
 
SubsunCommented:
You need to add old legacyExchangeDN as a X500 address to the new mailbox. Please refer the following question for details..#a38496513
0
 
afactsAuthor Commented:
I did that, but it didnt' work.  I copied the legacy exchange DN and added it as a x500 address, but it's still not working.  Not sure what else to do.
0
 
SubsunCommented:
Did you generate the X500 address from the email address mentioned in NDR?
0
 
afactsAuthor Commented:
yes, even looked at this post.

http://msexchangeguru.com/2012/03/15/x500/
0
 
SubsunCommented:
If you have generated X500 correctly (see screenshot) and added to mailbox then it should work..
X500Hope you added it as a custom address..
Read section : So, how to solve this? from flowing article..
Ref : http://blogs.technet.com/b/ilvancri/archive/2011/10/25/the-secret-about-a-successful-export-to-pst-and-import-from-pst-migration-is-called-add-custom-address-type-x500.aspx
0
 
afactsAuthor Commented:
Yes, that's what I did, but it was via the GUI, as I don't know powershell.
0
 
afactsAuthor Commented:
The new email was a custom X500 email address.
 I copied and pasted from adsi edit, from the legacy exchange DN.
0
 
SubsunCommented:
Nope that wont work, new account or restored account will have a new LDN which wont match with old mailbox LDN, that's why you are getting NDR..You need to copy the email ID from NDR which look like IMCEAEX-_O=name+20name_OU=name_CN=RECIPIENTS_CN=TStevens04676063@domainname.org

And use the script from my previous comment (ID: 38815499) to convert ot to X500 address... Then add it as a X500 address to the mailbox..
0
 
afactsAuthor Commented:
I understand what you ar saying, but I'm not sure what I shoudl make it. for example, this is the ID I get:
IMCEAEX_O=DOMAIN_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=user@DOMAIN.org

Not sure what script you are talking about? I saw your screenshot, but I'm not sure how to convert that to what it should be, to add it to the email address field, as an X500 entry.
0
 
SubsunCommented:
Check the link from comment ID: 38815499
0
 
SubsunCommented:
BTW
IMCEAEX_O=DOMAIN_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=user@DOMAIN.org

Open in new window

Converts to..
/O=DOMAIN/OU=EXCHANGE ADMINISTRATIVE GROUP (FYDIBOHF23SPDLT)/CN=RECIPIENTS/CN=user

Open in new window

0
 
afactsAuthor Commented:
I know, I did that
0
 
SubsunCommented:
Then it should work (I have done this many times.. :-) ).. If you say it's not working for you then the only thing you can do is to manually remove the cached address from outlook.. and select the email address from GAL while ending mail...
0
 
afactsAuthor Commented:
Oh great, the problem is, she's not getting any emails from any body.

What would happen if I delete her account and create it from scratch, would that give me any problems?  I think I did that in the past and I ran into the same issue, is that not true.  If I delete the user, is there a way to completely remove it fe AD, so it can look like that user account never existed?
0
 
SubsunCommented:
Are you able to send her mail from OWA?
If you delete user and create new mailbox with same email address, still you will face the problem with cached address.. If users send mail selecting her address from outlook cache or even if they reply to her old mail.. it will bounce back similar way..
0
 
afactsAuthor Commented:
Ok, that's what I was afraid of.  

I since I deleted my email cache, she is receiving my emails just fine and a few others as well, since I told them to clear the cache.  So will the same problem exist with external people sending her emails?
Internally, I can walk around and clear it, but there's nothing I can do externally.   I'm just stumped that it doesn't work.  I'll test it again on Monday, as we are closed on Fridays.  I'll let you know on Monday.  So basically don't delete the account, as I'll still have the same issue with caching.
0
 
SubsunCommented:
So will the same problem exist with external people sending her emails?
No external mail will work without any issue..

As I said, If Adding the X500 didn't work then you have to instruct users to delete the old address from cache and send mail to the address in GAL. After that the new address will be cached in outlook..

BTB  : Sometimes if you open the cached address in outlook it will give you the correct LDN which you can add to user mailbox as a X500 address..
0
 
afactsAuthor Commented:
Thanks guys for your help.  since it still didn't work, I just sent an email to everyone with instructions how to manually remove the autocomplete entry.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 12
  • 9
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now