Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

using GPO to change windows 7 login image background

Posted on 2013-01-24
5
Medium Priority
?
1,793 Views
Last Modified: 2013-10-02
I have tried several GPO with no success, please can someone point me in the right direction?

Basically I would like to seamlessly deploy a new image to replace the OEM images (OEM image pointing is enabled in REGEDIT).

Here is what I have been trying with little sucess. I can manually place the picture in the folder is have set as the destination and it all works. I cannot get the file to copy automatically....

http://www.grouppolicy.biz/2011/04/best-practice-how-to-use-group-policy-to-configure-windows-7-logon-ui-background-wallpaper/
0
Comment
Question by:drifted
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 5

Expert Comment

by:Dilip Patidar
ID: 38814262
Hello,

You can make some below changes and verify.

http://techmell.com/windows-tips/change-windows-7-logon-screen-background-image/

This feature is disabled by default, so you’ll have to enable it from the Registry Editor. You can also use the Group Policy Editor if you have a Professional version of Windows – scroll down a bit for the Group Policy Editor method.

Launch the Registry Editor by typing regedit into the search box in the Start menu and pressing Enter.

In the Registry Editor, navigate to the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background

You’ll see an DWORD value named OEMBackground. If you don’t see it, right-click in the right pane, point to the New submenu and create a new DWORD value with this name.

Double-click the OEMBackground value and set its value to 1.

Note that selecting a new theme in the Appearance and Personalization window will “unset” this registry value. Selecting a theme will change the value of the key to the value stored in the theme’s .ini file, which is probably 0 – if you change your theme, you’ll have to perform this registry tweak again.

Changing the setting in group policy will allow it to persist even when you change your theme, but the Group Policy Editor is only available in Professional editions of Windows.

If you have access to the Group Policy Editor, launch gpedit.msc from the Start menu.

Navigate to the following section in the Group Policy Editor window:

Computer Configuration\Administrative Templates\System\Logon

You’ll find a setting named “Always use custom login background.” Double-click it and set it to Enabled.



Setting An Image


Your image file must be less than 256 KB in size. It’s also a good idea to use an image file that matches the resolution of your monitor, so it won’t look stretched.

Windows looks for the custom logon screen background image in the following directory:

C:\Windows\System32\oobe\info\backgrounds

By default, the info and backgrounds folders don’t exist. Navigate to the C:\Windows\System32\oobe folder and create them yourself by right-clicking inside the folder, pointing to New, and selecting New Folder.

Copy your desired background image to the backgrounds folder and name it backgroundDefault.jpg.

The change will take effect immediately – no system reboot required. The first time you log out or lock your screen (try the WinKey-L keyboard shortcut), you’ll see your new background.



Regard's
Dilip Patel
0
 
LVL 19

Expert Comment

by:helpfinder
ID: 38814270
isn´t it a problem with permission of folder where the picture is placed? Try to set NTFS permissions on the folder and file to be accessible by Everyone
0
 

Accepted Solution

by:
drifted earned 0 total points
ID: 38814430
we dont seem to have “Always use custom login background.” in our templates.

I have been able to do this manually on a single machine, I would just like a good GPO to move the file to C:Windows> System32> oobe> info> backgrounds

The folder creates fine with the permissions I just cannot get the jpg to move in there through the file GPO.
0
 
LVL 1

Expert Comment

by:PTEExchange
ID: 38815711
As an alternate idea to GPO as I also found this a bit buggy we did this via MSI instead.

If you have experience of creating MSIs then just create and MSI that records the changes and deploy.
0
 

Author Closing Comment

by:drifted
ID: 39539260
Issue resolved
0

Featured Post

Looking for the Wi-Fi vendor that's right for you?

We know how difficult it can be to evaluate Wi-Fi vendors, so we created this helpful Wi-Fi Buyer's Guide to help you find the Wi-Fi vendor that's right for your business! Download the guide and get started on our checklist today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Postmortem reporting allow us to examine mistakes in a way that focuses on the situational aspects of a failure’s mechanism and the decision-making process of individuals proximate to the failure. Read our guide on how to handle IT post-mortem repor…
A new hacking trick has emerged leveraging your own helpdesk or support ticketing tools as an easy way to distribute malware.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question