• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 816
  • Last Modified:

Tags in SharePoint Tag Cloud not clickable

I have setup the Tag Cloud webpart in SP 2010 and I can see tags in the cloud. However, none of these tags are clickable. I am the administrator on the site so I do not believe it is a permissions issue - and I have processed the Timer jobs to make sure the tags were processed - just to be sure.

How can I make these tags clickable so that users can jump to the associated tagged articles or files?
0
jcaiola
Asked:
jcaiola
  • 5
  • 3
1 Solution
 
Rainer JeschorCommented:
Hi,

I have not seen this behavior before. Can you verify the HTML source of your page (e.g. using IE Dev Tools).

HTH
Rainer
0
 
jcaiolaAuthor Commented:
Sorry, I'm not sure what you are asing me to do here.
0
 
Rainer JeschorCommented:
Hi,

depending on your IE version (I assume you have IE9):
Just open the page with the tag cloud web part and then click "F12".  This will open IE Developer tools. You should see then the source of the page. Position the developer tools window side-by-side with your browser window.
Using the arrow button in the top left corner (of the dev tools window) you can then click on the tag cloud area (in the browser window) and you will see the source (dev tools window will automatically navigate to the right position).

HTH
Rainer
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
jcaiolaAuthor Commented:
Thanks.

The source is as follows when I click on the tag:

<div class="ms-TagCloud ms-TagCloudLink" id="tagCloudDatactl00_m_g_936df906_d015_4ca7_8a39_8517a1cd78ea">


Is this what you want?
0
 
Rainer JeschorCommented:
Yes, thats the container. And inside of this div you should see the entries like
<A class=rank1 href="http://mysites.dev.XXX.local:8080/tagprofile.aspx?termid=3b8dc2dc-1322-43ed-b004-a3428914ecff">SharePoint Tag (1)</A>

Open in new window

0
 
jcaiolaAuthor Commented:
I have tagged only one item "training" and I do not see that in the HTML - which I think is okay, but I see no items referencing any URLs.

I see the below:

<TD vAlign=top>
<DIV id=WebPartWPQ3 class="ms-WPBody noindex ms-wpContentDivSpace" allowDelete="false" width="100%" HasPers="false" WebPartID="2b33dbe9-4b72-45a4-a1c6-020d94fd8b52" allowRemove="false" WebPartID2="936df906-d015-4ca7-8a39-8517a1cd78ea">
<DIV id=tagCloudBodyctl00_m_g_936df906_d015_4ca7_8a39_8517a1cd78ea>
<DIV id=tagCloudDatactl00_m_g_936df906_d015_4ca7_8a39_8517a1cd78ea class="ms-TagCloud ms-TagCloudLink"><SPAN class=rank5.5>Training</SPAN></DIV></DIV></DIV></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></DIV>
<DIV style="DISPLAY: none" id=vid_936df906-d015-4ca7-8a39-8517a1cd78ea></DIV></DIV>&nbsp;
0
 
jcaiolaAuthor Commented:
I found the solution to this which was a misconfiguration issue within SharePoint.

Thanks
0
 
jcaiolaAuthor Commented:
User error more than anything.
0
 
NikkiGuCommented:
Hi jcaiola,
What was the solution? I appear to have the same problem.
Thanks,
Nikki
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now