?
Solved

Tags in SharePoint Tag Cloud not clickable

Posted on 2013-01-24
9
Medium Priority
?
794 Views
Last Modified: 2014-09-30
I have setup the Tag Cloud webpart in SP 2010 and I can see tags in the cloud. However, none of these tags are clickable. I am the administrator on the site so I do not believe it is a permissions issue - and I have processed the Timer jobs to make sure the tags were processed - just to be sure.

How can I make these tags clickable so that users can jump to the associated tagged articles or files?
0
Comment
Question by:jcaiola
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
9 Comments
 
LVL 44

Expert Comment

by:Rainer Jeschor
ID: 38818789
Hi,

I have not seen this behavior before. Can you verify the HTML source of your page (e.g. using IE Dev Tools).

HTH
Rainer
0
 

Author Comment

by:jcaiola
ID: 38819149
Sorry, I'm not sure what you are asing me to do here.
0
 
LVL 44

Expert Comment

by:Rainer Jeschor
ID: 38819196
Hi,

depending on your IE version (I assume you have IE9):
Just open the page with the tag cloud web part and then click "F12".  This will open IE Developer tools. You should see then the source of the page. Position the developer tools window side-by-side with your browser window.
Using the arrow button in the top left corner (of the dev tools window) you can then click on the tag cloud area (in the browser window) and you will see the source (dev tools window will automatically navigate to the right position).

HTH
Rainer
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 

Author Comment

by:jcaiola
ID: 38819227
Thanks.

The source is as follows when I click on the tag:

<div class="ms-TagCloud ms-TagCloudLink" id="tagCloudDatactl00_m_g_936df906_d015_4ca7_8a39_8517a1cd78ea">


Is this what you want?
0
 
LVL 44

Expert Comment

by:Rainer Jeschor
ID: 38819423
Yes, thats the container. And inside of this div you should see the entries like
<A class=rank1 href="http://mysites.dev.XXX.local:8080/tagprofile.aspx?termid=3b8dc2dc-1322-43ed-b004-a3428914ecff">SharePoint Tag (1)</A>

Open in new window

0
 

Author Comment

by:jcaiola
ID: 38820403
I have tagged only one item "training" and I do not see that in the HTML - which I think is okay, but I see no items referencing any URLs.

I see the below:

<TD vAlign=top>
<DIV id=WebPartWPQ3 class="ms-WPBody noindex ms-wpContentDivSpace" allowDelete="false" width="100%" HasPers="false" WebPartID="2b33dbe9-4b72-45a4-a1c6-020d94fd8b52" allowRemove="false" WebPartID2="936df906-d015-4ca7-8a39-8517a1cd78ea">
<DIV id=tagCloudBodyctl00_m_g_936df906_d015_4ca7_8a39_8517a1cd78ea>
<DIV id=tagCloudDatactl00_m_g_936df906_d015_4ca7_8a39_8517a1cd78ea class="ms-TagCloud ms-TagCloudLink"><SPAN class=rank5.5>Training</SPAN></DIV></DIV></DIV></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE></DIV>
<DIV style="DISPLAY: none" id=vid_936df906-d015-4ca7-8a39-8517a1cd78ea></DIV></DIV>&nbsp;
0
 

Accepted Solution

by:
jcaiola earned 0 total points
ID: 39022374
I found the solution to this which was a misconfiguration issue within SharePoint.

Thanks
0
 

Author Closing Comment

by:jcaiola
ID: 39035246
User error more than anything.
0
 

Expert Comment

by:NikkiGu
ID: 40353872
Hi jcaiola,
What was the solution? I appear to have the same problem.
Thanks,
Nikki
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SharePoint Designer 2010 has tools and commands to do everything that can be done with web parts in the browser, and then some – except uploading a web part straight into a page that is edited in SPD. So, can it be done? Scenario For a recent pr…
A recent project that involved parsing Tableau Desktop and Server log files to extract reusable user queries for use in other systems. I chose to use PowerShell to gather the data, and SharePoint to present it...
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question