Solved

Cannot Assigne Full Access Permissions To User's Mailbox Since Moving To Exchange 2010

Posted on 2013-01-24
13
459 Views
Last Modified: 2013-03-04
Hello,  I have just recently finished moving all our user mailboxes over to Ex2010 from Ex2007.  User mailboxes retained their Full Access permissions from Ex2007.  Okay, here is the problem.   New mailboxes created on Ex2010 - I cannot assign Full Access permission to some specific security groups we have set up in house.    For example, every user mailbox is modified with Full Access Permission for 3 site security groups (Leadership Group, Admin Assistants Group and System Administrators Group).   Worked fine on Ex2007.  However, on EX2010, these groups do not even appear in the list of users and groups in the
SELECT USER OR GROUP - ENTIRE FOREST.

When I search for the group name, it cannot be found????
Really need to have these permissions set, but no idea what the issue is.  Please advise.  Thanks.
0
Comment
Question by:rstuemke
  • 7
  • 4
  • 2
13 Comments
 
LVL 5

Expert Comment

by:Dilip Patidar
ID: 38814832
Hello,

You can try below command:

Get-DistributionGroupMember “Test Group” | foreach-Object { Add-MailboxPermission “Usermailbox” –AccessRights FullAccess –user $_.Name}

Regard's
Dilip Patel
0
 
LVL 18

Expert Comment

by:irweazelwallis
ID: 38814834
can you try adding them through powershell to see if you get a different error

Add-MailboxPermission -Identity "John Doe" -User yli -Accessright Fullaccess -InheritanceType all
0
 
LVL 5

Accepted Solution

by:
Dilip Patidar earned 500 total points
ID: 38814848
Hello,

You can also try this:

Add-AdPermission -Identity "User Mailbox login account Name" -User "Universal security group" -AccessRights readproperty, writeproperty _properties "Personal Information"

Get-Mailbox -Identity "User Mailbox Name" | Add-MailboxPermission -User "Universal security group" -AccessRights fullaccess

This can also try :

Get-Mailbox | Where { $_.Database –eq “” } | Add-AdPermission -User “Domain Admins” -AccessRights extendedright -ExtendedRights “send as

Regard's
Dilip Patel
0
 

Author Comment

by:rstuemke
ID: 38814857
Update......correction.... 2 of the 3 groups do not show up.... leadership and assistants groups.   Administrators groups does show up.  So perhaps it is a permissions problem.
Other site created security groups do appear.  I checked the security permissions on the groups that appear against those 2 that do not and they appear identical.
0
 

Author Comment

by:rstuemke
ID: 38814868
Went back to a user that was moved from EX2007 and these 2 groups are not visible if I try to modify Full Access permissions there either.   Just checked, even though I knew they would be missing.
0
 
LVL 18

Expert Comment

by:irweazelwallis
ID: 38814989
are they in the same domain/forest and what kind of groups are they ie. Domain Local , Global, Universal
0
Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 

Author Comment

by:rstuemke
ID: 38814993
Yes, I have a script that will add the permissions to all the users.  It works fine.  I ran it and the permissions are there.  Should have mentioned it  My comment about really needing to get the permissions installed was a bit misleading.  Sorry.

However, part of the procedure when creating a user mailbox is to add them when the user mailbox is created.  It is easier to just do it then, so I would like to actually correct the problem.
0
 
LVL 18

Expert Comment

by:irweazelwallis
ID: 38815368
if they are already added it won't let you add them a second time.
0
 

Author Comment

by:rstuemke
ID: 38815707
Yes, I know.      They were not added, though when I tried to add them thru the EMC, these 2 groups do not show up.  That is the real problem.  the groups do not appear in the list of users and groups - entire forest.  Let's not confuse that fact that I added the permissions thru a script.  Thanks,
0
 

Author Comment

by:rstuemke
ID: 38815713
These missing 2 groups showed up fine when the mailboxes were on the Ex2007 server.  Were never missing from the list.
0
 
LVL 18

Expert Comment

by:irweazelwallis
ID: 38815850
ok back to the previous question

what kind of groups are they?
Are the in the same domain/forest
0
 

Author Comment

by:rstuemke
ID: 38818563
They are security groups.  All same forest and domain.
0
 

Author Closing Comment

by:rstuemke
ID: 38950490
Resorted to just using the command line to add permissions.  Works fine.  Thanks.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

"Migrate" an SMTP relay receive connector to a new server using info from an old server.
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now