Solved

BESX - device only receiving internal emails but can send both

Posted on 2013-01-24
9
459 Views
Last Modified: 2013-05-23
Hi

This one is driving me crazy!  My client has about 15 Blackberry devices with BESX running on Windows 2003 SBS and Exchange Server 2003.  One user/device is not receiving EXTERNAL emails.  Internal emails receive OK and the device will send to both internal and external addresses.  I have checked the firewall settings on the device - Enterprise Email is un-ticked.  I have checked filters - there are none.  I have set up a test user on the device and external email works OK.  I have therefore concluded that the problem is user related but I'm running out of ideas.

Any help would be greatly appreciated!

Thanks

Glen
0
Comment
Question by:Glen_TTL
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 38845255
Have you tried checking the logs for the user? There should be some type of log for it if there is an error some where.
0
 

Author Comment

by:Glen_TTL
ID: 38851592
Hello rbarnhardt

Thanks for your suggestion - I have checked the logs and indeed there are errors for this user, notably:

MAPIMailbox::CheckSelectedFolders - OpenEntry (0x80004005) failed

Further research suggests that exporting everything to a PST, purging the mailbox then recreating will sort this problem.

I'll endeavour to do this tomorrow and I will let you know how I get on.

Thanks for your advice.

Glen
0
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 38853566
It could be the hidden file that BB puts in is corrupt. You may be able to remove them from the server, and when it ask if you want to remove the BB data from the inbox, click yes. Open Outlook with  /resetfolders, then re-add them to the server. It could also be a connection issue  http://support.microsoft.com/kb/830829/en-us or http://btsc.webapps.blackberry.com/btsc/viewdocument.do?noCount=true&externalId=KB20878&sliceId=2&cmd=displayKC&docType=kc&ViewedDocsListHelper=com.kanisa.apps.common.BaseViewedDocsListHelperImpl
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 

Author Comment

by:Glen_TTL
ID: 38860464
Hello rbarnhardt

Thanks for your further advice.  I did get to the customer late yesterday afternoon but the export of around 20 GB of emails was going to take too long.  I have rescheduled this for a future visit (one starting much earlier!) and will keep you updated.

Thanks

Glen
0
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 38861638
20GB! Do you think they could delete some email? The device has a size limit. You may want to check the amount of free memory on the devices. Users like this is why we have a 500MB to 1GB mailbox quota limit.
0
 

Author Comment

by:Glen_TTL
ID: 38868867
Hello rbarnhardt

I have to confess at being surprised when I saw this myself!  Not all folders are being synchronised with the device but I will check to ensure the limits aren't being exceeded.  If I was to even hint at mailbox limits I'd probably be shot.  I will see if we can archive some older emails though.

Thanks once again for your input.

Glen
0
 

Author Comment

by:Glen_TTL
ID: 39024998
OK, here's an update.  I finally managed to seperate the device from the user, export their emails to a PST, delete the mailbox, delete the user from BESX, recreate the mailbox, import the emails, create the user in BESX and configure the device.  The user can now receive external emails, but contacts are not synchronising to the device.  I have researched various causes of this problem but I have been informed that my client may be moving to new smartphones so this may no longer be an issue for this user.

Thanks to rbarnhardt for your advice.

Glen
0
 
LVL 32

Accepted Solution

by:
Rodney Barnhardt earned 500 total points
ID: 39025073
I have actually had this happen. Do the following:
Go to Options > Advanced Options > Enterprise Activation and in the email field press and hold the ALT key and type CNFG.  Once you enter this a hidden menu will appear and you need to change "Wireless Sync" to No, now exit this menu and wait 30 seconds and repeat the process but turn sync back to Yes.

You can Google "Blackberry CNFG". You will see people using this process to correct the problem. There is even a KB on it.

http://btsc.webapps.blackberry.com/btsc/viewdocument.do;jsessionid=F2452FEBF0B99C8FB3D505D7595C9983?externalId=KB24765&sliceId=2&cmd=displayKC&docType=kc&noCount=true&ViewedDocsListHelper=com.kanisa.apps.common.BaseViewedDocsListHelperImpl
0
 

Author Comment

by:Glen_TTL
ID: 39104770
My client has now moved away from Blackberry so the problem has effectively gone away, although it would have been good to try rbarnhardt's suggestion.  This question can therefore now be closed.  Thank you.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question