Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1059
  • Last Modified:

SonicWall SSL VPN Setup

I am currently trying to configure the SSL VPN for our X1 WAN port that has a range of assigned IP addresses on it.  It is setup except for the last part which is to enable user login via https for the x1 interface.  

The SSL VPN IP is not the first address on the interface.  So when I enable the SonicWall https user login for X1 it kills my policy to send the first assignable address to a webserver and instead sends it to the SonicWall login page.  Is there a way to configure it so a seconary IP goes to the login screen and not the first usable on the interface?
0
metricsinc
Asked:
metricsinc
  • 4
  • 4
1 Solution
 
Aaron TomoskySD-WAN SimplifiedCommented:
You can give send each external ip to anything you want. Just male an address object and assign it
0
 
metricsincAuthor Commented:
Thanks for the reply.  We have quite a few address objects for sending our other IP's to internal resources.  The problem is I can't seem to make an address object that points to the SonicWall User Login page?  I will go look again though and see if there is something I missed.
0
 
Aaron TomoskySD-WAN SimplifiedCommented:
Maybe I misunderstood. Are you sharing an external ip with the sonicwall and an internal web server?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
metricsincAuthor Commented:
We have 3 IP's coming into the X1 interface.
1st IP goes to internal webserver
2nd IP goes to another internal webserver
3rd IP needs to redirect to the SonicWall SSL VPN login

If I follow the SW instructions for the setup then as soon as I enable https for user login on the interface it sends the first IP to the sonicWall login page.  I need the 3rd IP to go there instead.

I have created an address object for the 3rd public IP on X1 but when I go to setup the NAT policy there is a "https managment" object I can select but there isn't an "https user login" object.  So not quite sure how to redirect the 3rd IP to the login page?

Hope this helps explain the problem better...
0
 
Aaron TomoskySD-WAN SimplifiedCommented:
I have a firewall rule:
WAN      >      WAN      5      Any      WAN Interface IP      SSLVPN

in address objects, I have a group called:
WAN Interface IP
and in it is the object WAN Primary IP

SO messing with the firewall rule is probably the safest place not to break anything else you have going on.
0
 
metricsincAuthor Commented:
Yes I have that same rule and it works on the first IP port 4433 the problem is that rule is auto created when WAN SSL VPN is enabled.  So that rule takes over my rule where WAN Interface IP is "CompanyVPN Public"

So their rule is enforced and mine is ignored.

I guess I need to figure out how to enable the SSL VPN without it creating the rule for WAN Interface IP...
0
 
Aaron TomoskySD-WAN SimplifiedCommented:
Can you change the rule priority?
0
 
metricsincAuthor Commented:
OK that works now I just need to make sure I get the correct NAT Policy and it may work like I want it to.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now