Arbitration mailboxes and Discovery do not show up using PowerShell Get command

Posted on 2013-01-24
Last Modified: 2013-02-04
We have been running Exchange SP1 Update Rollup 6 now for some time. I was doing some reading in my Exchange book and came across a section on System and Discovery Mailboxes. There are 4 mailboxes and the user accounts get created in the root Domain. I did check and the accounts are there and disabled like they should be. However, when I try to display the mailboxes using PowerShell on Exchange, nothing comes back. A get-mailbox -Arbitration produces nothing. The Discovery Search Mailbox shows up in the GUI just like any other recipient but I can't display it in PowerShell using the Display name or alias. I just get an error saying the mailbox is not found.

I will tell you that I can and have been doing Discovery searches right along with no issues. I don't think these mailboxes were deleted because we have been running like this for at least a year with no issues at all. Is there a situation where these mailboxes just won't display to keep you from deleting them? I know you can recreate the arbitration mailboxes but I don't want to do that if they are already there and I am just not viewing them correctly.
Question by:osiexchange
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
LVL 43

Accepted Solution

Amit earned 275 total points
ID: 38815524
Try this
Get-Mailbox -Database "DB Name" -Arbitration | fl name, alias

Author Comment

ID: 38815577
That did not work either. After I posted the above, I did using ADSIEdit to view the accounts and look at the attributes for all 4. They all have a value in HomeMDB and HomeMTA so it looks like these accounts do have mailboxes but I can't display them in PowerShell and only the DiscoverySearchMailbox shows up in the GUI.

Author Comment

ID: 38815639

When I dump the mailboxes to a .csv file using the get-mailbox -database command and open in Excel, I do see the mailboxes. A few show up with the Display Name

Micrsoft Exchange - One of the System Mailboxes
Microsoft Exchange Approval Assistant - FederatedEmail mailbox

So it looks like the mailboxes are there. Shouldn't they show up with the -arbitration switch?

I can't get them to display even with the display name using PowerShell.
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.


Author Comment

ID: 38819513
I escalated this to MSPS.

Assisted Solution

osiexchange earned 0 total points
ID: 38819671
The problem was I was not specifying a Domain Controller in the Forest root where the accounts live when I ran the get-mailbox command. Exchange is installed in a child Domain but the accounts live in the Forest Root. I ran the command below which found the mailboxes

Get-mailbox -arbitration -DomainController "Root DC name"
LVL 43

Expert Comment

ID: 38819690
Thanks for sharing.

Author Comment

ID: 38819700
Even MS was confused on that one. It took them about 15 minutes to figure it out.
LVL 43

Expert Comment

ID: 38819721
It's strange that these mailboxes reside at forest level.

Author Closing Comment

ID: 38850506
I escalted to Microsoft for conclusion.

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question