Solved

I want to share Wifi across my LAN and out a WRT54g WiFi router

Posted on 2013-01-24
11
935 Views
Last Modified: 2013-01-27
My girlfriend and I have moved for four months to a new city and I've opted to not buy Internet here due  setup costs, monthly payments and early cancellation costs.

I brought along the following:

- a Yagi Wifi antenna
- a WRT54g router (running DD-WRT firmware)
- a PC computer (an Intense PC by CompuLab)
- an Apple Mini MAC
- an iPhone, iPad, Kindle Fire and a NetBook

My PC has Wifi antennas on it and I'm able to remove one of them and to connect the Yagi WiFi antenna to it so that I can access WiFi signals at some distance.

I've found a University in the area from which I can obtain WiFi signal.  This WiFi works on my Intense PC just fine.

What I want to do now is to run a CAT5 cable from the Intense PC's LAN port to the WRT54g, another CAT5 cable from my WRT54g to my Apple Mini MAC and then also have the WRT54g broadcast WiFi locally here in our apartment so that all my other devices can access the Internet via WiFi.

Note that none of my other wireless devices can use the University's signal because, without the Yagi, it is too weak.

And this is where I'm hung up.   I cannot get the PC's Internet shared out via the PC's LAN port.

I've read about Bridges and ICS sharing.  

I've read that creating a bridge on my PC between the WiFi and the LAN port is not a wise idea as it will make everything on my local LAN visible to folks out on the Internet.  So, I've avoided that.

I'm thinking that ICS should do what I want but I can't get it to work.   I'm not sure if my problem is with the ICS setup or with how I'm trying to use, or misuse, the WRT54g.

What I'm expecting the WRT54g to do is to share whatever comes in on the LAN port from the PC out onto its other three LAN ports and also out over the WiFi it is broadcasting.

To setup ICS, I go to the the PC's network connections, select the WiFi connection and go to the sharing tab and click on "Allow other network users to connect through this computer's Internet connection".

Then it tells me that ICS will make the IP address of the LAN port be 192.168.0.1.  That's not a problem as I'd already set it manually to be 192.168.0.1.

Now, in the network connections, when I look at the WiFi connection, I see it is shared, it is a public network and it has Internet access.  It's getting its IP and DNS stuff via DHCP.

When I look at the LAN connection, I see it is described as an unidentified network, has no Internet access and is described as a public network.  It has an IP address of 192.168.0.1, mask of 255.255.255.0 and no gateway information (I read the gateway is suppose to be left blank).   I've also entered in two DNS IP addresses that I know are valid.

The WRT54g is manually set to IP = 192.168.0.2 and the Mini MAC is IP = 192.168.0.3.  I'm intending that the other devices will get their IPs from the WRT54g's DHCP.

My wireless devices (iPhone, iPad, etc.) are all finding the WRT54g OK.   From the Mini MAC, I can ping the WRT54g and any of the wireless devices linked to the WRT54g.  

But I cannot ping the PC @ 192.168.0.1 from the Mini MAC.  Nor is Internet being shared to the Mini MAC nor any of the wireless devices linked to the WRT54g.

Help, experts.  What am I missing here?
0
Comment
Question by:gallymon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
  • 2
11 Comments
 
LVL 17

Expert Comment

by:TimotiSt
ID: 38816947
Easiest way might be to but a cheap WiFi bridge (like a TP-link AP), hook up the Yagi to that, and connect a switch to its wired port. So you won't have to keep the PC running all the time.

Tamas
0
 

Author Comment

by:gallymon
ID: 38816962
Not a bad idea, Tamas, but I'm in New Zealand an the cables I'd need to connect the Yagi to the TP-Link AP would need to be made and shipped from the USA.  Expense and time say, 'no'.  I'm looking for a way to share the WiFi the PC's got without more hardware.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38817088
> Then it tells me that ICS will make the IP address of the LAN port be 192.168.0.1

A CompuLab Intense-PC should have come with Win7 on it... Win7's ICS uses the 192.168.137.0 subnet, not 192.168.0.0.

I would set the LAN adapter to DHCP, disable the ICS, then enable it again to let the ICS setup change the adapter's IP address to what ICS wants.  Then either set the WAN port in the Linksys to use automatic/DHCP and leave its LAN side using the default 192.168.1.0 subnet, or don't use its WAN port at all - just connect to one of its LAN ports instead and Disable the DD-WRT DHCP server on the Setup->Basic Setup tab (letting the ICS assign IP addresses). Then you can either not use the WAN port at all, or check the Assign WAN Port to Switch and turn it into a 5 port switch if you need the extra ethernet port.

Possibly you'll need to delete the bridge you made in ncpa.cpl before ICS will work, too.
0
Upcoming Webinar: Securing your MySQL/MariaDB data

Join Percona’s Chief Evangelist, Colin Charles as he presents Securing your MySQL®/MariaDB® data on Tuesday, July 11, 2017 at 7:00 am PDT / 10:00 am EDT (UTC-7).

 
LVL 17

Expert Comment

by:TimotiSt
ID: 38818190
Okay. Did you try bridging the wired and wireless adapter in windows, and assigning the bridge an IP address?
0
 

Author Comment

by:gallymon
ID: 38821507
Darr247.   I like what you wrote.   It's the weekend here in New Zealand and I'll give this a try on Monday.

TimotiSt.   I'm shying away from the Bridge option as I've read it can give folks out on the Internet access to my LAN here.   Not sure if that's true but I'm avoiding it until I hear different - and why.
0
 

Author Comment

by:gallymon
ID: 38823635
Darr247,

I've long since destroyed the bridge.  
I've disabled the DHCP server over on the WRT54g.
I turned off sharing on the Intense PC's WiFi port.
I set the Intense PC's LAN port to get its address via DHCP.
I enabled Sharing on the Intense PC's WiFi port.  

ICS always sets the LAN port to 192.168.0.1.

Your thoughts?
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38823654
What version of Win7 is it?
SP1?
0
 

Author Comment

by:gallymon
ID: 38823665
Win 7 Home Premium Service Pack 1.
0
 
LVL 44

Accepted Solution

by:
Darr247 earned 500 total points
ID: 38824497
Try it again.

Disable ICS in the Wireless Network Connection's Properites on the Sharing tab.

Reboot the computer.
People have almost forgotten how, as recently as Win98me and Win2k, rebooting the computer was required whenever *any* change to network settings was made.  ;-)

In the Wireless Network Connection's Properties, enable ICS on the Sharing tab, and choose the Local Area Connection (the LAN adapter) from the Select a private network connection picklist.

It's up to you whether you choose to enable the 2 options below that, though if you ever want to use remote desktop from outside your LAN you can check the box next to Remote Desktop under the Settings... button, which will make an extra hole in windows firewall so you can access remote desktop through that connection.

Now check to see if the Local Area Connection (LAN port) is getting the the proper 192.168.137.1 IP address in its "Internet Protocol Version 4 (TCP/IPv4)" Properties. If it's still not, check under the Advanced... button there (on the IP Settings tab), and also on the Alternate Configuration tab (for a 'user configured' IP address).
0
 

Author Comment

by:gallymon
ID: 38825280
Darr247, I'm going to award you the points on this one because you knew what should happen.

So, I solved the problem but it was a bit different that you might think.

I have two copies of Win7 on my system; both boot-able.  One came with the Intense PC and is Win7 Professional.  The other was transferred over from my previous machine using the tools and tricks that Paragon Hard Disk Manager 12 knows how to do.   It was Win7 Premium Home.   Most of the time, I've been running the latter since most of my stuff is still resident there.

It was the latter that I was having such a lot of trouble with.  Once I changed my focus over to the Win7 Professional, everything happened exactly as you said and the LAN port came up and 192.168.137.1 and we were off and sharing.

So, my suspicion is that when Paragon scrapes an OS off one machine and moves it over and rewired the drivers under it to conform to the new h/w, that there's a little something that gets lost along the way.

Ah, well, this is the incentive I needed to get my remaining stuff of the Home Premium version and over onto the Professional.

Thanks for your help!

Dennis
Wellington, New Zealand
0
 

Author Closing Comment

by:gallymon
ID: 38825282
Good help!
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Netscaler #MSSQL #Load Balance
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question