Solved

Random system freezes:  How nail down cause(s)

Posted on 2013-01-24
13
526 Views
Last Modified: 2013-02-02
My computer has several problems which have accrued over the last year or more.  However, the currently greatest obstacle to ordinary usage of my computer are its frequent, random, freezes.  The two changes I have made in the last year have been to
- increase ram from 4Gb to 8Gb under XPx32, anticipating my
- move to a dual boot with 07x64.

The freeze problem began before either of these changes but has gotten much worse in the last year.  Indeed, despite having installed the ram months before moving to the dual boot, it was the dramatic increase of freeze and other problems that scared me into actually installing the dual boot so I could learn Win7 and migrate to it completely but over time.  I thought that some undiscoverable bug had so corrupted XP that I was in danger of losing important work.  (Even though I have used WHS 2003 happily since 2008).

At one point, I thought I had eliminated the problem when I replaced the WD drive that held the system files with an equally old but unused Maxtor.  (pagefile on different drive.)  For several days after the replacement, the computer seemed to behave properly, for example, no freezes.  But the problems have returned.

The freeze occurs absolutely anywhere:
- any point in boot up / post including
- any time during mem count
- any time up to dual boot choice
- before, during, after welcome screens
- any time during completion of boot after OS start
- any time during any length idle with or without screensaver
- during use of any single or multiple programs
- during backup (WHS reports connection broken).

I ran the Win7 repair and mem check routines and CHKDSK.  All report the system fine every time run.

The trial version of AIDA64 Extreme stress test seems to report nothing wrong.  The only thing I did was start it, let it cycle through all systems until hard disks had finished 4 times.  Since the screen graph said TRIAL while displaying cpu temp and something else, I ran the report wizard.  The extremely long report gave stats but no proactive indication of anything wrong.

I thought perhaps there was something wrong with the motherboard but do not know how to diagnose that or any other hardware individually or together.  Except for my untutored use of Aida64, above.

The GPU seems to also be okay, although very, very rarely under Win7
- a window will freeze
- a streaming window will freeze the system as audio becomes a very rapid stutter that persists through the system freeze
- moving a window produces a string of windows

Going by my reading of a search of the voluminous EE archives on random freezes, I assume there is no way for anyone here to actually resolve my particular version of the issue.  Given this assumption, I guess I am seeking suggestions of doable, substantive courses of action other than scrapping what may still be a wonderful assemblage or inviting some professional to take a look.  (My experience gives me much, much more hope and faith in EE than in any computer mavin I could find or pay for.)  

In the meantime, I have just ordered Corsair memory at 1333 Hz to replace the 1600Hz I have used since the beginning.  

Thanks for any help.

_____________________________________________________
PS
All Win7 system and device drivers,  and installed software are up to date though I assume this is irrelevant to the frequent pre OS freezes during boot up.  Pre OS freezes seem to be less frequent --- though still present --- once the machine has warmed up.

There are at least two Win7 operation peculiarities that make me think Win7 may have some sort of additional memory problem:
- 07x64 responds more slowly than XPx32, as if it is doing a lot of background work
- WHS fails to backup one of my drives under Win7 but continues to back it up under XP.
Under Win7, the system freezes only when backing up this drive thus breaking connection to WHS. Increasing free space on the drive to 100+Mb does not help and is unnecessary under XP.

_____________________________________________________
Build Date......:  June 2008
OS-dual boot:   Windows XP Pro x32 SP3 (active) - Windows 7 Pro x64 SP1
Power Supply:  Thermaltake W0131 Toughpower 850W
Motherboard.:  Asus P5E64 WS EVOLUTION  BIOS v0802.
CPU................:  Intel Core2 Quad Q6600 @2.40GHz  2.39Ghz (2008)
Memory.........:  Corsair 8 Gb XMS3 DDR3 @ 1600Hz (2008)
Graphics Card: EVGA e-GeForce GTX 275 (2008)
Mouse...........:   Inland PS2 hardwire (Microcenter house brand, I think) (2012)
Keyboards.....:   Inland PS2 hardwire (Microcenter house brand, I think) (2012)
KVMA switch..:  CablesToGo Truelink 4-port (2008)
DISK Drives:
01..........:  STM3500630AS           (XPx32 - 07x64)
02..........:  WD1600AAJS-08PSA0 (PageFile; tech data)
03..........:  WD1001FALS-00J7B0  (data)
04..........:  WD10EACS-00ZJB0      (data)
05..........:  WD10EADS-00L5B1     (data)

Systray items:
WHS 2003 Connector
Logitech Orb webcam
AnyDVD
CloneCD Tray
Nvidia Settings
Active Desktop Calendar
Clam Sentinel
ClamWin
PrivateFirewall
HT OMEGA CLARO
virtual Clone Drive
0
Comment
Question by:blacktide
13 Comments
 
LVL 14

Accepted Solution

by:
JohnnyCanuck earned 200 total points
ID: 38816797
First thing I'd do is drop the memory down to 2 or 3 gb until the problem is sorted.  Then check your motherboard's capacitors for bulging or leaking as the symptoms are similar to what you get with bad caps - see the following link.

http://www.badcaps.net/pages.php?vid=5

Then I'd swap out the power supply - bad power can cause unusual behavior.  If nothing shows up by this time I'd remove all but the bare necessities - cpu, 1 stick of ram, video card (use onboard video).  Check system with live Linux disk (Knoppix, Ubuntu or something similar).  Test and post results
0
 
LVL 47

Assisted Solution

by:dbrunton
dbrunton earned 160 total points
ID: 38816803
I'd try the various tests.

Memory using the UBCD http://www.ultimatebootcd.com/download.html  Download links are the icons at the top of the page.  Burn the image to a CD and boot from it.

Also remove memory chips to a bare minimum and run the system like that.  See if the problmes go away with a minimum memory configuration.

Try running a Live Linux CD such as Ubuntu https://help.ubuntu.com/community/LiveCD  See if Ubuntu runs stabily or not.

Might be tempted to try another graphics card if you have a spare one.

Other experts will comment as well with other opinions.
0
 
LVL 91

Assisted Solution

by:nobus
nobus earned 140 total points
ID: 38817777
in your case, you can troubleshoot 2 ways : hard or soft.
since you had the problems on 2 different OS'es, i suggest the problem is hardware
as said, run diags for Ram and disk from the UBCD is a good first step; HOWEVER be aware that the test should run at least 2x the time between the Freezes - which may take LONG, very LONG.
so my firts step would be to reduce the system to its minimum setup  - disconnect all external devices, extra disks, and cd drives, and cards...
see details in my guide  :
http://www.experts-exchange.com/Hardware/Components/Motherboards/A_1945.html                  (Short-overview-of-how-to-troubleshoot-bad-hardware-when-a-pc-does-not-post)

to be complete -  here's how to handle disk problems :
http://www.experts-exchange.com/Storage/Hard_Drives/A_3000-The-bad-hard-disk-problem.html
0
 

Author Comment

by:blacktide
ID: 38822889
Johnnycanuck  ID: 38816797
dbrunton           ID: 38816803
nobus                 ID: 38817777

Thanks for your responses.  

As you know from my initiating query, I too suspect ram first.  Before asking here at E-E, I actually did remove the second pair of memory sticks to see what would happen.  The problem persisted, so I put them back in not knowing what next steps to take.

I say "first" because I also suspect the EVGA card.  I went to their site hoping to find a software diagnostic tool but found none.  I will look again there and also try the Nvidia site directly.

I do not have any spare parts except for hard drives.  I will have to cannibalize my other --- in use --- machines to do swap outs.  The unexpectedly low price of memory combined with both Asus and Corsair sites recommending only the lower frequency memory led me to make that purchase.  Comparable or better replacements for my EVGA (GPU) and Thermaltake (PSU) would be sort of pricey for me.

I have already downloaded the disc image files you have suggested.  I am printing out your comments, and texts from the suggested links.  I take your consensus point to strip working parts to essentials, especially staying at 4Gb or even 2Gb of ram if I can get away with it.

So, with our conversation to date in mind, my immediate plan is to get the software together, inspect the capacitors (which I did before I started this thread) in case something has become more visible there and get back to you.  This will take some time.

Thanks again.
0
 
LVL 91

Expert Comment

by:nobus
ID: 38823622
>>  did remove the second pair of memory sticks   <<  now replace the original 2 sticks with these, and tst again

>>  increase ram from 4Gb to 8Gb under XPx32  <<  THIS CAN CAUSE Problems, since 32 bit OS only recognises 4 GB Max

you can run diags for your video, and the rest :
-type in dxdiag and run the test for the screen (you can also test the sound)
-use Burnin test : http://www.passmark.com/download/index.htm      

also i must inform you that for testing  spares and equipment is needed; so if you don't have them, it may be necessary to have things tested at a shop

you can calculate the power needed here :   http://extreme.outervision.com/psucalculatorlite.jsp
0
 

Author Comment

by:blacktide
ID: 38838135
Hello, Gentlemen,

It has taken me quite a while but I found the source of my original problem, I think.

Bottome lines:  
  - bad memory stick was the source of the problem.

  - I am amazed at how robustly well Win7 runs on 2 Gb of ram.  Since I first moved to XP and then built my computers in June of 2008, I have never used less than 4Gb.

  - I have learned that just because memory tests say your memory is okay, it ain't necessarily so.

- The capacitors were in perfect condition.

Minimized details:

01  I tried twice to boot from the two CDs, Ultimate Boot Disk v511 and Ubuntu v12.10. For reasons unknown --- and the first time in my experience on these computers --- I could not.

02  I then disconnected everything from my computer and removed three of the four memory sticks.  My motherboard maxes out at 8Gb.  I then went through a series of empirical tests, in which I tried to replicate some of the circumstances in which my computer would freeze.  I mentioned these in my original post.  In the process I was surprised that when I booted with 2Gb of memory, Win7 put up a balloon saying it was installing three new USB devices.  I wondered why, drivers of some kind?  Only one port was being used, the USB-to-PS2 splitter for my mouse and keyboard. Whatever that was about, I tried to stress the machine with multiple simultaneous streaming television show ISOs from my server, while I worked on text and database files and cruised the internet.  All at the same time.  Flawless operation.  Amazing.

Incrementally, with cold boots for each new configuration, I added peripherals (audio, scanner (off), external drive (off)) one at a time, running the stresses each time.  Flawless, except for hub weirdnesses.

03 While going through this process but with the second memory module of the pair, I noticed the POST was saying memory was 1066 instead of the 1600 that it actually was.  This foreshadowed a new problem.  

04  In any case, I got to checking out the second memory.  The system immediately froze up. Tried different slots, different memory configurations while checking remaining two memory sticks.  Eventually, it became unavoidably clear that the second memory stick was the source of the random freezes regardless of POST memory counts, software tests et
cetera.

05  There came a point while tracking down the "new" problem --- it has to do with USB ports --- that I tried booting from the Ultimate Boot CD and the Live Linux Ubuntu v12.10 again.  The UBCD worked perfectly but I found the utilities unnecessary in regard to the resolved memory question; and unable to help me with the "new" USB problem.  The Live
Linux disc still just leaves my screen black after the POST and requires a reboot.

I hope it is obvious from the delay in my reporting back to you that there was much more to the process than included here. But you got me to a diagnostic process that solved the problem I outlined. So thank you Johnny Canuck, D Brunton, and Nobus.

FYI I may be back here with two more questions:
- Is it possible that USB ports can somehow conflict with memory?  
- Is there a short primer on memory tweaking?
When I connect my USB hub (web cam, external drive, mobile scanner), the motherboard loses its memory settings, the system freezes, or the motherboard presents different options for memory settings!  This comes on top of Win7 suggesting in between configurations that my equipment could run faster if I connected to one of my USB 2.0 ports, for which it just reinstalled drivers even though doing this causes the POST to freeze.  And this hub has, heretofore, always been connected to the USB 2.0!

Anyway, these are for another time.

Thanks again.
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 91

Expert Comment

by:nobus
ID: 38838595
>>  01  I tried twice to boot from the two CDs, Ultimate Boot Disk v511 and Ubuntu v12.10. For reasons unknown --- and the first time in my experience on these computers --- I could not  <<   what??  post info on problems, errors, and messages

>>  Win7 put up a balloon saying it was installing three new USB devices  << if you click on it you'll see what devices it installs

>>  POST was saying memory was 1066 instead of the 1600   <<  i assume you meann the ram speed here?  are all sticks the same?  if not, that can be the cause

>>  The system immediately froze up  << if you use different sticks, verify not only their speed, but also the voltage they run on - it's usually this that causes problems

>>  I found the UBCD utilities unnecessary   <<  WRONG imo, in such a case, i would recommend running the memetest86+ for at least 3 full passes (kind of burnin)

if the linux cd does not work, you still have hardware problems, - or the cd is bad, test it on another PC
0
 

Author Comment

by:blacktide
ID: 38841631
Hello, nobus,

In re Ultimate Boot Disk:
- There is no info on problems, errors, and messages to report on my virgin attempt to boot from the two discs.  My screen simply went black.  No freezes or anything.

- as mentioned, subsequently in my process the UBCD worked fine.  

In re your interest in Ubuntu:
- the disc does not boot in another machine

- I just re-downloaded the AMD 64 ISO I used before and burned a disc from it.  Boots fine in all machines.

re USB devices:
- The message may have been slightly different than I said, I do not remember.  I generally do click and read those info balloons but there was something about that one, it sort of flew by.

re RAM:
- Yes, it is this POST reported speed to which I refer.  Yes, all sticks are the same.  When I assembled the machine, modules were packaged and numbered in pairs to indicate matched production.  I was interested to see that the four 2Gb 1333 I just received were packaged as a set by Corsair but were not numbered in pairs or even sequentially.

- my prospective questions concern setting the voltages, timings and whatever else those series of numbers on the modules indicate.  For instance, the ones I was using are stamped 9-9-9-24 at 1.80v.  The BIOS settings show different and longer strings at first, second, and third information as well as different voltage.  The motherboard on auto apparently adjusts these things to optimally match the CPU.  Although I am disinterested in creating a monster "box" --- I have been very happy with my machine --- my recent difficulties and the capabilities of my motherboard suggest I will have to learn something about this area.

re UBCD utilities:
- I should have said "obviated" rather than "unnecessary".  I replaced all of my then extant RAM 1600 with the presumably matched new RAM 1333.  I opted for RAM space over speed when the disparity between the POST's report and the native module speed became inconstant.  I mean, rather than using  4Gb of 1600, I installed 8Gb of 1333.  Among the things I left out of my solution acceptance message was that the disturbing discrepancy between native and reported RAM speed led me to discover that my BIOS apparently changed this number, and speed options!, in varying ways if boot up experienced a freeze.  In particular, the final reattachment to my setup in the incremental process, my USB hub, now triggers a freeze if plugged into its usual USB 2.0. This led to a catch-22.  When memory was resolved and as peripherals were reattached, Win7 re-installed the USB drivers it had apparently replaced when I stripped down to 2 Gb  for the diagnostics.  When Win7 completed this install, it put up the balloon that I would get better performance were I to move the finally attached hub from the non-freeze producing USB v1 slot to the freeze-producing v2 slot.  This led to my wondering whether memory can somehow conflict with USB.

- On the other hand, perhaps you would suggest that I do the UBCD ram "burn in" on the new RAM anyway.

Thanks again.
0
 
LVL 91

Expert Comment

by:nobus
ID: 38842839
are you saying the UBCD and Knoppix disk work ok on other PC's - but not on this one? plse confirm

then you have a bad cd drive, or cable, or cd controller = mobo
you can swap cables and drives to test - to another PC, or try a known good cd drive on your PC; it can also be due to bad RAM

you said "My screen simply went black  "   when exactly?  after post?

>>  as well as different voltage  <<  be sure the bios is set to the correct voltage, and ALL sticks are for the same voltage ! -don't mix with others

you also have to use the ram slots following the manual, eg, A1 and B1 if 2 sticks are used in dual channel
it also says this :
r
0
 

Author Comment

by:blacktide
ID: 38845860
So, nobus,
- Both CDs work in all machines.
- Yes, all 4 sticks are the same, nothing is mixed.
- Sorry, I did not make explicit why I was using 4 2Gb sticks, but thanks.

I appreciate your passion and perseverance, nobus.  I consider this question closed.

I may open new questions about memory and USB ports, et cetera.  I will re-read the rules as to how to close questions.

Again, thanks a lot.
0
 
LVL 91

Expert Comment

by:nobus
ID: 38846207
you can pick one or more posts as answers
0
 

Author Comment

by:blacktide
ID: 38846627
Actually, I did pick multiple solutions with my response posted on  2013-01-30 at 22:48:04 ID: 38838135.  Also my account shows the question answered. Apparently this is not showing up in your browser, or perhaps throughout the E-E system.  I will wait two more days before calling for attention.  Thanks.
0
 
LVL 91

Expert Comment

by:nobus
ID: 38846813
>>  Apparently this is not showing up in your browser  <<  ???   why not?  eberything looksd ok here
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now