• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 580
  • Last Modified:

Missing Icons During GPO Software Deployment to Some Users

I am using GPO Software Deployment to install certain applications for both specific users and specific machines.

The ones causing problems are linked via an OU containing user objects via User Configuration.  Users that are not administrators (locally or on the domain) can access the program, however the icon is not installing properly on the desktop.  If I check the properties of the desktop shortcut, and click Change-Icon, it tells me a specific local %appdata% path doesn't exist.  How do I get around this?  I am guessing it is a local permissions problem, but I don't want to use GPO to make these users local administrators, and I don't want to change the application so it installs pre-login via Computer Configuration.

Thanks!
0
dietzmj
Asked:
dietzmj
  • 3
  • 2
1 Solution
 
RobSampsonCommented:
Hi, this seems to suggest that the application is installing as a "single user" product, and not an "all users" product.  If it's looking for the icon in %appdata%, that going to be profile specific.  I guess you could copy the icon file to the %appdata% folder of each profile, but probably better option would be to use Group Policy Preferences to set the shortcut yourself.  Do you have a 2008 server Domain Controller?

Rob.
0
 
dietzmjAuthor Commented:
They are remote apps and being installed via GPO with under Computers, so I think that should be "All Users" (no way to change the MSI that I know of to whatever it defaults to in RemoteApps -> Create Installer Package).  I fixed the problem by simply extracting the icon from the executable and putting it in a shared folder.  Not the fix I was hoping for, but it does the job.  Really didn't want to have to workaround the way suggested above.  We have Windows XP on many machines so GPP is not an option unless we install the client side extensions.
0
 
RobSampsonCommented:
I don't use GP Software Deployment, but can you alter the command line used, and use this:
setup.msi ALLUSERS=2 /qb /noestart

The ALLUSERS switch should be supported by the Microsoft Installer to force an All User installation.

Rob.
0
 
dietzmjAuthor Commented:
I ended up just extracting the icons from the application file and referencing the .ico file on a shared folder.  Thanks for the help.
0
 
dietzmjAuthor Commented:
It was the only solution since no others were really offered.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now