SBS2011 RD Gateway problems.

I have  new install of SBS2011. I can't get RDP to desktops within RWA working. I can log into the Remote website. When I try to connect to any of the desktops I am getting the error " The Remote Desktop Gateway Servers is unavailable. Try again later.

When I run the Fix My Network Wizard, it detects that Network Component ID 4 needs to be fixed. It isn't able to fix the error.

The the server was initially setup with a self sign cert. Since trying to troubleshoot the problem I have purchased a GoDaddy certificate and in doing that had to change the external domain name.

I have installed the Remote Desktop Gateway Manager. When I open that, there are no objects. When I try to add the server I get a message that the RD Gateway Settings could not be read.

Any ideas?
LVL 1
Micro-VisionAsked:
Who is Participating?
 
BlueComputeCommented:
Is the tsgateway service started?  You should also try running the SBS 2011 Best PRactices Analyzer: http://www.sbslinks.com/sbsbpa.htm
0
 
foxpc123Commented:
Having a quick look came across this article - when this error is encountered;

This computer can't connect to the remote computer because the Terminal Services Gateway server is temporarily unavailable. Try reconnecting later or contact your network administrator for assistance.
 
These are some of the common causes of this error:

 

1.     SBS Web Applications is missing binding for port 443 or multiple websites have this binding and one of them is only started because of that -- This might happen if someone has tried binding port 443 to another website.
 
 

2.     We might find port 443 binding present with Default Website -- This will happen if we have manually chosen the option to configure IIS for TS Gateway in TS Gateway manager
 
 

3.     HKLM\Software\Microsoft\Rpc\RpcProxy\ is missing Website key which represents the value for the website where rpc and rpcwithcert directories are.
 
With this resolution;

1. Run Fix my Network Wizard (this step should fix everything except creating registry entry if that is missing) - this may not work for you as you've stated above.
 
 

i) Manually remove 443 binding for Default website -- 443 binding is assigned to Default Website when you click "Configure IIS Settings for TS Gateway" in the TS Gateway console.
 
 

ii) Make sure we have 443 binding present with proper certificate

 

 iii) Manually create the registry key HKLM\Software\Microsoft\Rpc\RpcProxy\Website with the value "SBS Web Applications"

The whole article is referenced here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;969743 

Could you also post the fix my network wizard log - fncw.log at
%sbsprogramdir%\Windows Small Business Server\Logs

Thanks
0
 
Micro-VisionAuthor Commented:
Thank you BlueCompute and sorry I didn't respond before now. The tsgateway service was started. Running the BPA pointed to an invalid website name in the RPCProxy registry key. It was pointing to "SBS Web Applications" which isn't in SBS 2011, I changed it to "Default Web Site". After some configuring some permissions the RWA is up and running. Thank you very much.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.