Solved

SBS2011 server Transport service hang

Posted on 2013-01-25
6
1,248 Views
Last Modified: 2013-12-02
We have a single sbs2011 server running exchange and AVG.

We seem to have a problem that causes our transport service to stop working. This reveals itself by mail failing to arrive and MXTOOLBOX smtp diag reporting a time out due to no activity.

If we go into task manager and stop the MSExchangetransport.exe, which automatically restarts taht service, mail starts to arrive straight away.

There is nothing obvious that highlites that this has happened, as simply mail stops arriving, but I did notice this error in the server event log around the same time :-

The transport process failed during message processing with the following call stack: Microsoft.Exchange.Data.Mime.MimeException: MIME content error: MIME map data is invalid (1).
   at Microsoft.Exchange.Data.Mime.Internal.MimeCacheMap.Load(Stream cacheStream, CreateFixedStream createFixedStream, DecodingOptions decodingOptions)
   at Microsoft.Exchange.Transport.MimeCache.LoadFromCursor(DataTableCursor cursor)
   at Microsoft.Exchange.Transport.MimeCache.DeferredLoad()
   at Microsoft.Exchange.Transport.MimeCache.get_MimeDocument()
   at Microsoft.Exchange.Transport.TransportMailItem.get_RootPart()
   at Microsoft.Exchange.Transport.DsnGenerator.InternalGenerateDSNs(IReadOnlyMailItem mailItem, IEnumerable recipientList, DsnFlags dsnFlags, String remoteMta)
   at Microsoft.Exchange.Transport.DsnGenerator.GenerateDSNs(IReadOnlyMailItem mailItem, IEnumerable`1 recipientList, String remoteServer, CallerComponent callerComponent)
   at Microsoft.Exchange.Transport.Categorizer.CategorizerComponent.HandleFailedMessage(TransportMailItem transportMailItem, TaskContext taskContext)
   at Microsoft.Exchange.Transport.Categorizer.CategorizerComponent.BifurcateAndHandleFailedMessage(TransportMailItem mailItem, TaskContext taskContext)
   at Microsoft.Exchange.Transport.Categorizer.CategorizerComponent.HandleComponentException(Exception e, TaskContext taskContext)
   at Microsoft.Exchange.Transport.Categorizer.TaskContext.Invoke()
   at Microsoft.Exchange.Transport.Categorizer.CatScheduler.JobThreadEntry(Object ignored)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback tpWaitCallBack)
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object state)

Does anyone have any ideas about how we go about addressing this issue, as due to its nature it is causing a great deal of inconvenience.

Many thanks.
0
Comment
Question by:nigelbeatson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 38818580
I would be pointing the finger at AVG. The latest version has caused me no end of problems with Exchange servers.

Ensure that it has all of the required exclusions in place or even just disable the product completely to verify that it is the cause of the problem.

Simon.
0
 

Author Comment

by:nigelbeatson
ID: 38818619
many thanks. I have now disabled the VSAPI component within AVG, and will let you know how this works.

I have excluded the whole exchange folder, which I presume excludes all its subfolders.

Are there any others that I should check for?

Many thanks.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 38818742
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 

Author Comment

by:nigelbeatson
ID: 38888490
Many thanks. I have identified that a service pack may be required for exchange 2010 and an upgrade to AVG 2013.

I will carry this out and let you know how I get on.

Many thanks,.
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 38903571
Exchange 2010 SP3 has now been released and I am seeing it resolve a lot of odd issues, particularly on SBS 2011.

Simon.
0
 

Author Closing Comment

by:nigelbeatson
ID: 38957388
many thnaks
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
how to add IIS SMTP to handle application/Scanner relays into office 365.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question