?
Solved

WDS - Client Naming Policy Not Working

Posted on 2013-01-25
7
Medium Priority
?
4,228 Views
Last Modified: 2013-01-26
Hi Guys,

I'm trying to deploy Windows 7 x64 Ent Machines out, and need the machines named ws01, ws02, ws03 etc.  

I went into WDS properties and specified the client naming policy as "ws%02#".  I did not include a computername in the unattend xml file.

Basically when the machine boots, the user is prompted for a computer name.  Which wouldn't be so bad by itself, however by this stage the system has already been joined to the domain as a random name.

Any help with getting the correct name and getting the clients domain joined would be greatly appreciated.

Many thanks,
Matt
0
Comment
Question by:mmcdoug
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 11

Expert Comment

by:netballi
ID: 38819066
0
 
LVL 40

Expert Comment

by:footech
ID: 38819110
If you're using an answer file (the image unattend file), then you need to specify a variable for the computer name.  Here's an example of what is needed for the specialize pass.
    <settings pass="specialize">
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <Identification>
                <UnsecureJoin>true</UnsecureJoin>
                <JoinDomain>%USERDOMAIN%</JoinDomain>
            </Identification>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <ComputerName>%MACHINENAME%</ComputerName>
        </component>
    </settings>

Open in new window

Here's a list of the variables that WDS can use (copied from a Microsoft site);

Using Variables to Obtain Information from the Client
--------------------------------------------------------------------------------
Windows Deployment Services can obtain information during an installation, which you can use as part of a custom deployment scenario. Windows Deployment Services will insert the proper values into your unattend file automatically as long as the file is formatted correctly. The variables that the client can use for this purpose are:
•%USERDOMAIN%. The name of the user's domain, which was specified either by credentials or in the Windows Deployment Services client unattend file.
•%USERNAME%. The user's name, which was specified either by credentials or in the Windows Deployment Services client unattend file.
•%USERPASSWORD%. The user's password, which was specified either by credentials or in the Windows Deployment Services client unattend file. We do not recommend using this variable because it may pose a security risk. The password will be written to the unattend file in plain text.
•%MACHINEDOMAIN%. The domain that contains the computer account that represents the physical client computer.
•%MACHINENAME%. The computer name of the computer account that represents the physical client computer.
•%TIMEZONE%. The time zone of the Windows Deployment Services server.
•%ORGNAME%. The organization name of the Windows Deployment Services server.
0
 

Author Comment

by:mmcdoug
ID: 38821224
Hi footech,

Thanks for your suggestion.

Even with the suggested modification in specialise (as below)

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <CopyProfile>true</CopyProfile>
            <TimeZone>E. Australia Standard Time</TimeZone>
            <RegisteredOrganization>Company</RegisteredOrganization>
            <RegisteredOwner>Company User</RegisteredOwner>
            <ComputerName>%MACHINENAME%</ComputerName>
        </component>

Open in new window


I still get a random name.  In the setupact file, it just has

[Shell Unattend] Running 'specialize' pass
[Shell Unattend] ComputerName: generating computer name from user name
[Shell Unattend] ComputerName: generated name 'ALLIANC-M81TTR7'
[Shell Unattend] ComputerName set to 'ALLIANC-M81TTR7'

Open in new window


You will see in the server properties, this is what I have:
Properties
Any help would be greatly appreciated.

Thanks!
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 40

Expert Comment

by:footech
ID: 38821376
Are those settings in the image unattend file (not the client unattend file) which is linked to a particular image?
If you had a file linked, and then made any changes, you need to go to the properties of the image and re-select the the unattend file to use so it picks up the changes.
Just for reference I'm including basic client and image unattend files which work.
WDS-x86-part1.xml
WDS-x86-part2.xml
0
 

Author Comment

by:mmcdoug
ID: 38821422
Guys,

I have a solution.

In order for this to work you must enable "require administrative approval for unknown computers" under the PXE response policy.

In addition, you must delegate access to the Computers OU, and allow the WDS server permissions to create computers in AD.

Thanks for your help.
0
 

Author Comment

by:mmcdoug
ID: 38821923
I've requested that this question be closed as follows:

Accepted answer: 0 points for mmcdoug's comment #a38821422

for the following reason:

Guys,<br /><br />I have a solution.<br /><br />In order for this to work you must enable &quot;require administrative approval for unknown computers&quot; under the PXE response policy.<br /><br />In addition, you must delegate access to the Computers OU, and allow the WDS server permissions to create computers in AD.<br /><br />Thanks for your help.
0
 
LVL 40

Accepted Solution

by:
footech earned 1500 total points
ID: 38821565
I don't use the same settings as you and I haven't worked out all the combinations, but I believe the reason you needed to make changes as you did stems from the use of checking something other than the default for Computer Account Location in WDS properties.  When creating accounts in the default location, you don't need to modify permissions or approve requests.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Assume you have an outside contractor who comes in seasonally or once a week to do some work in your office, but you only want to give him access to the programs and files he needs and keep all other documents and programs private. Can you do this o…
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial will go in depth within Systems and Security in Windows 7 and will go into detail regarding Action Center, Windows Firewall, System, etc. This will be demonstrated using Windows 7 operating system.
Suggested Courses
Course of the Month11 days, 17 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question