• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 635
  • Last Modified:

Need help taming SPF in a new Exim4 install

I just set up a new relay server to scan mail for multiple school districts. First I have ever worked with Exim, so not clear how to resolve my issue.  I am using Ubuntu 12.04, Exim4 from the repository and baruwa. Everything is running properly now, except the SPF portion of the Exim config is very aggressive and blocks all email that is not already rejected by the rbl rules. I have included my configs for examination  on Pastebin. I worked with it some last night, which is why some portions of the config for spf have been commented out. I do want spf restrictions, but just not so overly aggresive.

http://pastebin.com/zayefeMz
0
tamray_tech
Asked:
tamray_tech
1 Solution
 
arnoldCommented:
Line 111 you have a deny comment the line out. You commented line 112 which would have indicated the rejection as permanent, while your current config defer the message for the remote server to try again later.  
Dealing with SPF on the incoming level provides a accept/reject option.
You could instead use accept and mark the message as iffy and then let further content filtering to make the determination of delivery into the mailbox as good or into bulk mail.
SPF also enforces based on parameters the owner of the domain references in their SPF rule
~all, -all.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now