Terminal Server only allowing connection to Console Session - no one else can log on!

Hi,

Suddenly I got a call today that users were no longer able to log onto one of our Terminal Servers (W2K3). In addition, there were a few users who had previously logged on earlier in the day but if these users logged off they were also NOT able to log back on.) At first I was pretty sure this was a firewall issue (which it might have been in the beginning), but now I am seeing the following:

Although I am able to access the console session on this machine remotely (using the "admin" switch"), NO OTHER USERS (not even my Domain Admin account) are able to log onto this terminal server. Any attempt to RDP to this machine (other than session "0") by anyone produces the Logon Message below (we've all seen this one before):

"To log onto this remote computer, you must have Terminal Server Access permissions on this computer" ...... If you are not a member of the Remote Desktop User group.... "  Etc.

I've checked the local Remote Desktop Users group and nothing there has changed from when it was working previously.

I've also checked the following:

*Terminal Services Configuration\Connections -- RDP-Tcp properties ¦ Permissions Tab: --> I added both a local and domain user explicitly and enabled full control but it still does not work

*Checked the Local Security Settings ¦ Allow log on through Terminal Services --> The Remote Desktop Users group is present and the proper domain and local user(s) group(s) have been added but still no dice

*I've checked the domain GPOs and none of these should be blocking user access (like I said, nothing was changed, the problem "just started happening".  Very bizarre.)

I'm not sure where else to look.

Any ideas?
cfsaAsked:
Who is Participating?
 
browningitConnect With a Mentor SysadminCommented:
I also found this:

Run Add/Remove Programs (run "appwiz.cpl")
Click Add/Remove Windows Components (Alt-W)
Uncheck Terminal Server
Press Next>.
Follow instructions, including rebooting.
Open System control panel applet (run "sysdm.cpl")
Click Remote tab.
Check Enable Remote Desktop on this computer. (because removing Terminal Server disables this)
Click Select Remote Users...
Make sure administrators is in the list.
Click OK.
Click OK. for the next dialog.
Wait a few minutes for things to get up and running and you're no ready for remote administration again.

Cheers,
0
 
browningitSysadminCommented:
Sounds to me like the you need to restart the Terminal Services, or just reboot your Terminal server altogether as a first step.  I'll spend a little more time in assisting after you give that a whirl and post the results.  If you need to figure out a way to do this without restarting the server (and thus losing user data) please let me know.

Cheers,
0
 
cfsaAuthor Commented:
Sorry, I should have mentioned that I rebooted the server - twice.  No change.
0
 
browningitConnect With a Mentor SysadminCommented:
Check out the comments on this person's solution, as well as the other posters.

http://www.techrepublic.com/forum/questions/101-210295/terminal-server-user-access-problem-windows-2003

I would start with a network cable disconnect, and then move to this thread which is linked in the above post:

http://blogs.msdn.com/ts/archive/2006/11/29/remote-desktop-connection-terminal-services-client-6-0-for-windows-xp-and-windows-server-2003-english-only-released.aspx

Let me know how that works out!
0
 
cfsaAuthor Commented:
I appreciate all of the helpful comments. In the end, we discovered that the firewall lost one of its rules (don't ask me how) and was filtering traffic to the Licensing Server. After re-establishing communications with it, a reboot of the Terminal Server solved our problems.<br /><br />Thanks to everyone. -j
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.