Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3939
  • Last Modified:

RD Gateway and Cert Subject Name Do Not Match

Hello,
I am having a issue with Remote Web Workplace.  I can log on and access any shares, but when I go to connect to a workstation I click on connect, use my credentials to get in then I receive this error:
  "Your computer can't connect to the remote computer because the Remote Desktop Gateway server address requested and the certificate subject name do not match. Contact your network administrator for assistance."

The Certificate is a Self-assigned Cert.
-Windows SBS 2011
0
jands
Asked:
jands
  • 2
1 Solution
 
jandsAuthor Commented:
Looking at the certificate for web server cn=sites (or subject name=sites).  On  the Cert that I have to install on the workstations it says the server name so cn=SERVERNAME

We are trying to hit this via IP Address.
0
 
Cliff GaliherCommented:
You cant use this by ip address. You must run the internet address wizard and set up an external DNS record to match the name you used in the wizard. You mist then either purchase a certificate and install it using the certificate wizard or you must install the certificate package that SBS creates for the self-signed cert onto the machine you are connecting FROM.

Either way, you mist connect to RWA using the name chosen when running the internet address wizard, and there CANNOT be any certificate warnings. Or RDG will fail. This is a core security feature of the RDGateway service and cannot be disabled or bypassed.
0
 
jandsAuthor Commented:
Thank you cgaliher for your time.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now