Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 470
  • Last Modified:

SQL - errir connect to SQL Server

I just install a SQL Server 2008 R2 on a VM.  As I try to login, I got the following error message.  I check the Task Manager (See file attached). SQL Server is running.  Does anyone can tell me what is the problem?
Thanks.


===================================

Cannot connect to TempoTangoSQL.

===================================

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider)

------------------------------
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=53&LinkId=20476

------------------------------
Error Number: 53
Severity: 20
State: 0


------------------------------
Program Location:

   at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
   at System.Data.SqlClient.TdsParser.Connect(ServerInfo serverInfo, SqlInternalConnectionTds connHandler, Boolean ignoreSniOpenTimeout, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, SqlConnection owningObject)
   at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)
   at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(String host, String newPassword, Boolean redirectedUserInstance, SqlConnection owningObject, SqlConnectionString connectionOptions, Int64 timerStart)
   at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
   at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
   at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
   at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup)
   at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
   at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
   at System.Data.SqlClient.SqlConnection.Open()
   at Microsoft.SqlServer.Management.SqlStudio.Explorer.ObjectExplorerService.ValidateConnection(UIConnectionInfo ci, IServerType server)
   at Microsoft.SqlServer.Management.UI.ConnectionDlg.Connector.ConnectionThreadUser()
Capture01.PNG
0
tommym121
Asked:
tommym121
  • 4
  • 3
2 Solutions
 
Dave BaldwinFixer of ProblemsCommented:
I believe you have to enable remote connections, TCP/IP connections, and SQL Authentication.  And you need to create a user other than 'sa' to connect with.  It is not recommended to use 'sa' because it has the highest privileges and can do anything.

In SSMS, the Properties page for the server let you set Enable Remote Connections and on the Security tab, you can enable SQL Authentication.
SQL Server PropertiesIn the SQL Server Configuration Manage, you can set the IP addresses and port number you need to use.
SQL TCP/IP settingsYou also need to enable the 'sqlbrowser.exe' service if you are trying to connect by 'named instances'.
0
 
tommym121Author Commented:
I cannot even able to login yet. Hence, I can not get to the property of the server instance.
(See Capture02.png)
I try to browse for server name,  nothing appear in Local or Network (See Capture03,png)
I have enable the NamePiped of SQL Server Network Configuration.

I did stop and restart the SQL Server. Problem still exists.
Capture02.PNG
Capture03.PNG
0
 
tommym121Author Commented:
Sorry forget to attach in the above post
Capture04.PNG
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Dave BaldwinFixer of ProblemsCommented:
On my machine in the login for SSMS, the servername is shown as "MACHINENAME\SQLSERVERNAME" and the username is specified as "MACHINENAME\Username", not just 'Username'.
0
 
tommym121Author Commented:
I add the MACHINENAME, same issue
0
 
tommym121Author Commented:
Thanks.
0
 
Dave BaldwinFixer of ProblemsCommented:
You're welcome, thanks for the points.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now