Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SSIS package running fine from visual studio, but not from Sceduler ?

Posted on 2013-01-26
5
Medium Priority
?
327 Views
Last Modified: 2016-02-10
Hi!

When i run my OLAP package (SSIS)  from visual studio. It runs just fine.

But setup this package to run from Microsoft server manager..
as a sceduler job it fails....

What is wrong ?

Olso try to run the pack from dos promt, using -> dtexec.exe
And here it works fine to

Please help
0
Comment
Question by:team2005
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 6

Expert Comment

by:liija
ID: 38822461
How have you taken care of user authentication in the data sources?
If you haven't defined anything inside the agent job - or are not using e.g. package configuration files, the agent service credentials are used. Probably it doesn't have rights to the data sources.

Check out this:
http://www.mssqltips.com/sqlservertip/1180/sql-server-integration-services-package-scheduling-with-sql-agent/
0
 
LVL 43

Expert Comment

by:Eugene Z
ID: 38823076
<What is wrong ?>

What is the error?

make sure you do not use C:\yourPCfolder
use instead UNC path:

\\servername\SharedFolder_With_NTFSSqlserverLoginPermissions_That_youSetSqlAgentJob
0
 
LVL 2

Author Comment

by:team2005
ID: 38823937
Hi!

Get tis errors:

Error: Failed to acquire connection "Olap". Connection may not be configured correctly or you may not have the right permissions on this connection.
0
 
LVL 6

Accepted Solution

by:
liija earned 2000 total points
ID: 38825814
My first comment applies.
Most likely you are trying to run SSIS package with Agent Service user account - which might be local system account. Agent Service user account doesn't have access to the OLAP cube  you are trying to process.
There are several different ways to get around this, here are a couple of them:

- Implement proxy account:
http://www.buildingmeaning.com/?p=89

- Check the link in my first post. In agent job there is a tab 'Data Source'. There you are able to manage the connections within the specific package inside the scheduled job.

- Implement package configurations.
http://www.simple-talk.com/sql/ssis/xml-configuration-files-in-sql-server-integration-services/

- Hardcode the user credentials into the SSIS package. Now you are probably using trusted connection. When you run this scheduled it won't work. Add a user and password inside your SSIS package. Set on the package security option 'EncryptSensitiveWithPassword'. This encrypts the connection credentials. Use naturally the same password in SQL Server Agent Job.
0
 
LVL 2

Author Closing Comment

by:team2005
ID: 38863313
thanks
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Windocks is an independent port of Docker's open source to Windows.   This article introduces the use of SQL Server in containers, with integrated support of SQL Server database cloning.
Via a live example, show how to set up a backup for SQL Server using a Maintenance Plan and how to schedule the job into SQL Server Agent.
Using examples as well as descriptions, and references to Books Online, show the documentation available for datatypes, explain the available data types and show how data can be passed into and out of variables.

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question