Solved

“Access Denied” while Activating Custom Timer Job in Sharepoint 2010

Posted on 2013-01-26
4
2,047 Views
Last Modified: 2013-05-03
When trying to Activate Feature of Timer Job in a host header site collection, it returns error : Access Denied

Scope of Feature is "Site". The account is registered as Farm service account. But Still not Working.

Tried to disable RemoteAdministratorAccessDenied feature, still not working.

Any help or suggestion is appreciated.

Thanks,
ash84
0
Comment
Question by:Ash84
  • 2
4 Comments
 
LVL 31

Expert Comment

by:Jamie McAllister MVP
ID: 38824000
0
 
LVL 3

Expert Comment

by:EvoLord
ID: 38825046
Jamie's right the link should explain why you can't activate your feature through the GUI. However, what it fails to explain is how else you can activate on other environments that do not have VS ( like your test and production environments). For those environments use the powershell commands for activation. The powershell command will run by the owstimer and so uses the farm service account for activation.

Here a msdn link with the enable feature so command http://msdn.microsoft.com/en-us/library/ms442691(v=office.14).aspx

Lastly, remember that farm features are automatically activated, so if you are using one then deploy your solution using powershell!

If the above does not help, let me know via a response to this post and if your willing to share your code I'll be happy to have a look and sort out the issue for you.
0
 
LVL 9

Expert Comment

by:kukdai
ID: 38827365
I would prefer changing the scope of the solution to higher level rather than site.
i do have a custom timer created but it is activated at the web application level and the process is actually for each site collection.

can't the scope of the site be changed to web application level hopefully that should fix the issue.
0
 
LVL 3

Accepted Solution

by:
EvoLord earned 500 total points
ID: 38828803
You should have no issues changing the scope to the web application level. Just activate the feature using powershell. Timerjob activation through the GUI will use the app pool account the GUI runs under. Activating using powershell uses the app account the Timerjob service runs under.


Hope this helps.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Sharepoint 2013 Library List View Limitations 9 57
Sharepoint 2010 Auditing 4 29
Create Task List as an icon on Home Page 6 30
Sharepoint Online 5 33
Last week I faced a strange issue recently, i have deployed SharePoint 2003 servers for one project and one of the requirements was to open SharePoint site from same server. when i was trying to open site from the same server i was getting authentic…
Microsoft SharePoint Foundation 2010 and Microsoft SharePoint Server 2010 do not offer the option to configure the location of the SharePoint diagnostic trace log files during installation.  This can, however, be configured through Central Administr…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question