Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Problems sending emails with Android devices via Activesync and Exchange2007 server

Posted on 2013-01-26
9
Medium Priority
?
4,276 Views
Last Modified: 2013-10-22
Hi, we are using Exchange 2007 server, and we don'thave any problems with Email syncing on Iphones via Activesync.  Now, we are testing Samsung Note with Android 4.x and we use native email client, and we have problems with forwarding some emails that have attached files, sometimes are little size image files.

We have decided to install Touchdown to solve this extrange problems, and it seems works fine at most of this cases but ...but now , with Touchdown, when you compose a new email and attach a 3Mb picture, it stucks in outbound and never sent it.

We have reviewed all setting of Exchange, Activesync ... and we have'nt any restrictions.
So, we don't understand what's is the problem for Androids-activesync-Exchange when email have attached image files, since we don't have any problem with the same situation using Iphones,

Thank's in advance.

Xavier
0
Comment
Question by:XRVXRV
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
9 Comments
 
LVL 5

Expert Comment

by:Slav Zabicki
ID: 38823141
I had this problem too. and I've got galaxy

this should help
https://play.google.com/store/apps/details?id=com.remoba.eas.mob.ui.activity&hl=en

It did help in case....
0
 

Author Comment

by:XRVXRV
ID: 38824276
Hi, I installed it but i have two problems:

- "sent items" folder seems that isn't a local sincronized folder, it access at the server folder every time;

- when i compose a new email with attached file, if size is about 3Mb appears a message like "File size is too large" ..

so I am in the same situation as before, and i don't see a good solution for me.
0
 
LVL 5

Expert Comment

by:Slav Zabicki
ID: 38824412
just in case:

go to IIS server in activesync site go to applications settings and check default max size (MaxDocumentDataSize)

also please check:
https://play.google.com/store/apps/details?id=com.qs.enhancedemail&hl=en

Do you have a phone with an older version of android?
4.0.1+ have some problems with activesync

read this:
http://forum.xda-developers.com/showthread.php?t=1812794
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:XRVXRV
ID: 38825979
In our Exchange 2007 server, we have unckecked the parameters about max size of email content and max size of attached file email, so I understand is applying default values (?)

In other hand we are using Samsung Note with Android 4.0.4

And the problem if when I compose new email and attach an image (only 1 Mb)  not send it ... but emails without attached images runs fine ..

Any new suggestion please?
0
 
LVL 5

Expert Comment

by:Slav Zabicki
ID: 38826920
I suggest to check IIS as I mentioned and install enhanced mail client.
0
 

Author Comment

by:XRVXRV
ID: 38828613
I have installed Enhanced Email. I set debug option, and when i send an email with 25kb image attached file, i can see this error : "Message sending failed. code : 413"
It seems an HTTP error, when server doesn't accept files with size bigger than certain parameter (?).
I don't understand why with our corporate iphones we don't have any problems sending emails with attached files to the same Exchange server with activesync, and I can't send any email with attached file with Android to the same server.
Perhaps Iphone and Android has different HTTP methods to upload an attached file?
Please, we have an Win2008 server, with Exchange2007, and IIS7.
Tell me detailed parameters that we must change in order to permit Android upload attached files in an email via Activesync. This is the problem.
Thank's in advance ..
0
 
LVL 5

Accepted Solution

by:
Slav Zabicki earned 1500 total points
ID: 38828941
stackoverflow.com/questions/467355/413-http-error-on-image-upload-in-iis6

scroll down to IIS7 section
0
 
LVL 5

Expert Comment

by:Slav Zabicki
ID: 38828954
stop IIS
find web.config file in the ExchServer\ClientAccess\Sync folder there is an entry for "MaxDocumentDataSize".  change it to 10240000

<add key="MaxDocumentDataSize" vaulue ="10240000">

start IIS
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is essential to make secure Yahoo Mail connection without facing any issue. It is providing simple steps to configure your Yahoo Mailbox to Hard drive using Microsoft Outlook.
Email signatures have numerous marketing benefits. Here are 8 top reasons to turn your email signature into a marketing channel.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question