• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 492
  • Last Modified:

Need help configuring a scheduled task (ran when not logged in)

I have configured a basic task to run that will run fine when I am logged in but when I re-configure it to run when I am not logged in it does not run. I have entered my credentials and I also tried checking the "run with the highest privileges" checkbox also. Any ideas not how to get this working?
0
Thaidog
Asked:
Thaidog
1 Solution
 
EMJSRCommented:
Does the task/software you run usually have an interactive component, e.g. a program GUI? Because, the running of the application when logged on or not, states, "...select the radio button labeled Run whether user is logged on or not. If this radio button is selected, tasks will not run interactively.  To make a task run interactively, select the Run only when user is logged on radio button."

Unless the task you are scheduling can be run from the command line, I guess it won't work.

So, if your task is requiring a user interface, it wouldn't be allowed to show it without a specific user providing rights by being logged in. If you can run the task without the need to show a window, then that would probably be just fine.

Would it be an option to simply lock your computer instead of logging off? You could do this by using the Windows Key + L. It would still password protect Windows, but keep you logged in with sufficient credentials to run a task. Just a thought?
0
 
arnoldCommented:
C:\windows\tasks
Make sure the require user to be logon or interact with desktop is not checked.
The other issue deals with whether your credentials have the run as batch rights.
0
 
ThaidogAuthor Commented:
This is for a powershell script to log on remotely to a vSphere server to do some sanity checks on the fiber channel storage.... I am running it with the hidden window option:

C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -nologo -WindowStyle Hidden -command "& {C:\users\johndoe\SkyDrive\PowerShell\Scripts\get_bad_paths.ps1}"

Open in new window


I'll try it with the screen locked to see if that works after I revert the changes I made to have it run when logged off...
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now