?
Solved

outlook 2010 cert error

Posted on 2013-01-26
5
Medium Priority
?
633 Views
Last Modified: 2013-02-02
Hi,
Oulook clients are getting "the on the security certificate is invalid or does not match the name of the site name"

Exchange servers' netbios name are not on the SAN cert and what we have on the cert are:

xyz.com
autodiscover.xyz.com
webmail.xyz.com
webmail.site2.xyz.com

There are 2 sites but all users are on primary site and getting outlook cert error because the primary exchange netbios name is not ion the SAN cert.

Autodiscover internal url seems correct as it is shown below...

[PS] C:\Windows\system32>Get-ClientAccessServer | fl Name,AutodiscoverServiceInternalUri

Name                           : primary-exch
AutoDiscoverServiceInternalUri : https://webmail.xyz.com/Autodiscover/Autodiscover.xml

Name                           : site2-exh
AutoDiscoverServiceInternalUri : https://webmail.site2.xyz.com/Autodiscover/Autodiscover.xml

Would appreciate any help...
thanks
0
Comment
Question by:c-iscen
  • 3
5 Comments
 
LVL 34

Accepted Solution

by:
Shreedhar Ette earned 1050 total points
ID: 38823610
- Please check Get-AutodiscovryVirtualDirectory | fl URL's are set properly

Make sure it is not set to netbios name of server. If they are set to netbios name than change it to webmail.xyz.com

- After above change check in outlook and psot back.
0
 

Author Comment

by:c-iscen
ID: 38824509
Both internal and external were set to NULL before so I set internalurl to webmail.xyz.com
as the command shown below.
Set-AutodiscoverVirtualDirectory -identity 'Autodiscover (Default Web Site)' –InternalUrl "https://webmail.xyz.com/Autodiscover/Autodiscover.xml"

Still getting cert error on outlook 2010
Thanks
0
 
LVL 10

Expert Comment

by:JaredJ1
ID: 38827092
You'll need to test autodiscover using Outlook.

1. Open Outlook. Once running, hold down the Ctrl key and then right click the Outlook icon (in the system tray). Select 'Test Email Autoconfiguration'.
2. Enter your email address and password - remove the two 'Guesssmart' options. Click Test and then check the 'log' tab to see what happens.

Send back the log and we'll figure it out.
0
 

Assisted Solution

by:c-iscen
c-iscen earned 0 total points
ID: 38827697
After set AutodiscoverVirtualDirectory, I also set ewc and follow up the instruction on ms article.
It seems working right now.

http://support.microsoft.com/kb/940726
thanks
0
 

Author Closing Comment

by:c-iscen
ID: 38846395
MS article shows the steps to resolve the issue as well.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
MS Outlook undoubtedly is the most widely used email client.Its user-friendliness, cost effectiveness, and availability with Microsoft Office Suite make it the most popular email application.  Its compatibility with Microsoft applications like Exch…
This video discusses moving either the default database or any database to a new volume.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
Suggested Courses
Course of the Month17 days, 12 hours left to enroll

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question