Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 783
  • Last Modified:

Windows XP Audio Driver for Sony VGN-FZ250E

I need the Audio Driver for a Sony VGN-FZ250E laptop. I cannot find it on the net. Several hardware databases I have do not issue the correct driver. The laptop comes shipped with Windows Vista and Sony has the Vista and Win7 drivers but no Windows XP drivers.

I have located all the other drivers for XP. Just need the audio. Can someone help?
0
riyc2comp
Asked:
riyc2comp
  • 3
  • 3
  • 3
  • +2
4 Solutions
 
tailoreddigitalCommented:
I just searched pretty thoroughly and it doesn't look like it's available.

This looks like it could help,

http://www.drivermanager.com/en/drivers.php?Brand=Sony&Logo=sony&gclid=CPa8kcz6ibUCFexxQgodlngA4g
0
 
dbruntonCommented:
Try Unknown Devices http://halfdone.com/ukd/

See what it returns for your sound.
0
 
☠ MASQ ☠Commented:
Looks like it should be a SigmaTel STAC 975X AC97 Sound driver
Try this XP version from Dell
ftp://ftp.dell.com/audio/R99254.EXE
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
nobusCommented:
try slimdrivers - it should find your driver : https://www.slimwareutilities.com/slimdrivers.php
0
 
riyc2compAuthor Commented:
Unfortunately none of the answers above worked. The audio driver in this model laptop remains illusive. I have tried multiple driver-search engines and they cannot find the correct one for Windows XP. I have to go forward with Windows 7 at this point.
0
 
☠ MASQ ☠Commented:
Can you post the Unknown Device PCI ID from Device Manager?
0
 
nobusCommented:
did you try slimdrivers?
and it found nothing?  post a screenshot what it found
0
 
riyc2compAuthor Commented:
Slimdrivers found a driver, but when I installed it the driver bombed. Same with some other hardware search engines (hardware helper, driver detective, etc ...) ... all found all other drivers but gave the WRONG sound driver. I just decided to re-install Windows 7. I will let you know if the sound works, I think it will because that was what was on it before I downgraded and I believe the sound was working.
0
 
nobusCommented:
you can also test if the sound - and other hardware works by running from a live cd, like Knoppix :  ftp://mirrors.kernel.org/knoppix-dvd/KNOPPIX_V7.0.4bootonly-2012-08-20-EN.iso
0
 
riyc2compAuthor Commented:
With Windows 7 re-loaded, sound driver is in and working. It was not a hardware problem. Thanks everyone but I really wish I could have figured it out. I have reservations of downgrading Sony computer products since this happened.
0
 
☠ MASQ ☠Commented:
Just an afterthought - did you install XP's UAA architecture before trying to install the SigmaTel Hi Def audio?  Some manufacturers leave the interface for Hi Def audio to Windows to sort out and without UAA the driver won't be recognised.

Downgrading newer motherboards is always going to be a risky affair if drivers aren't readily available - newer hardware means creating new drivers and as older operating systems get left behind there's no incentive for manufacturers to make those new drivers for anything other than the current versions.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now