Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Server Error in web.config

Posted on 2013-01-28
2
358 Views
Last Modified: 2013-02-04
Hi,

My web.config contains the following settings
 

 <customErrors mode="RemoteOnly" defaultRedirect="~/Errors/Default.htm">
      <error statusCode="404" redirect="~/Errors/Http404.htm"/>
    </customErrors>


Now i deployed my site in the server and the url is going to be used by Remote machine

but i am getting the following error.

============================================================================

Server Error in '/' Application.
---------------------------------

Runtime Error
 
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
======================================================================================

but if i run this url on server machine it is working fine,

So, Please suggest me what are the changes should I need to do more.
0
Comment
Question by:praveen1981
2 Comments
 
LVL 7

Accepted Solution

by:
Scobber earned 500 total points
ID: 38826001
Check your authentication schemes, on the local machine you might find that its automatically logging you on as a local user.

You might have to add the appropriate permissions (iusr and the application pool user) are a good place to start to the NTFS folder structure. you should also enable anonymous access if your expecting users to browse without logging on.

If you modify that line in web.config you will get the stack trace, if you can paste it here,if you cant work it out with those tips.
0
 

Author Closing Comment

by:praveen1981
ID: 38850168
Thanks, it is the issue with authentication
0

Featured Post

Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this Article, I will provide a few tips in problem and solution manner. Opening an ASPX page in Visual studio 2003 is very slow. To make it fast, please do follow below steps:   Open the Solution/Project. Right click the ASPX file to b…
I recently went through the process of creating a Calendar Control of events with the basis of using a database to keep track of the dates that are selectable, one requirement was to have the selected date pop-up in a simple lightbox.  At first this…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question