Solved

Folder cannot be deleted - Location is not available

Posted on 2013-01-28
6
1,525 Views
Last Modified: 2013-01-28
I have looked this up and cannot find any solution that works.

I installed a new SATA II hard drive in my desktop as an additional data drive. It is working perfectly.
I backed up all of my Steam games to this drive without any errors. My intention was to move all of the backups to an external drive afterwards. When I tried to move the backup folders (about 30) to an external drive, 2 of them won't copy. When I double click on them, I get the error "Location is not available" - "... refers to a location that is unavailable". If I try and delete these 2 folders, I get "Item not found" - "Could not find this item".
I have tried the following as per various articles on the web:
- Start Windows with last good configuration
- Try and delete from an elevated CMD
- Try and delete from Safe Mode
- Roll back to the last restore point
- Run a full check disk on the drive (drive is healthy, no errors)

I cannot remove these folders at all. I can even create folders with the exact same names in the same folder.

The only thing I can think of is that before I installed the drive (F:), drives F, G, H and I were used by USB ports on my machine. Have I perhaps interfered with Windows recognising F: as a USB device? It doesn't explain why the rest of the files and folders on the drive work fine.

Can it be a drive hardware fault or is this a known Windows issue?
0
Comment
Question by:garion1
  • 3
  • 2
6 Comments
 
LVL 5

Accepted Solution

by:
Coffinated earned 250 total points
Comment Utility
Can you try deleting from the command prompt using 8.3 file names?
Go to command promt, type "dir /x"
You will see short file names such as
filena~1.txt
filena~2.doc

next type "del filena!1.txt /F"
0
 

Author Comment

by:garion1
Comment Utility
Thanks. I will try this when I get home later.
0
 
LVL 5

Expert Comment

by:Coffinated
Comment Utility
Another option you may want to consider are:
1 Kill the explorer
•Open a command prompt
•Navigate to the location where the locked file is
•Press CTRL-ALT-DEL, click on “task manager”, select the Processes tab
•Kill the explorer.exe process via the “End Process” button
•Go back to the command prompt and delete the file
•Bring up the task manager windows again
•Select file->new task
•Type explorer.exe in the “create new task” field
•Press OK.

1. Use Unlocker
http://www.filehippo.com/download_unlocker/

3. Linux Live CD
Download Kaspersky Live CD, https://support.kaspersky.com/viruses/rescuedisk
Delete it from there

4. Check the file ownership, reset file/folder permissions and delete.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 1

Expert Comment

by:ggoodwill
Comment Utility
I have two solutions here - both third party programs but seem to work brilliantly where the standard toold don't work (both are also free).

The first I'd say to try is "File Assassin", which is actually created by the same people as MalwareBytes:
http://www.malwarebytes.org/products/fileassassin/
It doesn't require an installation, you ust download, unzip and run.

The second one, usually works better, as if it fails the delete it will try a delete during your computers next boot, before the OS launches. This is called "unlocker".
http://www.filehippo.com/download_unlocker/
This does require install, but is only a small program. You also have the option to have it running in the background (can be disabled) to monitor for any issues deleting files. If the windows explorer fails a delete, this will take over and attempt it for you instead. It also integrates with windows explorer so you can right click a file and choose to delete with unlocker. Unlocker can also deal with renaming files and moving files with similar problems.

Hope this helps!
0
 

Author Closing Comment

by:garion1
Comment Utility
Thanks Coffinated. Worked perfectly. Because they were folders, I had to use "rd filena~1 /S /Q" but you sent me in the right direction.
0
 

Author Comment

by:garion1
Comment Utility
One more note for people who have the same issue.
I tried creating the backups again and had the same issue. I noticed that the 2 problematic folders had dots and commas in the names. After deleting again, I created the backups without the punctuation and the folders are fine now.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

How can this article save you time AND money?  In just a few minutes you may discover something you didn't know existed that is easy enough for you to fix yourself!
Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now