Solved

User quota for all but one

Posted on 2013-01-28
12
623 Views
Last Modified: 2013-02-07
I need to setup a user quota across all the servers to prevent users to save large than 1gb profile. I need to exclude one service user.
so having an issue setting this for all users except one.  I might be able to do it via command line and/or script on each individual server, however that’s pretty cumbersome and isn’t easily managed.

Anyone know how to set this up to all user but exclude one?
0
Comment
Question by:Tiras25
  • 4
  • 4
  • 2
  • +1
12 Comments
 
LVL 3

Accepted Solution

by:
foxpc123 earned 100 total points
ID: 38828425
If you set the default quota for all users so that this meets your minimum requirement so that users can't save more than 1GB. Then apply this to all users.

Would it then be possible to go into that user's properties for the one user that you don't want to apply, and remove the quota from that one user - as this seems simpler as you only need to manage one user, which may be accomplished manually.

Sorry if I've missed the point there and it's not as easy as my suggestion.

Thanks

Mike
0
 
LVL 17

Author Comment

by:Tiras25
ID: 38828781
this can’t be done via group policy, and I don’t have a “user profile” tool in place to manage quotas centrally.  I didn’t have any luck setting the quota to all users, and then removing it for one user.
0
 
LVL 23

Assisted Solution

by:Erik Bjers
Erik Bjers earned 400 total points
ID: 38834263
Mike,

You can use File Server Resource Manager in 2008 to configure quotas based on user and or group so this should help you.

It has been a while since I have done this but the following links provide some good information.

http://www.simple-talk.com/sysadmin/exchange/implementing-windows-server-2008-file-system-quotas/

http://technet.microsoft.com/en-us/library/cc755603%28v=ws.10%29.aspx

eb
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38834413
I would say Set it to all Mailbox users and then Explicitly change for one Service account you want that should be it ...... OR ..... simply have the 1GB Quota on the Databases and then set to unlimited or whatever on that one Serviceaccount :)

- Rancy
0
 
LVL 17

Author Comment

by:Tiras25
ID: 38835509
File resource manager. Is this something builtin into 2008 or separate tool?
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38835595
I guess thats for Folders not Mailbox Quota

- Rancy
0
 
LVL 17

Author Comment

by:Tiras25
ID: 38836187
So with File Server Resource Manager that applies only to that specific File Server and can be enabled on that server only correct?
I need to apply to the users profiles that would apply to all the servers across Domain.

Can FSRM help in this situation?
0
 
LVL 23

Assisted Solution

by:Erik Bjers
Erik Bjers earned 400 total points
ID: 38841129
FSRM comes with 2008R2, I think MS introduced it in 2003R2, you can install it from roll and feature manager.

As far as setting a policy that goes across multiple servers I believe you can do that in Group Policy with the preference extensions they added for Wind 7 and 2008 but you are going to have to do a little research into how to implement this.  I have only used FSRM on a few servers and the policy was only local to that server.

eb
0
 
LVL 23

Assisted Solution

by:Erik Bjers
Erik Bjers earned 400 total points
ID: 38841195
Dug a little deeper and it looks like there is a command line component that can be scripted so I think you could create a script that creates the policies then run the script on each server or use a startup/ login script.

"
The FSRM command line is scriptable and remoteable. The best bet for the customer is to create command line scripts that perform the management operations on all desired machines. For convenience and flexibility, the scripts can be parametrized, making it easy to change. The following blog post provides one such example http://blogs.dirteam.com/blogs/r2/archive/2005/11/19/104.aspx
"
-http://blogs.technet.com/b/filecab/archive/2007/01/03/managing-file-server-resource-manager-quotas-on-multiple-servers.aspx

eb
0
 
LVL 17

Author Comment

by:Tiras25
ID: 38845177
NO idea how these things work.  I enabled the quota on C:\ and limited disk space to below 1GB.  Then I copied 2GB file to my desktop with no issues.  Quota entries shows 2KB amount used.  However my profile is 2GB+.   I don't think its working like its suppose to..
0
 
LVL 23

Assisted Solution

by:Erik Bjers
Erik Bjers earned 400 total points
ID: 38847264
You have a couple different quota options;

Soft quota which will only warn users if they exceed the quota
Hard quota where the system will take the action as directed by the policy

I can not sit here without looking at your system and tell you the best way to implement this, all I can do is point you to the resources above and suggest you study up.

It is likely that since your 2G+ profile existed before you implemented the quota it will remain above 2G as I am sure you do not want the system to just delete everything over 2G without asking.

Read the documentation shown above, this is really not that hard to setup once you understand how it works.

eb
0

Join & Write a Comment

OfficeMate Freezes on login or does not load after login credentials are input.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now