could not read file header for datafile 5 error reason 1

I have gotten the error "could not read file header for datafile 5 error reason 1" when trying to backup a database from RMAN, using

backup database;

Can someone help me to diagnoze and fix the issue?
LVL 35
Who is Participating?

Improve company productivity with a Business Account.Sign Up

slightwv (䄆 Netminder)Connect With a Mentor Commented:
What datafiles were added after you recovered the controlfile from your backup/recovery testing?

See if this thread helps:
slightwv (䄆 Netminder)Connect With a Mentor Commented:
Looks like a file is either missing or corrupt.

Connect to the database and post the results of the following:
select file_id, file_name from dba_data_files;

Look for the file with the file_id=5.  Make sure it is where it is supposed to be.
YZlatAuthor Commented:
I got the output


so looks like a file is missing, but how do I determine which file is missing
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

YZlatAuthor Commented:
I am not sure... Looks like all data files are there that have been there before
YZlatAuthor Commented:
when I ran the statment you posted, I got


But /u01/app/oracle/oradata/DBName/ contains one more file - tbspace1_01.dbf

So I rename thefile:

alter database rename file '/u01/app/oracle/product/' to '/u01/app/oracle/oradata/DBName/tbspace1_01.dbf';

Then I ran

recover datafile 5;

and got another error:

SQL> recover datafile 5;
ORA-00283: recovery session canceled due to errors
ORA-19909: datafile 5 belongs to an orphan incarnation
ORA-01110: data file 5: '/u01/app/oracle/oradata/DBName/tbspace1_01.dbf'
slightwv (䄆 Netminder) Commented:
Something is missing or Oracle wouldn't have created the missing0005 pointer.

I tried to locate a good reference that talks about the missing0000n filed but could not find anything decent.
slightwv (䄆 Netminder) Commented:
>>ORA-19909: datafile 5 belongs to an orphan incarnation

Check out:
YZlatAuthor Commented:
Actually looks like there are no more issues and I was able to do a backup and no files are reported as missing.

Thank you so much! You are always very helpful and I have no idea what I would do without you the past couple of months
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.