• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 868
  • Last Modified:

SSL localhost.localdomain instead of my dot com

I have pointed to the SSL certificates in the VirtualHost in httpd.conf as I have on all my web servers but in this case it's pulling localhost.localdomain instead of my dot com.

I know the httpd.conf is correct because I copied it from a working server. The ssl.conf file was also copied from working server.

I've done this many times and it's worked fine until I updated php to 5.3 from 5.1. Not sure how to proceed.
0
jasonslogan
Asked:
jasonslogan
1 Solution
 
arnoldCommented:
Usually the virtualhost that is tied to port 443 is in SSL.conf
You can only have one virtualhost that is bound to port ip:443
Can you post the configuration?
0
 
Steve BinkCommented:
>>> I know the httpd.conf is correct because I copied it from a working server

I love that statement.

Chances are, you left a default host enabled in your conf files.  As arnold pointed out, a specific IP:port combination is bound to a single certificate.  In Apache, if you have more than one certificate bound to an IP:port, Apache will use whichever it finds first.  In some default installations, Apache is pre-configured with a default SSL host, using a certificate for localhost.localdomain, and it will usually be found first unless you have taken care to disable or move it.
0
 
ahoffmannCommented:
> ..  it's pulling localhost.localdomain
can you please explain what you mean by that? best with an example URL
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now