• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5574
  • Last Modified:

Cannot attach iSCSI LUN to ESXi host

Trying to attach new iSCSI LUN to ESXi 5.1 host.
Rescan completed by gives errors :
Login to iSCSI target iqn.1984-05.com.dell:powervault.md3200i.690b11c000118d010000000050e89f17 on vmhba37
@ vmk2 failed. The iSCSI initiator could not establish a network connection to the target.
error
Login to iSCSI target iqn.1984-05.com.dell:powervault.md3200i.690b11c000118d010000000050e89f17 on vmhba37
@ vmk1 failed. The iSCSI initiator could not establish a network connection to the target.
error

In Configuration - storage adaptors  - under the datailes I can see the LUN as mounted.

When I am going to add the storage in Hardware - Storage :
Add Storage - Disk/LUN - Hignline the LUN - after a couple of mi there is an error :

Call "HostDatastoreSystem.CreateVmfsDatastore" for object "datastoreSystem-15" on vCenter Server "XXXXXX" failed.

Verified that the steps from this article are completed :
http://www.experts-exchange.com/Software/VMWare/A_9250-HOW-TO-Add-an-iSCSI-Software-Adaptor-and-Create-an-iSCSI-Multipath-Network-in-VMware-vSphere-Hypervisor-ESXi-5-0.html


Thanks for the help
0
Vasilax50
Asked:
Vasilax50
  • 4
  • 2
3 Solutions
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
check your MD3200i firmware is at least

07.84

is this a new LUN?

can you ping and vmkping the MD3200i?

from a Windows computer, can you connect by telnet to:-

telnet <ip address of md3200i> 3260

you have checked the IP address and target IP address and port number is correct 3260?

can you upload a screenshot of the storage adaptors with LUN showing?

I'm rather puzzles, because you state the LUN is mounted, but yet, iSCSI software initiator confirms a connection error?

do you have any chap settings specified?

do you have any ACL restrictions, permissions assigned to the LUN?

at present I would keep the config, very simple, and just try a single iSCSI initiator, single nic.
0
 
Vasilax50Author Commented:
The firmware is 07.84
this is a new LUN on a new MD3220i
Can ping and vmkping
Can telnet
Both IPs and port are Ok - 3260
Screenshots attached
If I use hardware
Right now I can only connect ESXi host to MD3220 through Broadcom NIC's hardware iscsi TOE drive,however that won't allow me to config NIC teaming for more throughput and failover.
No authentication enabled
No permissions or ACL on LUN...

Thanks
Error MessageAdding LUNStorage Adaptors
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if you have connected using Broadcom NIC's, have you checked, permission allocation, e.g. IP Address, IQN, or hostname?

network connectivity is correct.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Vasilax50Author Commented:
Yes, everything is double checked...
0
 
Vasilax50Author Commented:
Just figured out that there were jumbo frames enabled on Vswitch, but no jambo frames enabled on the physical switch.
Switching back the values to 1500 fixed the problem.
Still do not understand why when the LUN was connected using physical NICs, the jumbo frames weren't the issue...

Anyway, thank you for all the suggestions and help hanccocka
0
 
Vasilax50Author Commented:
With the help of hanccocka was able to find the problem
0

Featured Post

[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now